View Issue Details

IDProjectCategoryView StatusLast Update
0016124ScribusBuild Systempublic2020-08-11 20:56
Reporteroliverthered Assigned Tojghali  
PriorityurgentSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Platformia64OSwindowsOS Version10
Product Version1.5.6.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0016124: Add support for visual studio 2019
Descriptionadd support for visual studio 2019
Additional Informationzip file containing the new files needed for vs2019 attached.
Tagspatch, vs2019, windows10
PatchYes

Activities

oliverthered

2020-06-03 10:29

reporter  

vs2019-support.zip (419,273 bytes)

oliverthered

2020-06-03 10:59

reporter   ~0047658

as i remember harfbuzz couldn't find icu-65.1

lib files that needs updating from scribus-1.5.x-libs-msvc2017:
copy-dlls-to-build-dir.bat
scribus-lib-paths.props
scribus-libs-msvc2017.sln and needs renaming
cairo-1.16.0\cairo-win32.vcxproj
harfbuzz-2.6.4\harfbuzz.vcxproj
harfbuzz-2.6.4\harfbuzz.vcxproj.filters
harfbuzz-2.6.4\harfbuzz.vcxproj.user
podofo-0.9.5\podofo.vcxproj
libzmf-0.0.2\libzmf.vcxproj
libvisio-0.1.7\libvisio.sln
libtiff-4.1.0\libtiff5.vcxproj
libcdr-0.1.6\libcdr.vcxproj
libfreehand-0.1.2\libfreehand.vcxproj
libmspub-0.1.4\libmspub.vcxproj
libxml2-2.9.10\libxml2.vcxproj
libpagemaker-0.0.4\libpagemaker.vcxproj
libqxp-0.0.2\libqxp.vcxproj
libiconv-1.15\libiconv_dll.vcxproj
libjpeg-9c\libjpeg-9c.vcxproj
librevenge-0.0.4\librevengestream.vcxproj
librevenge-0.0.4\librevengegenerators.vcxproj
openssl-1.1.1f\libcrypto.vcxproj
poppler-0.87.0\poppler.vcxproj


files in scribus-common-libs that need updating:
copy-python3-to-15x-build-dir.bat
scribus-common-lib-paths.props
boost-1.70.0\bootstrap.bat
boost-1.70.0\bin.v2\project-cache.jam
boost-1.70.0\bin.v2\standalone\msvc\msvc-14.2\msvc-setup.bat
boost-1.70.0\bin.v2\standalone\msvc\msvc-14.2\address-model-64\architecture-x86\msvc-setup.bat

oliverthered

2020-06-03 11:00

reporter   ~0047659

visual studio internal version number needs to be updated in those files.

oliverthered

2020-06-03 11:07

reporter   ~0047660

version needs updating to v142 I believe

oliverthered

2020-06-03 14:23

reporter   ~0047661

i'm having some issues with the vs2019 build files. first some of the files in the project had been deleted or added and secondly it looks like the version of QT being used in head is newer than the one I have. I hope those are the only two issues

i'll attach an updated zip as soon as the issue is resolved

oliverthered

2020-06-03 15:28

reporter   ~0047663

i have verified that this version of vs2019 project files loads, compiles and runs

msvc2019.rar (346,937 bytes)

jghali

2020-06-04 22:32

administrator   ~0047674

Thanks. As a bonus, I have uploaded a new dependency package for msvc 2019 on sourceforge.

Issue History

Date Modified Username Field Change
2020-06-03 10:29 oliverthered New Issue
2020-06-03 10:29 oliverthered Tag Attached: patch
2020-06-03 10:29 oliverthered Tag Attached: vs2019
2020-06-03 10:29 oliverthered Tag Attached: windows10
2020-06-03 10:29 oliverthered File Added: vs2019-support.zip
2020-06-03 10:35 ale Steps to Reproduce Updated View Revisions
2020-06-03 10:35 ale Additional Information Updated View Revisions
2020-06-03 10:59 oliverthered Note Added: 0047658
2020-06-03 11:00 oliverthered Note Added: 0047659
2020-06-03 11:07 oliverthered Note Added: 0047660
2020-06-03 14:23 oliverthered Note Added: 0047661
2020-06-03 15:28 oliverthered File Added: msvc2019.rar
2020-06-03 15:28 oliverthered Note Added: 0047663
2020-06-04 22:14 jghali Summary support for visual studio 2019 => Add support for visual studio 2019
2020-06-04 22:32 jghali Assigned To => jghali
2020-06-04 22:32 jghali Status new => resolved
2020-06-04 22:32 jghali Resolution open => fixed
2020-06-04 22:32 jghali Fixed in Version => 1.5.6.svn
2020-06-04 22:32 jghali Note Added: 0047674
2020-08-11 20:56 cbradney Status resolved => closed