View Issue Details

IDProjectCategoryView StatusLast Update
0016181ScribusStory Editor / Text Framespublic2020-08-19 11:56
Reporterale Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status newResolutionopen 
Product Version1.5.6.svn 
Summary0016181: PATCH: refactor the anchor mark out of scribus.h
Description- create a marks directory for the whole code for the marks.
- refactor the anchor out of ScribusMainWindow::insertMarkDialog().
- as soon as the code is reviewed and merged, i plan to also refactor the other types of marks and move them to the marks directory.
- the CMakeLists in marks is inspired by the one in styles/.
- ScribusMainWindow::editMarkDlg() should also be refactored out. i first wait for the concept to be accepted.
- instead of the inheritance to a main Marks class, i'm using a utils static class: most of the code in there is not specific to the marks and it might be useful to see it moved to ScribusDoc or ScribusView once the whole refactoring is finished.
- in the future more code should move to specific directories and i hope that one day scribus.cpp (and the other main classes) will get a bit slimmer...

https://gitlab.com/scribus/scribus/-/merge_requests/23
TagsNo tags attached.
PatchYes

Activities

ale

2020-07-20 19:19

manager  

anchor-refactoring.diff (10,638 bytes)   

jghali

2020-07-20 21:34

administrator   ~0047860

I cannot review this patch as it is incomplete. The marks/anchor.h file and probably others are missing.

jghali

2020-07-20 21:43

administrator   ~0047862

>> Instead of the inheritance to a main Marks class, i'm using a utils static class

Hmmm, when I'm reading this I become pretty skeptic.

ale

2020-07-21 07:25

manager   ~0047863

Last edited: 2020-07-21 07:38

ooops, yes, i haven't uploaded the two files and it was too late to wait for the CI to finish... sorry.

here is the complete diff.

anchor-refactoring-02.diff (13,547 bytes)   

ale

2020-07-21 09:23

manager   ~0047866

concerning the static functions:

currently two of them should go to scribusdoc (get a frame if some conditions are met; i have a few ideas to be discussed and tested on how to make them more general) and the third one to pageitem (refresh the document around a page item).
and, of course, they should not be static there.

those are boilerplate that is repeated over and over in scribus and imo distract from the actual logic of the code.
at the end there might be no Utils class at all (and i plan to rename it to Marks::Marks anyway).

ale

2020-07-21 15:13

manager   ~0047867

new patch that takes into consideration craig's concern and a few other things i've noticed or have been discussed.

please see the commits in the gitlab merge request for the details.
marks-refactoring-03.diff (13,698 bytes)   

cbradney

2020-08-11 20:55

administrator   ~0047923

This seems to replace just the code for Anchors. Are you planning on something similar for VariableText/Item/Notes?

ale

2020-08-12 07:13

manager   ~0047924

obviously yes, @cbradney . this is how i plan to do it for all marks.

but before going on i need an ok on the way it is done and, if possible the code being merged so that i can continue my work on the pdf bookmarks without fearing big merge conflicts.

jghali

2020-08-18 16:37

administrator   ~0047963

Last edited: 2020-08-18 16:38

1) please remove "namespace Marks" stuff, it's useless
2) I don't like api such as "bool Anchor::insert(PageItem_TextFrame* textFrame, QString& label)", it is the Anchor which is inserted into text frame so should be something like bool PageItem_TextFrame::insert(Anchor* anchor, QString& label)
3) The undo stuff in Anchor::insert() is incorrect as any call of UndoManager::beginTransaction() must be balanced by a call to UndoManager::commit(). The first call to beginTransaction() in particular should receive as arguments the user description of the undo action. The second call to beginTransaction() in the "if (textFrame->HasSel)" block is then useless. Move trans.commit() out of if (undoManager->undoEnabled()) block and replace by "if (trans) trans.commit()".

ale

2020-08-18 17:10

manager   ~0047966

Last edited: 2020-08-18 17:13

1/ of course, namespaces are basically useless.
    but i would welcome it, if every class that is in a directory uses the namespaces as a prefix.
   in this way, one knows that Marks/Anchor is to be found in marks/anchor.h
   the alternative is to rename the class to MarksAnchor as it's otherwise done in scribus. but is it really better?

2/ on the one side i agree with you. it's about the text frame.
     on the other side the code in insert is very specific to the anchor mark.
    and one of the main ideas behind having a directory dedicated to the marks is to separate it from the rest of the code.
   as an example it might allow creating a new type of mark and being and easily all or most of the spots to be changed.
   another beneficial effect of this approach, is that some files with lot of code can be made a bit slimmer.

3/ ok, i'll try to fix it.
  since the undo manager seams to be a part of the code where many error happens, it would be nice to have a documentation on it.
  as an example: how should the user description be composed (if it's not there, i fear that it was not in the original code).

cbradney

2020-08-18 18:31

administrator   ~0047967

I see where Jean is coming from with this comment:
2) I don't like api such as "bool Anchor::insert(PageItem_TextFrame* textFrame, QString& label)", it is the Anchor which is inserted into text frame so should be something like bool PageItem_TextFrame::insert(Anchor* anchor, QString& label)

However, I would prefer that all the Marks code is in that one directory.

jghali

2020-08-18 18:55

administrator   ~0047968

4) Do not re-use the marks.h/cpp file names, there is already files with such names in Scribus/scribus directory. That will prevent compilation with MSVC.

ale

2020-08-18 19:28

manager   ~0047970

jean, are you sure that msvc cannot compile files with the same name but in different directories?

that would remove much of the benefit of using namespaces!
namespaces exist to avoid clashes in the class names but, i think, also for file names.

and it also reduces a small bit the advantage of having multiple sub directories.

anyway, this is just a question of principle, since at the end of the refactoring scribus/marks.h/.cpp will disappear and go into marks/ .

p.s.: is it this problem?
https://stackoverflow.com/questions/9351132/two-files-of-the-same-name-give-linker-error-in-visual-studio

cbradney

2020-08-18 20:42

administrator   ~0047971

MSVC is daft

jghali

2020-08-18 20:59

administrator   ~0047972

>> jean, are you sure that msvc cannot compile files with the same name but in different directories?

Yes.

>> namespaces exist to avoid clashes in the class names but, i think, also for file names.

No, namespaces do not prevent in any way clashes of file names.

>> anyway, this is just a question of principle, since at the end of the refactoring scribus/marks.h/.cpp will disappear and go into marks/ .

I think your Marks class is badly named anyway as it does not represent any kind of mark. MarkHelper or MarksHelper would probably be better. Then your marks.h/cpp would have to be renamed mark(s)helper.h/.cpp and problems goes away. Same for your Anchor class btw, I think AnchorHelper would be more suited.

jghali

2020-08-18 21:03

administrator   ~0047973

>> as an example: how should the user description be composed (if it's not there, i fear that it was not in the original code)

You have plenty of example of use of UndoManager::beginTransaction() in our source code. You may have to add proper Action string(s) to UndoManager class.

jghali

2020-08-18 21:35

administrator   ~0047974

Btw, with that Anchor to AnchorHelper renaming, my point 2. would become moot.

ale

2020-08-19 05:55

manager   ~0047976

https://en.wikipedia.org/wiki/Helper_class

are you sure?

the main goal of the Anchor class is to implement the Anchor functionality.

jean, i'm not trying to nitpick but i'd lke to find a solution that can be used in future code of scribus to improve the readability of the code and help new contributors improve existing features and add new ones.
by having sets of files that implement a feature, in their own directories, with a manageable length (and possibly a doc at their beginning or a README file in there).

concerning the file names in msvc: i tried an internet search for the file name conflict, but i could not find that many references (very few indeed).
if there was no solution, i guess that there should be many more results!
i've pasted above a stackoverflow question and answer that could describe the error you're facing and i'd like to know if this is the issue and if you have tried the solution suggested in the post.

this must be a common issue when you pull in external modules... every programmer creates a utility.h file...
i can't think that there is no solution.

(and yes namespaces help also go get nicer file names: it's a common pattern to use the class name as a file name and the directory name for the namespace: MarksAnchor.cpp becomes Marks/Anchor.cpp ... which is nicer than Marks/MarksAnchor.cpp if you want to use directories and unique filenames / class names)

jghali

2020-08-19 11:56

administrator   ~0047978

>> are you sure?

Yes, I'm sure. Your Anchor class does not represent an anchor as it does not have any data which would make it so. It has only functions. An Anchor is already represented by a Mark object of type MARKAnchorType.

Issue History

Date Modified Username Field Change
2020-07-20 19:19 ale New Issue
2020-07-20 19:19 ale File Added: anchor-refactoring.diff
2020-07-20 21:34 jghali Note Added: 0047860
2020-07-20 21:43 jghali Note Added: 0047862
2020-07-21 07:25 ale File Added: anchor-refactoring-02.diff
2020-07-21 07:25 ale Note Added: 0047863
2020-07-21 07:38 ale Note Edited: 0047863
2020-07-21 09:23 ale Note Added: 0047866
2020-07-21 15:13 ale File Added: marks-refactoring-03.diff
2020-07-21 15:13 ale Note Added: 0047867
2020-08-11 20:55 cbradney Note Added: 0047923
2020-08-12 07:13 ale Note Added: 0047924
2020-08-18 16:37 jghali Note Added: 0047963
2020-08-18 16:37 jghali Note Edited: 0047963
2020-08-18 16:38 jghali Note Edited: 0047963
2020-08-18 17:10 ale Note Added: 0047966
2020-08-18 17:11 ale Note Edited: 0047966
2020-08-18 17:13 ale Note Edited: 0047966
2020-08-18 18:31 cbradney Note Added: 0047967
2020-08-18 18:55 jghali Note Added: 0047968
2020-08-18 19:28 ale Note Added: 0047970
2020-08-18 20:42 cbradney Note Added: 0047971
2020-08-18 20:59 jghali Note Added: 0047972
2020-08-18 21:03 jghali Note Added: 0047973
2020-08-18 21:35 jghali Note Added: 0047974
2020-08-19 05:55 ale Note Added: 0047976
2020-08-19 11:56 jghali Note Added: 0047978