View Issue Details

IDProjectCategoryView StatusLast Update
0016195ScribusUser Interfacepublic2020-08-11 20:56
Reporterale Assigned Toale  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.6.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0016195: Clicking the RTL button does not give any visual feedback
Descriptionwhile all other buttons get darker when clicked, the RTL one stays the same and it's hard to tell which direction is now active.
TagsNo tags attached.
PatchYes

Activities

cbradney

2020-08-05 20:50

administrator   ~0047903

They do here.. tested on OSX and on Ubuntu 20.04

jghali

2020-08-06 00:01

administrator   ~0047905

They do on Windows too.

ale

2020-08-06 07:03

manager   ~0047906

you can see in the animated gif in 0016201 that on my computer they don't work correctly.

i had a closer look at the icons: they have a white background which interferes with the ability of qt to highlight the buttons.
they also have a border drawn around them, which will double the border drawn by qt around the tool buttons.

i'm attaching a new version of the icons, with the background and the border removed.
now the rtl/ltr icons behave just like in the align buttons next to them.
(they still stick out, because they have more grey tones than the other, but i'll let an icon designer fix that part...)

text-direction-ltr.png (2,323 bytes)
text-direction-ltr.png (2,323 bytes)
text-direction-rtl.png (2,317 bytes)
text-direction-rtl.png (2,317 bytes)

ale

2020-08-06 07:05

manager   ~0047907

the dark mode icons do not have a background but also have an additional border. here a version without the borders.

text-direction-ltr-2.png (1,788 bytes)
text-direction-ltr-2.png (1,788 bytes)
text-direction-rtl-2.png (1,591 bytes)
text-direction-rtl-2.png (1,591 bytes)

ale

2020-08-06 07:11

manager   ~0047908

since the dark mode icon already already has a single gray version, i've made icons for the "normal" mode that matches the other "black and white" icons in use in scribus.

i don't have the feeling that they are perfect (i "can't" test the dark mode ones to see if they are better) but you might want use these ones instead of the first two i've posted.

text-direction-ltr-3.png (1,781 bytes)
text-direction-ltr-3.png (1,781 bytes)
text-direction-rtl-3.png (1,608 bytes)
text-direction-rtl-3.png (1,608 bytes)

ale

2020-08-06 17:47

manager   ~0047910

thanks

Issue History

Date Modified Username Field Change
2020-07-29 09:22 ale New Issue
2020-08-05 20:50 cbradney Note Added: 0047903
2020-08-06 00:01 jghali Note Added: 0047905
2020-08-06 07:03 ale File Added: text-direction-ltr.png
2020-08-06 07:03 ale File Added: text-direction-rtl.png
2020-08-06 07:03 ale Note Added: 0047906
2020-08-06 07:05 ale File Added: text-direction-ltr-2.png
2020-08-06 07:05 ale File Added: text-direction-rtl-2.png
2020-08-06 07:05 ale Note Added: 0047907
2020-08-06 07:11 ale File Added: text-direction-ltr-3.png
2020-08-06 07:11 ale File Added: text-direction-rtl-3.png
2020-08-06 07:11 ale Note Added: 0047908
2020-08-06 11:06 ale Summary clicking the RTL button does not give any visual feedback => [PATCH]: clicking the RTL button does not give any visual feedback
2020-08-06 11:06 ale Patch No => Yes
2020-08-06 16:09 jghali Summary [PATCH]: clicking the RTL button does not give any visual feedback => Clicking the RTL button does not give any visual feedback
2020-08-06 16:10 jghali Assigned To => ale
2020-08-06 16:10 jghali Status new => resolved
2020-08-06 16:10 jghali Resolution open => fixed
2020-08-06 16:10 jghali Fixed in Version => 1.5.6.svn
2020-08-06 17:47 ale Note Added: 0047910
2020-08-11 20:56 cbradney Status resolved => closed