View Issue Details

IDProjectCategoryView StatusLast Update
0016199ScribusUsabilitypublic2020-08-25 05:28
ReporterAMDphreak Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version1.5.5 
Target VersionFixed in Version 
Summary0016199: Tool panels cover up non-scribus application windows
DescriptionWhen a tool panel is open and I switch to another application, that tool panel covers up my other applications. This means I have to close the panel and reopen it EVERY TIME I ALT TAB BETWEEN APPLICATIONS.

This is idiotic behavior from a program that is completely avoidable by selecting the CORRECT window interaction behavior. How could you let this through your testing and quality control? Do any of you actually use the software you claim to develop?

Getting real sick of having to report obvious bugs like this in open source projects.
Steps To ReproduceUse brain
Voila
TagsNo tags attached.
PatchNo

Activities

AMDphreak

2020-07-30 17:45

reporter  

jghali

2020-07-30 19:23

administrator   ~0047892

Unable to reproduce on Windows 10, MacOS, LinuxMint 19.3 / 20.0, OpenSuse Tumbleweed and Ubuntu 20.04. It seems your issue comes from your windows manager.

ale

2020-07-31 06:14

manager   ~0047896

Last edited: 2020-07-31 08:41

View 2 revisions

i can reproduce here but it's also what i would expect to happen.

i've tried to replicate with gimp or inskape and i noticed a big difference: the other applications, by default show the non modal dialogs as docked.

the main problem i see is that by default scribus does not dock dialogs that are supposed to stay for a long time on the screen.
and it does not provide a good way to manage a big number of docked dialogs.

again, i've been working on this topic but patches have been waiting for a review for many months now.

in your case, just dock the palettes to the right side and your issue is solved.

jghali

2020-08-06 23:37

administrator   ~0047913

I did some tests using Fedora's GNOME. I couldn't reproduce this issue either in this environment.

AMDphreak

2020-08-08 06:25

reporter   ~0047915

It is also applicable to the Windows release. It applies to the stable release and testing 1.5.5 release.

AMDphreak

2020-08-08 06:29

reporter   ~0047916

"can reproduce but it's also what i would expect to happen."
I think you're confusing this behavior with something localized to the parent application. I'm talking about the modal dialogs on top--all the time---in every program I use. It should be on top whenever I have Scribus focused, not when it's been minimized or lost focus due to selecting another app's window. This is very peculiar behavior for any app. The only apps that typically use this behavior are system/task manager apps or some kind of resource monitor where you specifically want it to be visible at all times.

jghali

2020-08-08 13:10

administrator   ~0047919

>> It is also applicable to the Windows release.

Well I'm mostly using Windows and I can't reproduce this issue on Windows at all.

jghali

2020-08-25 00:46

administrator   ~0047998

Last edited: 2020-08-25 01:33

View 3 revisions

In the end, it seems to be an issue which is distro specific and affects at least Pop!OS:
https://www.reddit.com/r/pop_os/comments/gmbv8c/modal_dialogs_always_on_top_is_this_a_bug/

We correctly specify tool panels as tool windows. If some distros decide to make tool windows always on top by default, there is unfortunately nothing we can do on our side. This has to be fixed at the distro level.

ale

2020-08-25 05:28

manager   ~0048000

there is more coming...

https://askubuntu.com/questions/1268639/scribus-property-window-doesnt-move-expectedly

Issue History

Date Modified Username Field Change
2020-07-30 17:45 AMDphreak New Issue
2020-07-30 17:45 AMDphreak File Added: Screenshot from 2020-07-30 12-44-17.png
2020-07-30 19:23 jghali Note Added: 0047892
2020-07-30 19:23 jghali Severity major => minor
2020-07-30 19:23 jghali Priority immediate => normal
2020-07-31 06:14 ale Note Added: 0047896
2020-07-31 08:41 ale Note Edited: 0047896 View Revisions
2020-08-06 23:37 jghali Note Added: 0047913
2020-08-08 06:25 AMDphreak Note Added: 0047915
2020-08-08 06:29 AMDphreak Note Added: 0047916
2020-08-08 13:10 jghali Note Added: 0047919
2020-08-25 00:46 jghali Assigned To => jghali
2020-08-25 00:46 jghali Status new => resolved
2020-08-25 00:46 jghali Resolution open => no change required
2020-08-25 00:46 jghali Note Added: 0047998
2020-08-25 00:46 jghali Note Edited: 0047998 View Revisions
2020-08-25 00:46 jghali Status resolved => closed
2020-08-25 01:33 jghali Note Edited: 0047998 View Revisions
2020-08-25 05:28 ale Note Added: 0048000