View Issue Details

IDProjectCategoryView StatusLast Update
0016210ScribusScripterpublic2020-08-14 06:01
Reporterale Assigned Tojghali  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.5.6.svn 
Summary0016210: Provide a way to get the current script path
Descriptionis there a way to get the full path to the current script?

i could not find one...
TagsNo tags attached.
PatchNo

Activities

jghali

2020-08-14 02:50

administrator   ~0047930

The current script path is usually provided in Python by __file__ variable. Due to our use of an embedded python interpreter, this variable is however not defined. I've done the necessary modifications so that this variable gets defined when running an external script.

ale

2020-08-14 06:01

manager   ~0047934

thanks!

Issue History

Date Modified Username Field Change
2020-08-13 08:28 ale New Issue
2020-08-14 02:50 jghali Note Added: 0047930
2020-08-14 02:50 jghali Summary provide (or document) a way to get the current script path => Provide a way to get the current script path
2020-08-14 02:51 jghali Assigned To => jghali
2020-08-14 02:51 jghali Status new => resolved
2020-08-14 02:51 jghali Resolution open => fixed
2020-08-14 02:51 jghali Fixed in Version => 1.5.6.svn
2020-08-14 06:01 ale Note Added: 0047934