View Issue Details

IDProjectCategoryView StatusLast Update
0016215Infrastructure[All Projects] Generalpublic2020-08-22 17:11
Reporterale Assigned Toltning  
PriorityurgentSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Summary0016215: posting to the forum is broken
Descriptioni tried to post to the forum and i got the error:

Field 'ua_os' doesn't have a default value
File: /usr/local/www/forums.scribus.net/forums/Sources/Subs-Post.php
Line: 1816

somebody else wrote me a private message (so parts of it do work...) and reported a general "database error"...
TagsNo tags attached.

Activities

ale

2020-08-15 10:48

manager   ~0047939

... and now the forum is completely out of order...

ale

2020-08-16 07:21

manager   ~0047940

yesterday, i've tried to add a warning to the template (index.template.php ?) and during the editing all broke.

not sure if it is related to the editing.

jghali

2020-08-16 10:54

administrator   ~0047941

>> not sure if it is related to the editing.

The webpage indicates a syntax error so it may well be related to the editing.

ale

2020-08-16 16:04

manager   ~0047943

somebody with ssh access can try to access that file...

btw, the forum has been broken for some time, but nobody (else) reported.

cbradney

2020-08-16 16:18

administrator   ~0047944

Sent an email to Eirik, I have no login for that host.

ale

2020-08-16 17:46

manager   ~0047950

btw, i'm not aware of having added a \...

it was something like echo("

It's currently not possible to post to this forum

");

... mmm, it's unlikely that i've typed <\p>... but it's not impossible...

cbradney

2020-08-16 21:29

administrator   ~0047951

I'm not sure where you would have put that text anyway? I cannot even get to the server to change this.

ale

2020-08-17 06:15

manager   ~0047952

i can't login anymore.

but i got into a demo forum and it is in:

configuration > themes and layout > modify themes > Browse the templates and files in this theme > index.template.php

i've tried to modifiy template_body_above() by adding an echo()

i've done the same thing in the demo instance, and the test text shows up on the main page.

if the error is related to my change, now that i redid the whole process, i think that the most likely error would be a missing ;...

Luna Nightshade

2020-08-21 12:48

reporter   ~0047981

As to the original error - that usually appears after a database upgrade. The database wants a value for a field that is not provided and there is no default value given - changing the database to have a default value there - or modifying the php code to provide the value will get rid of that error.

As to the new error ... I think backslashes are only used for Namespaces (which I do not know too much about) and usually not anywhere outside the code.

A '

' is usually part of HTML and not of PHP, and thus that as the error is unlikely - unless it is written outside of strings, or echoes or anything that is supposed to be send out to the user.

That said, it is the first time I have seen the Namespace error - if anyone can ... find the backslash in the code - it probably doesn't belong there.

ale

2020-08-22 07:36

manager   ~0047982

the templates are php files.

if the second error is related to my editing, than the most likely cause is a missing " which then makes a \" to be read outside of the string context.
on my keyboard it is unlikely that a \ drops in by error and i don't recall to have escaped anything.

... if it's related to my editing... no idea, since i cannot check.

dl

2020-08-22 10:21

reporter   ~0047983

I have just joined this list (and mailing list) to understand why the Scribus forum has been broken for so long. Much useful information in the forum is lost.
To help my understanding .. as an outsider with no knowledge of the server structure .. is per chance Drupal used for the forum?

ale

2020-08-22 12:28

manager   ~0047984

no, it's a simplemachines forum.

there are there issue that are open:

1. getting into the server.
2. find out if the template i have edited is broken.
3. find out why it is impossible to post.

we are stuck at 1. and until that is not solved, there is nothing that can be done.

dl

2020-08-22 13:21

reporter   ~0047985

On trying again I see that the server is back up. I was trying contact with site administrator through whois > GoDaddy a few minutes earlier. Coincidence I guess. I see that workpress is in use,

ale

2020-08-22 13:57

manager   ~0047986

hi dl

"we" fixed it...

craig got the admin on the line and

- indeed i've made an error while editing the template online (i won't do that anymore, promised!)
- we could find the table to be fixed and fix it.

the forum is up and running again.

Issue History

Date Modified Username Field Change
2020-08-15 09:20 ale New Issue
2020-08-15 10:48 ale Note Added: 0047939
2020-08-16 07:21 ale Note Added: 0047940
2020-08-16 10:54 jghali Note Added: 0047941
2020-08-16 16:04 ale Note Added: 0047943
2020-08-16 16:18 cbradney Note Added: 0047944
2020-08-16 17:46 ale Note Added: 0047950
2020-08-16 21:29 cbradney Note Added: 0047951
2020-08-17 06:15 ale Note Added: 0047952
2020-08-21 12:48 Luna Nightshade Note Added: 0047981
2020-08-22 07:36 ale Note Added: 0047982
2020-08-22 10:21 dl Note Added: 0047983
2020-08-22 12:28 ale Note Added: 0047984
2020-08-22 13:21 dl Note Added: 0047985
2020-08-22 13:57 ale Assigned To => ltning
2020-08-22 13:57 ale Status new => resolved
2020-08-22 13:57 ale Resolution open => fixed
2020-08-22 13:57 ale Note Added: 0047986
2020-08-22 17:11 jghali Project Scribus => Infrastructure
2020-08-22 17:11 jghali Category Website => General