View Issue Details

IDProjectCategoryView StatusLast Update
0016240ScribusScripterpublic2020-09-16 06:32
Reporterale Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.5.6.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0016240: pasteObject always returns null but the docstring promises a text
Descriptionit would indeed be handy if pasteObject could return the name of the newly created object.
you mostly need to do something with the paste item...

... if this is not wished, the docstring should be fixed...
TagsNo tags attached.
PatchNo

Activities

jghali

2020-09-14 08:34

administrator   ~0048049

>> it would indeed be handy if pasteObject could return the name of the newly created object.

And if there are multiple created objects?

ale

2020-09-14 13:45

manager   ~0048053

than you add an "s":

"it would indeed be handy if pasteObject could return the name of the newly created objects."

since the pasted objects are selected, it's not a must. there is an "easy" workaround.

but at least the docstring should be fixed.

ale

2020-09-16 06:32

manager   ~0048077

thanks!

if i understand your patch correctly, it's now returning a comma separated string of item names.
i'd lke to check if it's not just as easy to return a real list of strings... in the case somebody decides that it's cool to put a comma in an item name...

Issue History

Date Modified Username Field Change
2020-09-14 08:22 ale New Issue
2020-09-14 08:34 jghali Note Added: 0048049
2020-09-14 13:45 ale Note Added: 0048053
2020-09-15 21:21 cbradney Assigned To => cbradney
2020-09-15 21:21 cbradney Status new => resolved
2020-09-15 21:21 cbradney Resolution open => fixed
2020-09-15 21:21 cbradney Fixed in Version => 1.5.6.svn
2020-09-16 06:32 ale Note Added: 0048077