View Issue Details

IDProjectCategoryView StatusLast Update
0016342ScribusGeneralpublic2020-11-17 14:58
ReporterDavidGDFC Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
PlatformPCOSWindows VistaOS Versionx86
Product Version1.5.6 
Target VersionFixed in Version 
Summary0016342: This application failed to start because no Qt platform plugin could be initialized
DescriptionHi!

This is my first message on this forum and I hope to get it right. I’ve known Scribus for a while, but it wasn’t until now that I’ve decided to learnt how to use it.

I’ve just installed Scribus 1.5.6.1 (x86) on Windows Vista and, whenever I want to open the programme, I get the following message: “This application failed to start because no Qt platform plugin could be initialized”.

There was no previous installation of Scribus on my PC. I’ve tried to Google the issue, but I really don’t know what to do.

Thanks in advance.
TagsNo tags attached.
PatchNo

Activities

jghali

2020-11-16 23:33

administrator   ~0048442

I doubt latest version of Scribus will work on Windows Vista. The Qt toolkit version we use was recently upgraded and the new version does not support Windows Vista officially anymore (here that means it may still work, but it may also not).

DavidGDFC

2020-11-17 08:58

reporter   ~0048445

Thank you for your reply. I was afraid that was the reason, but since the web said Windows Vista was supported, I gave it a try. I'm only using Vista temporarily, so I'll install it again once I have my new PC with Windows 10.

DavidGDFC

2020-11-17 10:00

reporter   ~0048446

Hi again!

Just to let you know that, despite some error messages regarding kernell32.dll, importpub.dll and importcdr.dll, version 1.5.5 does open on Windows Vista.

jghali

2020-11-17 11:28

administrator   ~0048447

Yes, maybe, but as I've said we have upgraded one of Scribus main component in 1.5.6 and that component does not support Windows Vista officially anymore. Unfortunately I can hardly perform any test on that system as it is now difficult to have an "up-to-date" Vista system, even in a virtual machine, due to issues affecting the Windows Update component in Vista SP2 images (cannot install updates which would be required to run Scribus due to Windows update searching updates for hours).

DavidGDFC

2020-11-17 11:33

reporter   ~0048448

That's OK: I understand Vista is too old anyway. I'll stick to version 1.5.5 for the moment. Thanks anyway!

jghali

2020-11-17 14:47

administrator   ~0048452

I removed mentions of Windows Vista (and XP!) on download page for our development branch. When we'll release 1.5.7, the installer will also error out if user tries to install Scribus on such an old system.

Issue History

Date Modified Username Field Change
2020-11-16 21:36 DavidGDFC New Issue
2020-11-16 23:28 jghali Priority high => normal
2020-11-16 23:33 jghali Note Added: 0048442
2020-11-16 23:38 jghali Product Version => 1.5.6
2020-11-16 23:55 jghali Severity block => major
2020-11-17 08:58 DavidGDFC Note Added: 0048445
2020-11-17 10:00 DavidGDFC Note Added: 0048446
2020-11-17 11:28 jghali Note Added: 0048447
2020-11-17 11:33 DavidGDFC Note Added: 0048448
2020-11-17 14:47 jghali Assigned To => jghali
2020-11-17 14:47 jghali Status new => resolved
2020-11-17 14:47 jghali Resolution open => won't fix
2020-11-17 14:47 jghali Note Added: 0048452
2020-11-17 14:58 jghali Status resolved => closed