View Issue Details

IDProjectCategoryView StatusLast Update
0016421Scribus3rd Partypublic2021-01-10 18:27
ReporterPeterBenedek Assigned Toale  
PrioritylowSeverityfeatureReproducibilitysometimes
Status closedResolutionfixed 
Platformx64OSLinux MintOS Version20 (64bit)
Product Version1.5.7.svn 
Target VersionFixed in Version 
Summary0016421: Scribus appimage doesn't building in GitLab
DescriptionGitlab doesn't build a Scribus appimage since 03.01.2021 (Pipeline: failed)
Web page: https://gitlab.com/scribus/scribus/commits/master

The last working version was built: 03.01.2021
The version built on the 04.01.2021 crashes on startup.

Can anyone deal with this fault? A.l.e unfortunately stopped contributing to scribus around mid november.
TagsNo tags attached.
PatchNo

Activities

JLuc

2021-01-09 15:39

developer   ~0048661

https://gitlab.com/scribus/scribus/-/jobs/947330847 says "W: GPG error: https://apt.kitware.com/ubuntu bionic InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY DE19EB17684BA42D - E: The repository 'https://apt.kitware.com/ubuntu bionic InRelease' is not signed."...

ale

2021-01-09 17:09

manager   ~0048662

if somebody wants to work on it, please get in touch with me.
or simply make a pull request for https://gitlab.com/scribus/scribus-ci-docker if the issue is in there.

jghali

2021-01-09 20:59

administrator   ~0048663

As far as I understand, it might just be needed to rebuild the docker image. The key retrieved from https://apt.kitware.com/keys/kitware-archive-latest.asc is just too old in current image and has to be updated.

ale

2021-01-10 17:30

manager   ~0048665

i did run again the docker pipeline then the scribus one.

the scribus pipelin got through this time.

peter, please test the appimage : - )

PeterBenedek

2021-01-10 18:26

developer   ~0048666

I am thankful ale. Appimage works fine again.

I close this ticket.

Issue History

Date Modified Username Field Change
2021-01-09 14:48 PeterBenedek New Issue
2021-01-09 14:53 PeterBenedek Description Updated View Revisions
2021-01-09 14:55 PeterBenedek Summary Scribus appimage don't building in GitLab => Scribus appimage doesn't building in GitLab
2021-01-09 14:55 PeterBenedek Description Updated View Revisions
2021-01-09 15:02 PeterBenedek Severity minor => feature
2021-01-09 15:39 JLuc Note Added: 0048661
2021-01-09 17:09 ale Note Added: 0048662
2021-01-09 20:59 jghali Note Added: 0048663
2021-01-10 17:30 ale Note Added: 0048665
2021-01-10 18:26 PeterBenedek Note Added: 0048666
2021-01-10 18:27 PeterBenedek Assigned To => ale
2021-01-10 18:27 PeterBenedek Status new => closed
2021-01-10 18:27 PeterBenedek Resolution open => fixed