View Issue Details

IDProjectCategoryView StatusLast Update
0016623ScribusOS-MacOSXpublic2021-08-27 13:58
ReporterElise Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.5.8.svn 
Fixed in Version1.5.8.svn 
Summary0016623: Scribus crashes when importing IDML file
DescriptionCrash, with above message. "Importing..." screen shows "progress", cursor is a B&W circle in 4 quarters, this remains unchanging for as long as I care to wait and longer. (Second or third time I left it in the background for even longer, still no "progress".)

OSX Big Sur 11.5.2
Scribus 1.5.8 svn r24694
Steps To ReproduceDouble-click to open Scribus in Applications directory (Finder). Scribus opens "New Document" window. I open instead "Open Existing Document" window and select an .IDML document. Three Missing Font dialogues open in series; I accept suggested alternative ("OK") each time. Next screen is the above error (crash) message. I click (with round B&W cursor; s.o.) on OK. Screen shows "Importing..." window with progress bar. And that's it. Nothing else happens after that.
TagsNo tags attached.
PatchNo

Activities

Elise

2021-08-22 15:45

reporter  

jghali

2021-08-22 16:14

administrator   ~0049222

In order to process this issue, we'll need the IDML document which triggers this crash. If it is small enough, please upload it here. Otherwise please upload it somewhere at your convenience and paste the link here.

Elise

2021-08-22 20:38

reporter   ~0049223

Same result with Scribus v1.5.7.

Elise

2021-08-22 20:39

reporter   ~0049224

Oops, didn't see your note! Thanks -
en_LSF_Mietpakete.idml (266,596 bytes)

Elise

2021-08-27 13:58

reporter   ~0049230

Works for me!

Issue History

Date Modified Username Field Change
2021-08-22 15:45 Elise New Issue
2021-08-22 15:45 Elise File Added: Screen Shot 2021-08-22 at 17.17.22.png
2021-08-22 15:45 Elise File Added: Screen Shot 2021-08-22 at 17.17.32.png
2021-08-22 15:45 Elise File Added: Screen Shot 2021-08-22 at 16.19.07.png
2021-08-22 15:45 Elise File Added: Screen Shot 2021-08-22 at 16.18.58.png
2021-08-22 15:45 Elise File Added: Screen Shot 2021-08-22 at 16.18.47.png
2021-08-22 15:45 Elise File Added: Screen Shot 2021-08-22 at 17.18.17.png
2021-08-22 15:45 Elise File Added: Screen Shot 2021-08-22 at 17.21.49.png
2021-08-22 16:13 jghali Priority high => normal
2021-08-22 16:14 jghali Note Added: 0049222
2021-08-22 20:38 Elise Note Added: 0049223
2021-08-22 20:39 Elise Note Added: 0049224
2021-08-22 20:39 Elise File Added: en_LSF_Mietpakete.idml
2021-08-23 19:21 jghali Summary Scribus crashes due to Signal 0000011 => Scribus crashes when importing IDML file
2021-08-23 19:22 jghali Assigned To => jghali
2021-08-23 19:22 jghali Status new => resolved
2021-08-23 19:22 jghali Resolution open => fixed
2021-08-23 19:22 jghali Fixed in Version => 1.5.8.svn
2021-08-27 13:58 Elise Note Added: 0049230