View Issue Details

IDProjectCategoryView StatusLast Update
0016745ScribusBuild Systempublic2022-05-22 12:59
Reporterfwsmit Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
OSArch Linux 
Summary0016745: Cannot build - cmake could not find Qt6
DescriptionI tried building scribus from source to fix 0016743, but cmake gives me errors about qt6. The BUILDING info, however, says that I only need qt5.
Steps To Reproducesvn checkout svn://scribus.net/trunk/Scribus
mkdir build
cd build
cmake ..
Additional InformationCmake output:

-- CMake Version: 3.22.2
-- Precompiled headers disabled
-- Scribus 1.7.0.svn will be built and installed into /usr
-- Shared Library Flags: -fPIC
-- Machine: x86_64-pc-linux-gnu, void pointer size: 8
-- Found target X86_64
-- Building for target x86_64-pc-linux-gnu
-- Using standard ApplicationDataDir. You can change it with -DAPPLICATION_DATA_DIR
-- Using standard ApplicationConfigDir. You can change it with -DAPPLICATION_CONFIG_DIR
-- Enabling C++17 compiler features
CMake Error at CMakeLists_Dependencies.cmake:10 (find_package):
  By not providing "FindQt6.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Qt6", but
  CMake did not find one.

  Could not find a package configuration file provided by "Qt6" with any of
  the following names:

    Qt6Config.cmake
    qt6-config.cmake

  Add the installation prefix of "Qt6" to CMAKE_PREFIX_PATH or set "Qt6_DIR"
  to a directory containing one of the above files. If "Qt6" provides a
  separate development package or SDK, be sure it has been installed.
Call Stack (most recent call first):
  CMakeLists.txt:418 (include)
TagsNo tags attached.
PatchNo

Activities

jghali

2022-02-10 20:26

administrator   ~0049529

You have to install Qt6 development packages first. Arch Linux seems to have Qt6 packages in its Extra repository:
https://archlinuxarm.org/packages/aarch64/qt6-base

Depending on distros, Qt6 packages may not be available yet (eg. Ubuntu). In such case it would be easier to build Qt5 based Version15x branch:
svn://scribus.net/branches/Version15x/Scribus

fwsmit

2022-02-11 09:11

reporter   ~0049532

Then I would like to suggest to update the building instructions in BUILDING. It mentions the requirement of Qt >= 5.14.0. The other two BUILDING instructions are also outdated.

fwsmit

2022-02-11 09:16

reporter   ~0049533

For future reference: I needed to install the following packages on arch:
- qt6-base
- qt6-5compat
- qt6-tools

fwsmit

2022-02-11 10:13

reporter   ~0049534

I'm still unable to build scribus, even when I install all the packages mentioned in https://aur.archlinux.org/packages/scribus-svn.

Here's the cmake output:
-- CMake Version: 3.22.2
-- Precompiled headers disabled
-- The C compiler identification is GNU 11.1.0
-- The CXX compiler identification is GNU 11.1.0
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/bin/cc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++ - skipped
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Scribus 1.7.0.svn will be built and installed into /usr
-- Shared Library Flags: -fPIC
-- Machine: x86_64-pc-linux-gnu, void pointer size: 8
-- Found target X86_64
-- Building for target x86_64-pc-linux-gnu
-- Using standard ApplicationDataDir. You can change it with -DAPPLICATION_DATA_DIR
-- Using standard ApplicationConfigDir. You can change it with -DAPPLICATION_CONFIG_DIR
-- Enabling C++17 compiler features
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Performing Test CMAKE_HAVE_LIBC_PTHREAD
-- Performing Test CMAKE_HAVE_LIBC_PTHREAD - Failed
-- Check if compiler accepts -pthread
-- Check if compiler accepts -pthread - yes
-- Found Threads: TRUE
-- Performing Test HAVE_STDATOMIC
-- Performing Test HAVE_STDATOMIC - Success
-- Found WrapAtomic: TRUE
-- Found OpenGL: /usr/lib/libOpenGL.so
-- Found WrapOpenGL: TRUE
-- Found XKB: /usr/lib/libxkbcommon.so (found suitable version "1.4.0", minimum required is "0.5.0")
-- Found WrapVulkanHeaders: /usr/include
-- Qt Version Found: 6.2.3
-- Found ZLIB: /usr/lib/libz.so (found version "1.2.11")
ZLIB Library Found OK
OSG found OK
-- Looking for memrchr
-- Looking for memrchr - found
-- Found JPEG: /usr/lib/libjpeg.so (found version "80")
JPEG Library Found OK
-- Found PNG: /usr/lib/libpng.so (found suitable version "1.6.37", minimum required is "1.6")
PNG Library Found OK
-- Found TIFF: /usr/lib/libtiff.so (found version "4.3.0")
TIFF Library Found OK
Python 3.x Selected
-- Found Python3: /usr/bin/python3.10 (found version "3.10.2") found components: Interpreter Development Development.Module Development.Embed
Python 3.x Library Found OK (Version 3.10.2)
Interpreter: /usr/bin/python3.10
Include directories: /usr/include/python3.10
Library directories: /usr/lib
Runtime library directories: /usr/lib
-- Found Freetype: /usr/lib/libfreetype.so (found version "2.11.1")
-- FreeType2 Library Found OK
-- Checking for one of the modules 'libcairo>=1.14.0;cairo>=1.14.0'
cairo Library found OK
-- Found Cups: /usr/lib/libcups.so (found version "2.4.1")
CUPS Library Found OK
-- Found LibXml2: /usr/lib/libxml2.so (found version "2.9.12")
LIBXML2 Library Found OK
LCMS 2 ReleaseLibrary: /usr/lib/liblcms2.so
LCMS 2 Debug Library: LCMS2_LIBRARY_DEBUG-NOTFOUND
LCMS 2 Library: /usr/lib/liblcms2.so
LittleCMS-2 Library Found OK
-- Found Fontconfig: /usr/lib/libfontconfig.so (found version "2.13.96")
FontConfig Found OK
-- Checking for one of the modules 'hunspell'
-- New hunspell API found. hunspell version 1.7.0
-- hunspell INCLUDE /usr/include/hunspell
-- hunspell LIBRARIES hunspell-1.7
hunspell Found OK
OpenSSL found OK for installed version of PoDoFo (>= 0.9.5) - Enabling support for PDF embedded in AI
PoDoFo found OK
-- Found Boost: /usr/lib/cmake/Boost-1.78.0/BoostConfig.cmake (found version "1.78.0")
Boost Library Found OK
-- Checking for module 'GraphicsMagick'
-- Found GraphicsMagick, version 1.3.37
 GraphicsMagick Found OK
-- Checking for one of the modules 'libpoppler>=0.62.0;poppler>=0.62.0'
-- Checking for one of the modules 'libpoppler-cpp>=0.62.0;poppler-cpp>=0.62.0'
-- Found poppler
-- Found poppler libs: /usr/lib/libpoppler.so
-- Found poppler includes: /usr/include/poppler
-- Poppler Version:22.02.0
-- C++17 is the minimum C++ standard since poppler 22.01.0
-- Checking for module 'librevenge-0.0'
-- Found librevenge-0.0, version 0.0.4
-- Checking for module 'librevenge-stream-0.0'
-- Found librevenge-stream-0.0, version 0.0.4
-- Checking for module 'librevenge-generators-0.0'
-- Found librevenge-generators-0.0, version 0.0.4
-- Checking for modules 'harfbuzz>=0.9.42;harfbuzz-icu'
-- Found harfbuzz, version 3.3.2
-- Found harfbuzz-icu, version 3.3.2
Harfbuzz library Found OK
-- Checking for module 'icu-uc'
-- Found icu-uc, version 70.1
-- Checking for module 'harfbuzz-subset>=2.4.0'
-- Found harfbuzz-subset, version 3.3.2
Harfbuzz subset library Found OK
-- Looking for dlfcn.h
-- Looking for dlfcn.h - found
-- Looking for unistd.h
-- Looking for unistd.h - found
-- Looking for sys/types.h
-- Looking for sys/types.h - found
-- Looking for sys/stat.h
-- Looking for sys/stat.h - found
-- Looking for include file endian.h
-- Looking for include file endian.h - found
-- Looking for include file fcntl.h
-- Looking for include file fcntl.h - found
-- SVN Version requested in About dialog
-- GMAGICK: Libs: -L/usr/lib;-lGraphicsMagick, Inc: /usr/include/GraphicsMagick, Ldflags: -L/usr/lib;-lGraphicsMagick
-- Including OpenSSL files for PoDoFo >= 0.9.5
-- Autogen Include Path: /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/include
RPATH: lib/scribus/plugins/;
-- Qt based Markdown plugin: Qt version >= 5.14.0 Ok, Installed Qt version:
-- Found PkgConfig: /usr/bin/pkg-config (found version "1.8.0")
-- Checking for module 'libcdr-0.1>=0.1'
-- Found libcdr-0.1, version 0.1.7
Building Corel Draw Importer with librevenge
-- Checking for module 'libfreehand-0.1'
-- Found libfreehand-0.1, version 0.1.2
Building Freehand Importer with librevenge
-- Checking for module 'libpagemaker-0.0'
-- Found libpagemaker-0.0, version 0.0.4
Building Pagemaker Importer with librevenge
-- Checking for module 'libmspub-0.1>=0.1'
-- Found libmspub-0.1, version 0.1.4
Building MS Publisher Importer with librevenge
-- Checking for module 'libqxp-0.0'
-- Found libqxp-0.0, version 0.0.2
Building QuarkXPress Importer
-- Checking for module 'libvisio-0.1>=0.1'
-- Found libvisio-0.1, version 0.1.7
Building MS-Visio Importer with librevenge
-- Checking for module 'libzmf-0.0'
-- Found libzmf-0.0, version 0.0.2
Building Zoner Draw Importer
-- Building with Scripter 1
-- No source header files will be installed
-- The following GUI languages will be installed:
-- Configuring done
-- Generating done
-- Build files have been written to: /home/friso/aur/scribus-svn/src/scribus/Scribus
-- Found Subversion: /usr/bin/svn (found version "1.14.1")
[ 0%] Built target svnheader
[ 0%] Generating share/scribus/translations/scribus.af.qm
[ 0%] Generating share/scribus/translations/scribus.ar.qm
[ 0%] Generating share/scribus/translations/scribus.az.qm
[ 0%] Generating share/scribus/translations/scribus.be.qm
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.
[ 0%] Generating share/scribus/translations/scribus.bg.qm
[ 0%] Generating share/scribus/translations/scribus.bn_IN.qm
[ 0%] Generating share/scribus/translations/scribus.br.qm
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.
[ 0%] Generating share/scribus/translations/scribus.ca.qm
[ 1%] Generating share/scribus/translations/scribus.cs_CZ.qm
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.
[ 1%] Generating share/scribus/translations/scribus.cy.qm
[ 1%] Generating share/scribus/translations/scribus.da_DK.qm
[ 1%] Generating share/scribus/translations/scribus.de.qm
[ 1%] Generating share/scribus/translations/scribus.de_1901.qm
[ 1%] Generating share/scribus/translations/scribus.de_CH.qm
[ 1%] Generating share/scribus/translations/scribus.el.qm
[ 1%] Generating share/scribus/translations/scribus.en_AU.qm
[ 1%] Generating share/scribus/translations/scribus.en_GB.qm
[ 1%] Generating share/scribus/translations/scribus.en_US.qm
[ 1%] Generating share/scribus/translations/scribus.eo.qm
[ 1%] Generating share/scribus/translations/scribus.es_AR.qm
[ 2%] Generating share/scribus/translations/scribus.es_ES.qm
[ 2%] Generating share/scribus/translations/scribus.et.qm
[ 2%] Generating share/scribus/translations/scribus.eu.qm
[ 2%] Generating share/scribus/translations/scribus.fa_IR.qm
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.
[ 2%] Generating share/scribus/translations/scribus.fi.qm
[ 2%] Generating share/scribus/translations/scribus.fr.qm
[ 2%] Generating share/scribus/translations/scribus.gl.qm
[ 2%] Generating share/scribus/translations/scribus.he_IL.qm
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.
[ 2%] Generating share/scribus/translations/scribus.hi_IN.qm
[ 2%] Generating share/scribus/translations/scribus.hr_HR.qm
[ 2%] Generating share/scribus/translations/scribus.hu.qm
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.
[ 3%] Generating share/scribus/translations/scribus.id.qm
[ 3%] Generating share/scribus/translations/scribus.it.qm
[ 3%] Generating share/scribus/translations/scribus.ja.qm
[ 3%] Generating share/scribus/translations/scribus.kab.qm
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.
[ 3%] Generating share/scribus/translations/scribus.kn_IN.qm
[ 3%] Generating share/scribus/translations/scribus.ko.qm
[ 3%] Generating share/scribus/translations/scribus.lt_LT.qm
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.
[ 3%] Generating share/scribus/translations/scribus.ml.qm
[ 3%] Generating share/scribus/translations/scribus.mn_MN.qm
[ 3%] Generating share/scribus/translations/scribus.ms_MY.qm
[ 3%] Generating share/scribus/translations/scribus.nb_NO.qm
[ 4%] Generating share/scribus/translations/scribus.nl.qm
[ 4%] Generating share/scribus/translations/scribus.nn_NO.qm
[ 4%] Generating share/scribus/translations/scribus.oc.qm
[ 4%] Generating share/scribus/translations/scribus.pl_PL.qm
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.
[ 4%] Generating share/scribus/translations/scribus.pms.qm
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.
[ 4%] Generating share/scribus/translations/scribus.pt.qm
[ 4%] Generating share/scribus/translations/scribus.pt_BR.qm
[ 4%] Generating share/scribus/translations/scribus.pt_PT.qm
[ 4%] Generating share/scribus/translations/scribus.ro.qm
[ 4%] Generating share/scribus/translations/scribus.ru.qm
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.
[ 4%] Generating share/scribus/translations/scribus.sa.qm
[ 4%] Generating share/scribus/translations/scribus.si.qm
[ 5%] Generating share/scribus/translations/scribus.sk_SK.qm
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.
[ 5%] Generating share/scribus/translations/scribus.sl.qm
[ 5%] Generating share/scribus/translations/scribus.so.qm
[ 5%] Generating share/scribus/translations/scribus.sq.qm
[ 5%] Generating share/scribus/translations/scribus.sr.qm
[ 5%] Generating share/scribus/translations/scribus.sv.qm
[ 5%] Generating share/scribus/translations/scribus.ta.qm
[ 5%] Generating share/scribus/translations/scribus.te.qm
[ 5%] Generating share/scribus/translations/scribus.th_TH.qm
[ 5%] Generating share/scribus/translations/scribus.tr.qm
[ 5%] Generating share/scribus/translations/scribus.uk.qm
Removed plural forms as the target language has less forms.
If this sounds wrong, possibly the target language is not set or recognized.
[ 6%] Generating share/scribus/translations/scribus.untranslated.qm
[ 6%] Generating share/scribus/translations/scribus.zh_CN.qm
[ 6%] Generating share/scribus/translations/scribus.zh_TW.qm
[ 6%] Built target scribus_lrelease
[ 6%] Automatic MOC and UIC for target scribus_prc_lib
[ 6%] Built target scribus_prc_lib_autogen
[ 7%] Building CXX object scribus/third_party/prc/CMakeFiles/scribus_prc_lib.dir/scribus_prc_lib_autogen/mocs_compilation.cpp.o
[ 7%] Building CXX object scribus/third_party/prc/CMakeFiles/scribus_prc_lib.dir/oPRCFile.cc.o
[ 7%] Building CXX object scribus/third_party/prc/CMakeFiles/scribus_prc_lib.dir/PRCbitStream.cc.o
[ 7%] Building CXX object scribus/third_party/prc/CMakeFiles/scribus_prc_lib.dir/PRCdouble.cc.o
[ 7%] Building CXX object scribus/third_party/prc/CMakeFiles/scribus_prc_lib.dir/writePRC.cc.o
[ 7%] Building CXX object scribus/third_party/prc/CMakeFiles/scribus_prc_lib.dir/exportPRC.cpp.o
[ 7%] Linking CXX static library libscribus_prc_lib.a
[ 7%] Built target scribus_prc_lib
[ 7%] Automatic MOC and UIC for target scribus_2geom_lib
[ 7%] Built target scribus_2geom_lib_autogen
[ 7%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/scribus_2geom_lib_autogen/mocs_compilation.cpp.o
[ 7%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/svg-path.cpp.o
[ 7%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/path.cpp.o
[ 7%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/path-intersection.cpp.o
[ 7%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/shape.cpp.o
[ 7%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/region.cpp.o
[ 7%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/crossing.cpp.o
[ 7%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/sweep.cpp.o
[ 7%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/poly.cpp.o
[ 8%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/poly-dk-solve.cpp.o
[ 8%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/poly-laguerre-solve.cpp.o
[ 8%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/quadtree.cpp.o
[ 8%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/matrix.cpp.o
[ 8%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/transforms.cpp.o
[ 8%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/point.cpp.o
[ 8%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/d2-sbasis.cpp.o
[ 8%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/piecewise.cpp.o
[ 8%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/sbasis.cpp.o
[ 8%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/sbasis-2d.cpp.o
[ 8%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/sbasis-geometric.cpp.o
[ 8%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/sbasis-math.cpp.o
[ 9%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/sbasis-poly.cpp.o
[ 9%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/sbasis-roots.cpp.o
[ 9%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/sbasis-to-bezier.cpp.o
[ 9%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/basic-intersection.cpp.o
[ 9%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/geom.cpp.o
[ 9%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/bezier-utils.cpp.o
[ 9%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/conjugate_gradient.cpp.o
[ 9%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/convex-cover.cpp.o
[ 9%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/solve-bezier-one-d.cpp.o
[ 9%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/solve-bezier-parametric.cpp.o
[ 9%] Building CXX object scribus/third_party/lib2geom/CMakeFiles/scribus_2geom_lib.dir/scribushelper.cpp.o
[ 10%] Linking CXX static library libscribus_2geom_lib.a
[ 10%] Built target scribus_2geom_lib
[ 10%] Automatic MOC and UIC for target scribus_wpg_lib
[ 10%] Built target scribus_wpg_lib_autogen
[ 10%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/scribus_wpg_lib_autogen/mocs_compilation.cpp.o
[ 10%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPG1Parser.cpp.o
[ 11%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPG2Parser.cpp.o
[ 11%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGBinaryData.cpp.o
[ 11%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGBitmap.cpp.o
[ 11%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGBrush.cpp.o
[ 11%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGColor.cpp.o
[ 11%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGGradient.cpp.o
[ 11%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGHeader.cpp.o
[ 11%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGInternalStream.cpp.o
[ 11%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGOLEStream.cpp.o
[ 11%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGPath.cpp.o
[ 11%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGPen.cpp.o
[ 11%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGPoint.cpp.o
[ 12%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGraphics.cpp.o
[ 12%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGRect.cpp.o
[ 12%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGStreamImplementation.cpp.o
[ 12%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGString.cpp.o
[ 12%] Building CXX object scribus/third_party/wpg/CMakeFiles/scribus_wpg_lib.dir/WPGXParser.cpp.o
[ 12%] Linking CXX static library libscribus_wpg_lib.a
[ 12%] Built target scribus_wpg_lib
[ 12%] Automatic MOC and UIC for target scribus_pgf_lib
[ 12%] Built target scribus_pgf_lib_autogen
[ 12%] Building CXX object scribus/third_party/pgf/CMakeFiles/scribus_pgf_lib.dir/scribus_pgf_lib_autogen/mocs_compilation.cpp.o
[ 12%] Building CXX object scribus/third_party/pgf/CMakeFiles/scribus_pgf_lib.dir/Decoder.cpp.o
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Decoder.cpp:29:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Decoder.h:57: warning: ignoring ‘#pragma warning ’ [-Wunknown-pragmas]
   57 | #pragma warning( suppress : 4351 )
      |
[ 12%] Building CXX object scribus/third_party/pgf/CMakeFiles/scribus_pgf_lib.dir/Encoder.cpp.o
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Encoder.cpp:29:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Encoder.h:57: warning: ignoring ‘#pragma warning ’ [-Wunknown-pragmas]
   57 | #pragma warning( suppress : 4351 )
      |
[ 12%] Building CXX object scribus/third_party/pgf/CMakeFiles/scribus_pgf_lib.dir/PGFimage.cpp.o
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/PGFimage.cpp:30:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Decoder.h:57: warning: ignoring ‘#pragma warning ’ [-Wunknown-pragmas]
   57 | #pragma warning( suppress : 4351 )
      |
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/PGFimage.cpp:31:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Encoder.h:57: warning: ignoring ‘#pragma warning ’ [-Wunknown-pragmas]
   57 | #pragma warning( suppress : 4351 )
      |
[ 12%] Building CXX object scribus/third_party/pgf/CMakeFiles/scribus_pgf_lib.dir/PGFstream.cpp.o
[ 12%] Building CXX object scribus/third_party/pgf/CMakeFiles/scribus_pgf_lib.dir/Subband.cpp.o
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Subband.cpp:30:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Encoder.h:57: warning: ignoring ‘#pragma warning ’ [-Wunknown-pragmas]
   57 | #pragma warning( suppress : 4351 )
      |
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Subband.cpp:31:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Decoder.h:57: warning: ignoring ‘#pragma warning ’ [-Wunknown-pragmas]
   57 | #pragma warning( suppress : 4351 )
      |
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Subband.cpp:29:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Subband.h: In constructor ‘CSubband::CSubband()’:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Subband.h:172:16: warning: ‘CSubband::m_data’ will be initialized after [-Wreorder]
  172 | DataT* m_data; ///< buffer
      | ^~~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Subband.h:171:16: warning: ‘UINT32 CSubband::m_dataPos’ [-Wreorder]
  171 | UINT32 m_dataPos; ///< current position in m_data
      | ^~~~~~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Subband.cpp:35:1: warning: when initialized here [-Wreorder]
   35 | CSubband::CSubband()
      | ^~~~~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Subband.cpp: In member function ‘void CSubband::ExtractTile(CEncoder&, bool, UINT32, UINT32)’:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Subband.cpp:189:17: warning: statement has no effect [-Wunused-value]
  189 | tileX; tileY; tile; // prevents from unreferenced formal parameter warning
      | ^~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Subband.cpp:189:24: warning: statement has no effect [-Wunused-value]
  189 | tileX; tileY; tile; // prevents from unreferenced formal parameter warning
      | ^~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Subband.cpp:189:31: warning: statement has no effect [-Wunused-value]
  189 | tileX; tileY; tile; // prevents from unreferenced formal parameter warning
      | ^~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Subband.cpp: In member function ‘void CSubband::PlaceTile(CDecoder&, int, bool, UINT32, UINT32)’:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Subband.cpp:229:17: warning: statement has no effect [-Wunused-value]
  229 | tileX; tileY; tile; // prevents from unreferenced formal parameter warning
      | ^~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Subband.cpp:229:24: warning: statement has no effect [-Wunused-value]
  229 | tileX; tileY; tile; // prevents from unreferenced formal parameter warning
      | ^~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/Subband.cpp:229:31: warning: statement has no effect [-Wunused-value]
  229 | tileX; tileY; tile; // prevents from unreferenced formal parameter warning
      | ^~~~
[ 12%] Building CXX object scribus/third_party/pgf/CMakeFiles/scribus_pgf_lib.dir/WaveletTransform.cpp.o
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/WaveletTransform.cpp:29:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/WaveletTransform.h: In constructor ‘CWaveletTransform::CWaveletTransform(UINT32, UINT32, int, DataT*)’:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/WaveletTransform.h:142:27: warning: ‘CWaveletTransform::m_subband’ will be initialized after [-Wreorder]
  142 | CSubband (*m_subband)[NSubbands]; ///< quadtree of subbands: LL HL LH HH
      | ^~~~~~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/WaveletTransform.h:138:18: warning: ‘PGFRect* CWaveletTransform::m_indices’ [-Wreorder]
  138 | PGFRect *m_indices; ///< array of length m_nLevels of tile indices
      | ^~~~~~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/pgf/WaveletTransform.cpp:40:1: warning: when initialized here [-Wreorder]
   40 | CWaveletTransform::CWaveletTransform(UINT32 width, UINT32 height, int levels, DataT* data)
      | ^~~~~~~~~~~~~~~~~
[ 12%] Linking CXX static library libscribus_pgf_lib.a
[ 12%] Built target scribus_pgf_lib
[ 12%] Automatic MOC and UIC for target scribus_rtf_lib
[ 12%] Built target scribus_rtf_lib_autogen
[ 12%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/scribus_rtf_lib_autogen/mocs_compilation.cpp.o
[ 12%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/AbstractRtfOutput.cpp.o
[ 12%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/AuthorPcdataDestination.cpp.o
[ 13%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/CategoryPcdataDestination.cpp.o
[ 13%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/ColorTableDestination.cpp.o
[ 13%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/CommentPcdataDestination.cpp.o
[ 13%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/CompanyPcdataDestination.cpp.o
[ 13%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/controlword.cpp.o
[ 13%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/Destination.cpp.o
[ 13%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/DocumentCommentPcdataDestination.cpp.o
[ 13%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/DocumentDestination.cpp.o
[ 13%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/FontTableDestination.cpp.o
[ 13%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/GeneratorPcdataDestination.cpp.o
[ 13%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/HLinkBasePcdataDestination.cpp.o
[ 14%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/IgnoredDestination.cpp.o
[ 14%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/InfoCreatedTimeDestination.cpp.o
[ 14%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/InfoDestination.cpp.o
[ 14%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/InfoPrintedTimeDestination.cpp.o
[ 14%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/InfoRevisedTimeDestination.cpp.o
[ 14%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/InfoTimeDestination.cpp.o
[ 14%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/KeywordsPcdataDestination.cpp.o
[ 14%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/ManagerPcdataDestination.cpp.o
[ 14%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/OperatorPcdataDestination.cpp.o
[ 14%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/PcdataDestination.cpp.o
[ 14%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/PictDestination.cpp.o
[ 14%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/rtfreader.cpp.o
[ 15%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/sladocumentrtfoutput.cpp.o
[ 15%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/StyleSheetDestination.cpp.o
[ 15%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/SubjectPcdataDestination.cpp.o
[ 15%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/TitlePcdataDestination.cpp.o
[ 15%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/Token.cpp.o
[ 15%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/Tokenizer.cpp.o
[ 15%] Building CXX object scribus/third_party/rtf-qt/CMakeFiles/scribus_rtf_lib.dir/UserPropsDestination.cpp.o
[ 15%] Linking CXX static library libscribus_rtf_lib.a
[ 15%] Built target scribus_rtf_lib
[ 15%] Automatic MOC and UIC for target scribus_zip_lib
[ 15%] Built target scribus_zip_lib_autogen
[ 15%] Building CXX object scribus/third_party/zip/CMakeFiles/scribus_zip_lib.dir/scribus_zip_lib_autogen/mocs_compilation.cpp.o
[ 15%] Building CXX object scribus/third_party/zip/CMakeFiles/scribus_zip_lib.dir/unzip.cpp.o
[ 15%] Building CXX object scribus/third_party/zip/CMakeFiles/scribus_zip_lib.dir/zip.cpp.o
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/zip/zip.cpp: In member function ‘Zip::ErrorCode ZipPrivate::createEntry(const QFileInfo&, const QString&, Zip::CompressionLevel)’:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/zip/zip.cpp:946:38: warning: ‘T* QScopedPointer<T, Cleanup>::take() [with T = ZipEntryP; Cleanup = QScopedPointerDeleter<ZipEntryP>]’ is deprecated: Use std::unique_ptr instead, and call release(). [-Wdeprecated-declarations]
  946 | headers->insert(entryName, h.take());
      | ~~~~~~^~
In file included from /usr/include/qt6/QtCore/qdatastream.h:43,
                 from /usr/include/qt6/QtCore/qmetatype.h:52,
                 from /usr/include/qt6/QtCore/qvariant.h:46,
                 from /usr/include/qt6/QtCore/qlocale.h:43,
                 from /usr/include/qt6/QtCore/qcalendar.h:46,
                 from /usr/include/qt6/QtCore/qdatetime.h:47,
                 from /usr/include/qt6/QtCore/QDateTime:1,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/zip/zipglobal.h:31,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/zip/zip.h:31,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/third_party/zip/zip.cpp:28:
/usr/include/qt6/QtCore/qscopedpointer.h:165:8: note: declared here
  165 | T *take() noexcept
      | ^~~~
[ 15%] Building CXX object scribus/third_party/zip/CMakeFiles/scribus_zip_lib.dir/zipglobal.cpp.o
[ 16%] Building CXX object scribus/third_party/zip/CMakeFiles/scribus_zip_lib.dir/scribus_zip.cpp.o
[ 16%] Linking CXX static library libscribus_zip_lib.a
[ 16%] Built target scribus_zip_lib
[ 16%] Automatic MOC and UIC for target scribus
[ 16%] Built target scribus_autogen
[ 16%] Building CXX object scribus/CMakeFiles/scribus.dir/scribus_autogen/mocs_compilation.cpp.o
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:10,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:96:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/../../ui/AdapterWidget.h:25:1: error: expected class-name before ‘{’ token
   25 | {
      | ^
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/../../ui/AdapterWidget.h:28:89: error: ‘QGLWidget’ does not name a type; did you mean ‘QWidget’?
   28 | AdapterWidget ( QWidget* parent = nullptr, const char * name = 0, const QGLWidget * shareWidget = 0);
      | ^~~~~~~~~
      | QWidget
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/../../ui/AdapterWidget.h:56:84: error: ‘QGLWidget’ does not name a type; did you mean ‘QWidget’?
   56 | ViewerQT ( QWidget* parent = nullptr, const char * name = 0, const QGLWidget * shareWidget = 0) : AdapterWidget ( parent, name, shareWidget)
      | ^~~~~~~~~
      | QWidget
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:10,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:96:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/../../ui/AdapterWidget.h: In constructor ‘ViewerQT::ViewerQT(QWidget*, const char*, const int*)’:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/../../ui/AdapterWidget.h:58:76: error: ‘width’ was not declared in this scope; did you mean ‘wcwidth’?
   58 | getCamera()->setViewport ( new osg::Viewport ( 0,0,width(),height() ) );
      | ^~~~~
      | wcwidth
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/../../ui/AdapterWidget.h:58:84: error: ‘height’ was not declared in this scope; did you mean ‘_light’?
   58 | getCamera()->setViewport ( new osg::Viewport ( 0,0,width(),height() ) );
      | ^~~~~~
      | _light
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/../../ui/AdapterWidget.h:60:37: error: ‘palette’ was not declared in this scope; did you mean ‘QPalette’?
   60 | QColor bg = palette().window().color();
      | ^~~~~~~
      | QPalette
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/../../ui/AdapterWidget.h:67:25: error: ‘connect’ was not declared in this scope; did you mean ‘QtFuture::connect’?
   67 | connect ( &_timer, SIGNAL ( timeout() ), this, SLOT ( updateGL() ) );
      | ^~~~~~~
      | QtFuture::connect
In file included from /usr/include/qt6/QtCore/qfuture.h:48,
                 from /usr/include/qt6/QtCore/QtCore:92,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/../../ui/AdapterWidget.h:18,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:10,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:96:
/usr/include/qt6/QtCore/qfuture_impl.h:870:34: note: ‘QtFuture::connect’ declared here
  870 | static QFuture<ArgsType<Signal>> connect(Sender *sender, Signal signal)
      | ^~~~~~~
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:96:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp: In static member function ‘static void AdapterWidget::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)’:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:68:20: error: invalid ‘static_cast’ from type ‘QObject*’ to type ‘AdapterWidget*’
   68 | auto *_t = static_cast<AdapterWidget *>(_o);
      | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp: At global scope:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:88:34: error: ‘QGLWidget’ was not declared in this scope; did you mean ‘QWidget’?
   88 | QMetaObject::SuperData::link<QGLWidget::staticMetaObject>(),
      | ^~~~~~~~~
      | QWidget
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:88:29: error: parse error in template argument list
   88 | QMetaObject::SuperData::link<QGLWidget::staticMetaObject>(),
      | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:88:62: error: no matching function for call to ‘QMetaObject::SuperData::link<<expression error> >()’
   88 | QMetaObject::SuperData::link<QGLWidget::staticMetaObject>(),
      | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~
In file included from /usr/include/qt6/QtGui/qkeysequence.h:45,
                 from /usr/include/qt6/QtGui/QKeySequence:1,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/EWIEGA46WW/../../actionmanager.h:24,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/EWIEGA46WW/moc_actionmanager.cpp:10,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:2:
/usr/include/qt6/QtCore/qobjectdefs.h:422:69: note: candidate: ‘template<const QMetaObject& MO> static constexpr QMetaObject::SuperData QMetaObject::SuperData::link()’
  422 | template <const QMetaObject &MO> static constexpr SuperData link()
      | ^~~~
/usr/include/qt6/QtCore/qobjectdefs.h:422:69: note: template argument deduction/substitution failed:
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:96:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:88:62: error: template argument 1 is invalid
   88 | QMetaObject::SuperData::link<QGLWidget::staticMetaObject>(),
      | ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp: In member function ‘virtual const QMetaObject* AdapterWidget::metaObject() const’:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:105:21: error: ‘QScopedPointer<QObjectData> QObject::d_ptr’ is protected within this context
  105 | return QObject::d_ptr->metaObject ? QObject::d_ptr->dynamicMetaObject() : &staticMetaObject;
      | ^~~~~
In file included from /usr/include/qt6/QtCore/QObject:1,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/EWIEGA46WW/../../actionmanager.h:25,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/EWIEGA46WW/moc_actionmanager.cpp:10,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:2:
/usr/include/qt6/QtCore/qobject.h:415:33: note: declared protected here
  415 | QScopedPointer<QObjectData> d_ptr;
      | ^~~~~
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:96:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:105:21: error: invalid use of non-static data member ‘QObject::d_ptr’
  105 | return QObject::d_ptr->metaObject ? QObject::d_ptr->dynamicMetaObject() : &staticMetaObject;
      | ^~~~~
In file included from /usr/include/qt6/QtCore/QObject:1,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/EWIEGA46WW/../../actionmanager.h:25,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/EWIEGA46WW/moc_actionmanager.cpp:10,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:2:
/usr/include/qt6/QtCore/qobject.h:415:33: note: declared here
  415 | QScopedPointer<QObjectData> d_ptr;
      | ^~~~~
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:96:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:105:50: error: ‘QScopedPointer<QObjectData> QObject::d_ptr’ is protected within this context
  105 | return QObject::d_ptr->metaObject ? QObject::d_ptr->dynamicMetaObject() : &staticMetaObject;
      | ^~~~~
In file included from /usr/include/qt6/QtCore/QObject:1,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/EWIEGA46WW/../../actionmanager.h:25,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/EWIEGA46WW/moc_actionmanager.cpp:10,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:2:
/usr/include/qt6/QtCore/qobject.h:415:33: note: declared protected here
  415 | QScopedPointer<QObjectData> d_ptr;
      | ^~~~~
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:96:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:105:50: error: invalid use of non-static data member ‘QObject::d_ptr’
  105 | return QObject::d_ptr->metaObject ? QObject::d_ptr->dynamicMetaObject() : &staticMetaObject;
      | ^~~~~
In file included from /usr/include/qt6/QtCore/QObject:1,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/EWIEGA46WW/../../actionmanager.h:25,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/EWIEGA46WW/moc_actionmanager.cpp:10,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:2:
/usr/include/qt6/QtCore/qobject.h:415:33: note: declared here
  415 | QScopedPointer<QObjectData> d_ptr;
      | ^~~~~
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:96:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp: In member function ‘virtual void* AdapterWidget::qt_metacast(const char*)’:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:113:12: error: ‘QGLWidget’ has not been declared
  113 | return QGLWidget::qt_metacast(_clname);
      | ^~~~~~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp: In member function ‘virtual int AdapterWidget::qt_metacall(QMetaObject::Call, int, void**)’:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:118:11: error: ‘QGLWidget’ has not been declared
  118 | _id = QGLWidget::qt_metacall(_c, _id, _a);
      | ^~~~~~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:123:32: error: cannot convert ‘AdapterWidget*’ to ‘QObject*’
  123 | qt_static_metacall(this, _c, _id, _a);
      | ^~~~
      | |
      | AdapterWidget*
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:65:49: note: initializing argument 1 of ‘static void AdapterWidget::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)’
   65 | void AdapterWidget::qt_static_metacall(QObject *_o, QMetaObject::Call _c, int _id, void **_a)
      | ~~~~~~~~~^~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp: In member function ‘void AdapterWidget::mouseMoved()’:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:136:26: error: no matching function for call to ‘QMetaObject::activate(AdapterWidget*, const QMetaObject*, int, std::nullptr_t)’
  136 | QMetaObject::activate(this, &staticMetaObject, 0, nullptr);
      | ~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from /usr/include/qt6/QtGui/qkeysequence.h:45,
                 from /usr/include/qt6/QtGui/QKeySequence:1,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/EWIEGA46WW/../../actionmanager.h:24,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/EWIEGA46WW/moc_actionmanager.cpp:10,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:2:
/usr/include/qt6/QtCore/qobjectdefs.h:223:17: note: candidate: ‘static void QMetaObject::activate(QObject*, int, void**)’
  223 | static void activate(QObject *sender, int signal_index, void **argv);
      | ^~~~~~~~
/usr/include/qt6/QtCore/qobjectdefs.h:223:17: note: candidate expects 3 arguments, 4 provided
/usr/include/qt6/QtCore/qobjectdefs.h:224:17: note: candidate: ‘static void QMetaObject::activate(QObject*, const QMetaObject*, int, void**)’
  224 | static void activate(QObject *sender, const QMetaObject *, int local_signal_index, void **argv);
      | ^~~~~~~~
/usr/include/qt6/QtCore/qobjectdefs.h:224:35: note: no known conversion for argument 1 from ‘AdapterWidget*’ to ‘QObject*’
  224 | static void activate(QObject *sender, const QMetaObject *, int local_signal_index, void **argv);
      | ~~~~~~~~~^~~~~~
/usr/include/qt6/QtCore/qobjectdefs.h:225:17: note: candidate: ‘static void QMetaObject::activate(QObject*, int, int, void**)’
  225 | static void activate(QObject *sender, int signal_offset, int local_signal_index, void **argv);
      | ^~~~~~~~
/usr/include/qt6/QtCore/qobjectdefs.h:225:35: note: no known conversion for argument 1 from ‘AdapterWidget*’ to ‘QObject*’
  225 | static void activate(QObject *sender, int signal_offset, int local_signal_index, void **argv);
      | ~~~~~~~~~^~~~~~
In file included from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/../../ui/osgeditor.h:31,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/UYX5XTB5RZ/moc_osgeditor.cpp:10,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:201:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/include/ui_osgeditor.h: In member function ‘void Ui_OSGEditor::setupUi(QDialog*)’:
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/include/ui_osgeditor.h:100:22: error: ‘class ViewerQT’ has no member named ‘setObjectName’
  100 | drawingarea->setObjectName(QString::fromUtf8("drawingarea"));
      | ^~~~~~~~~~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/include/ui_osgeditor.h:104:51: error: ‘class ViewerQT’ has no member named ‘sizePolicy’
  104 | sizePolicy.setHeightForWidth(drawingarea->sizePolicy().hasHeightForWidth());
      | ^~~~~~~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/include/ui_osgeditor.h:105:22: error: ‘class ViewerQT’ has no member named ‘setSizePolicy’
  105 | drawingarea->setSizePolicy(sizePolicy);
      | ^~~~~~~~~~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/include/ui_osgeditor.h:106:22: error: ‘class ViewerQT’ has no member named ‘setMinimumSize’
  106 | drawingarea->setMinimumSize(QSize(30, 30));
      | ^~~~~~~~~~~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/include/ui_osgeditor.h:107:22: error: ‘class ViewerQT’ has no member named ‘setMaximumSize’
  107 | drawingarea->setMaximumSize(QSize(400, 400));
      | ^~~~~~~~~~~~~~
/home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/include/ui_osgeditor.h:109:32: error: no matching function for call to ‘QGridLayout::addWidget(ViewerQT*&, int, int, int, int)’
  109 | gridLayout_4->addWidget(drawingarea, 1, 1, 1, 1);
      | ~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~
In file included from /usr/include/qt6/QtWidgets/QGridLayout:1,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/include/ui_arcvectorbase.h:14,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/EWIEGA46WW/../../ui/arcvectordialog.h:27,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/EWIEGA46WW/../../canvasmode_editarc.h:31,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/EWIEGA46WW/moc_canvasmode_editarc.cpp:10,
                 from /home/friso/aur/scribus-svn/src/scribus/Scribus/scribus/scribus_autogen/mocs_compilation.cpp:14:
/usr/include/qt6/QtWidgets/qgridlayout.h:100:17: note: candidate: ‘void QGridLayout::addWidget(QWidget*)’
  100 | inline void addWidget(QWidget *w) { QLayout::addWidget(w); }
      | ^~~~~~~~~
/usr/include/qt6/QtWidgets/qgridlayout.h:100:17: note: candidate expects 1 argument, 5 provided
/usr/include/qt6/QtWidgets/qgridlayout.h:101:10: note: candidate: ‘void QGridLayout::addWidget(QWidget*, int, int, Qt::Alignment)’
  101 | void addWidget(QWidget *, int row, int column, Qt::Alignment = Qt::Alignment());
      | ^~~~~~~~~
/usr/include/qt6/QtWidgets/qgridlayout.h:101:10: note: candidate expects 4 arguments, 5 provided
/usr/include/qt6/QtWidgets/qgridlayout.h:102:10: note: candidate: ‘void QGridLayout::addWidget(QWidget*, int, int, int, int, Qt::Alignment)’
  102 | void addWidget(QWidget *, int row, int column, int rowSpan, int columnSpan, Qt::Alignment = Qt::Alignment());
      | ^~~~~~~~~
/usr/include/qt6/QtWidgets/qgridlayout.h:102:20: note: no known conversion for argument 1 from ‘ViewerQT*’ to ‘QWidget*’
  102 | void addWidget(QWidget *, int row, int column, int rowSpan, int columnSpan, Qt::Alignment = Qt::Alignment());
      | ^~~~~~~~~
make[2]: *** [scribus/CMakeFiles/scribus.dir/build.make:75: scribus/CMakeFiles/scribus.dir/scribus_autogen/mocs_compilation.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:2105: scribus/CMakeFiles/scribus.dir/all] Error 2
make: *** [Makefile:156: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

fwsmit

2022-02-11 11:02

reporter   ~0049535

I also tried building scribus 15x and the building succeeded, but when running it, I get the error: "No icons found :("

jghali

2022-02-11 12:18

administrator   ~0049536

>> OSG found OK

As for trunk, there is currently no OSG package compatible with Qt6:
https://github.com/openscenegraph/osgQt/issues/52

>> but when running it, I get the error: "No icons found :("

After building, you have to run command "make install"

cbradney

2022-02-12 09:44

administrator   ~0049540

I've updated the BUILDING files.

If you want really use Scribus, you should build the Version15x branches and use Qt5. Trunk is undergoing a lot of change due to Qt6 compatibility and has no more features at this point than 1.5.x

fwsmit

2022-02-13 11:11

reporter   ~0049543

Thanks, I'll work from the version 15 branch then. I've opened a feature request for not needing make install here: https://bugs.scribus.net/view.php?id=16748

fwsmit

2022-02-13 11:12

reporter   ~0049544

This can be closed

cbradney

2022-02-13 11:28

administrator   ~0049546

Thanks closing. Per other bug, we are not going to support not installing Scribus. No technical reason and hardly any reason at all.

fwsmit

2022-02-13 18:01

reporter   ~0049547

Thanks, I understand. The mentioned workflow is fine to me.

goto_coder

2022-05-22 11:57

reporter   ~0049654

I'm trying to compile 1.7.0 and I get the same errors regarding AdapterWidget.h. It starts with this line and many errors follow:

[ 18%] Building CXX object scribus/CMakeFiles/scribus.dir/canvas.cpp.o
In file included from /home/user/Programming/scribus/scribus-code/trunk/builddir/scribus/scribus_autogen/UYX5XTB5RZ/moc_AdapterWidget.cpp:10,
                 from /home/user/Programming/scribus/scribus-code/trunk/builddir/scribus/scribus_autogen/mocs_compilation.cpp:96:
/home/user/Programming/scribus/scribus-code/trunk/Scribus/scribus/ui/AdapterWidget.h:25:1: error: expected class-name before ‘{’ token
   25 | {
      | ^

I looked at AdapterWidget.h and found:

 22 #include <osg/Vec3>
 23
 24 class AdapterWidget : public QGLWidget
 25 {
 26 Q_OBJECT

This looks innocent enough, so I guess the error is related to the fact that "As for trunk, there is currently no OSG package compatible with Qt6" since it's the last library included before the "offending" statement?
Does that mean, that there is no possibility to compile scribus 1.7.0 right now? Or is there a workaround?
My ultimate goal is getting to a point where I can help developing scribus, so I'm not sure if working on an earlier release until this is fixed would make sense for me?

cbradney

2022-05-22 12:44

administrator   ~0049655

Try adding -DWANT_NOOSG=1 to your cmake command line

Issue History

Date Modified Username Field Change
2022-02-10 11:05 fwsmit New Issue
2022-02-10 20:26 jghali Assigned To => jghali
2022-02-10 20:26 jghali Status new => resolved
2022-02-10 20:26 jghali Resolution open => no change required
2022-02-10 20:26 jghali Note Added: 0049529
2022-02-10 20:26 jghali Status resolved => closed
2022-02-11 09:11 fwsmit Status closed => feedback
2022-02-11 09:11 fwsmit Resolution no change required => reopened
2022-02-11 09:11 fwsmit Note Added: 0049532
2022-02-11 09:16 fwsmit Note Added: 0049533
2022-02-11 09:16 fwsmit Status feedback => assigned
2022-02-11 10:13 fwsmit Note Added: 0049534
2022-02-11 11:02 fwsmit Note Added: 0049535
2022-02-11 12:18 jghali Note Added: 0049536
2022-02-12 09:44 cbradney Note Added: 0049540
2022-02-13 11:11 fwsmit Note Added: 0049543
2022-02-13 11:12 fwsmit Note Added: 0049544
2022-02-13 11:28 cbradney Assigned To jghali => cbradney
2022-02-13 11:28 cbradney Status assigned => resolved
2022-02-13 11:28 cbradney Note Added: 0049546
2022-02-13 18:01 fwsmit Note Added: 0049547
2022-05-22 11:57 goto_coder Note Added: 0049654
2022-05-22 12:44 cbradney Note Added: 0049655
2022-05-22 12:59 jghali Resolution reopened => no change required