View Issue Details

IDProjectCategoryView StatusLast Update
0016808ScribusUser Interfacepublic2022-06-17 18:02
Reportergoto_coder Assigned Tojghali  
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Platform64bitOSUbuntuOS Version20.04
Product Version1.5.9.svn 
Fixed in Version1.5.9.svn 
Summary0016808: Scrapbook dialog dropdown menu has unintuitive icon
DescriptionThe dropdown menu button for the option list displays only a tiny arrow. If you don't look closely, you might even think it hasn't got any icon at all.
Maybe the "usual" dropdown menu symbol, three horizontal bars, would make this more intuitive?
This might also apply to other 'QToolButton' buttons, if there are any.
Steps To ReproduceOpen scrapbook dialog and look at button for "options" menu.
TagsDialogs, menus, options, toolbars
PatchYes

Activities

goto_coder

2022-06-12 20:12

reporter  

dropdown_menu_scrapbookpalette_2022_06_12_goto_coder.diff (1,070 bytes)   
Index: resources/iconsets/1_5_1/16/dropdown_menu.png
===================================================================
Kann nicht anzeigen: Dateityp ist als binär angegeben.
svn:mime-type = application/octet-stream

Property changes on: resources/iconsets/1_5_1/16/dropdown_menu.png
___________________________________________________________________
Added: svn:mime-type
## -0,0 +1 ##
+application/octet-stream
\ No newline at end of property
Index: scribus/ui/scrapbookpalette.cpp
===================================================================
--- scribus/ui/scrapbookpalette.cpp	(Revision 25096)
+++ scribus/ui/scrapbookpalette.cpp	(Arbeitskopie)
@@ -745,7 +745,9 @@
 	closeButton->setIconSize(QSize(16, 16));
 	configButton = new QToolButton(this);
 	configButton->setSizePolicy(QSizePolicy(QSizePolicy::Fixed, QSizePolicy::Fixed));
+    configButton->setIcon(IconManager::instance().loadPixmap("16/dropdown_menu.png"));
 
+
 	configMenue = new QMenu();
 	conf_HideDirs = configMenue->addAction( tr("Hide Directories"));
 	conf_HideDirs->setCheckable(true);
dropdown_menu.png (582 bytes)   
dropdown_menu.png (582 bytes)   

jghali

2022-06-17 18:02

administrator   ~0049703

Thanks for the report. There was already an assigned icon for this button (see iconSetChange()), however due to a missing call, it was not set properly on dialog creation. I nevertheless added your new icon (+ a corresponding icon for dark icon set).

Issue History

Date Modified Username Field Change
2022-06-12 20:12 goto_coder New Issue
2022-06-12 20:12 goto_coder Tag Attached: Dialogs
2022-06-12 20:12 goto_coder Tag Attached: menus
2022-06-12 20:12 goto_coder Tag Attached: options
2022-06-12 20:12 goto_coder Tag Attached: toolbars
2022-06-12 20:12 goto_coder File Added: dropdown_menu_scrapbookpalette_2022_06_12_goto_coder.diff
2022-06-12 20:12 goto_coder File Added: dropdown_menu.png
2022-06-17 17:57 jghali Summary Dropdown menu has unintuitive icon on scrapbook dialog (maybe other dialogs too?) => Scrapbook dialog dropdown menu has unintuitive icon
2022-06-17 18:02 jghali Assigned To => jghali
2022-06-17 18:02 jghali Status new => resolved
2022-06-17 18:02 jghali Resolution open => fixed
2022-06-17 18:02 jghali Fixed in Version => 1.5.9.svn
2022-06-17 18:02 jghali Note Added: 0049703