View Issue Details

IDProjectCategoryView StatusLast Update
0016821ScribusShape Drawingpublic2022-06-30 22:10
Reportertim_occ Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
OSUbuntuOS Version22.04 
Product Version1.5.8 
Fixed in Version1.5.9.svn 
Summary0016821: Scribus crash if you delete a symbol during in "symbol edit mode".
DescriptionScribus crash if you delete a symbol during in "symbol edit mode".
Steps To Reproduce1. Create a new document and draw a random shape
2. Convert shape to symbol (right click --> Convert To... --> Symbol)
3. Double-click on symbol to switch to edit mode
4. Open Symbol Panel (Windows menu --> Symbols)
5. Remove Symbol in Symbols Panel (right click --> remove item
Crash: Scribus crashes due to Signal 0000011
Additional InformationSystem:
OS: Ubuntu 22.04
CPU: AMD® Ryzen 7 3700x 8-core processor × 16
GPU: NVIDIA Corporation TU104 [GeForce RTX 2070 SUPER]
RAM: 16,0 GiB
Window Manager: X11
Tagssymbol
PatchNo

Activities

tim_occ

2022-06-27 21:24

reporter  

Issue History

Date Modified Username Field Change
2022-06-27 21:24 tim_occ New Issue
2022-06-27 21:24 tim_occ Tag Attached: symbol
2022-06-27 21:24 tim_occ File Added: Bildschirmfoto vom 2022-06-27 23-24-00.png
2022-06-30 22:10 jghali Assigned To => jghali
2022-06-30 22:10 jghali Status new => resolved
2022-06-30 22:10 jghali Resolution open => fixed
2022-06-30 22:10 jghali Fixed in Version => 1.5.9.svn