View Issue Details

IDProjectCategoryView StatusLast Update
0016867ScribusUsabilitypublic2022-12-05 22:42
Reportertaiwbi Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSManjaro LinuxOS Version22.0.0
Product Version1.5.8 
Fixed in Version1.5.9.svn 
Summary0016867: If a right to left paragraph follows a left to right paragraph, one of the paragraphs will not work properly
DescriptionSuppose I am writing a book in an RTL language and all my paragraphs are right to left.
Now I need to write a paragraph in English between all other paragraphs and I have to set this paragraph's direction left to right.
In this case, the direction of all my RTL paragraphs also changes, the UI shows they are still right to left that should be but they work like left to right paragraph. All the writing will be messed up, the end points of the line are moved to the beginning of the line and if there is an English word in the Persian paragraphs, it messes up the whole paragraph.
Steps To ReproduceCreate a text frame.
Type one English paragraph and one RTL language paragraph inside the text frame. Make sure you're using a right to left language while writing the right to left paragraph. put a dot at the end of each paragraph. In text properties style both of them right to left.
As you can see now, dots are at the left of the last line of the paragraphs, that is correct for Persian paragraph and wrong for English paragraph. Because English paragraph ends at the left and dot should be at the end of the sentence.
Now change the English paragraph direction to left to right, so the dot position on English paragraph must be fixed and it will be and as we didn't change the Persian paragraph direction so that should work fine too but it the dot will position will be at the right of the Persian paragraph that is wrong.
Additional InformationI think this happens because for some reason all paragraph directions in a text frame changes while changing a single paragraph direction but it doesn't show it on the UI. I'm not sure, I'm just guessing. Also this issue happens with all linked text frames.
Tagsright to left, RTL, RTLGUI
PatchNo

Activities

Issue History

Date Modified Username Field Change
2022-12-05 05:50 taiwbi New Issue
2022-12-05 05:50 taiwbi Tag Attached: right to left
2022-12-05 05:50 taiwbi Tag Attached: RTL
2022-12-05 05:50 taiwbi Tag Attached: RTLGUI
2022-12-05 05:50 taiwbi File Added: Screenshot from 2022-11-29 13-42-40.png
2022-12-05 05:50 taiwbi File Added: Screenshot from 2022-12-05 09-15-06.png
2022-12-05 05:50 taiwbi File Added: Screenshot from 2022-12-05 09-16-00.png
2022-12-05 05:50 taiwbi File Added: Screenshot from 2022-12-05 09-17-29.png
2022-12-05 05:50 taiwbi File Deleted: Screenshot from 2022-11-29 13-42-40.png
2022-12-05 14:24 jghali Summary In a text frame, if style one parapgraph left to right and another right to left, one of the paragraphs will not work properly. => In a text frame, if style one paragraph left to right and another right to left, one of the paragraphs will not work properly.
2022-12-05 22:41 jghali Summary In a text frame, if style one paragraph left to right and another right to left, one of the paragraphs will not work properly. => If a right to left paragraph follows a left to right paragraph, one of the paragraphs will not work properly
2022-12-05 22:42 jghali Assigned To => jghali
2022-12-05 22:42 jghali Status new => resolved
2022-12-05 22:42 jghali Resolution open => fixed
2022-12-05 22:42 jghali Fixed in Version => 1.5.9.svn