View Issue Details

IDProjectCategoryView StatusLast Update
0000201ScribusStylespublic2005-05-15 09:47
Reporterale Assigned Tofschmid  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version1.2.2cvs 
Fixed in Version1.2.2cvs 
Summary0000201: paragraph indent/tabulator disturbed by a floating image
DescriptionIf a text floats on the right side of a picture, the indent and the tabulators are still referenced to the left margin of the text frame.

That's not the way i expect the floating to work :-)

I understand that this could be correct if with the tabs I was trying to simulate a table, but not if i am simulating a bulletted list...

A solution to the problem could be that the tabulator character doesn't only skip to the next tab but also to the left indent if there is one.

Then, the tabublator marks could always reference the left margin of the frame and the indents would refere to the real start of the characters.

The attached images show the two examples in scribus and in ooffice.
TagsNo tags attached.
Patch

Activities

ale

2004-01-23 18:12

manager   ~0000297

sorry, i was in a hurry, it's not a documentation feature... it's a styles minor bug... but i can't change it anymore... can somebody change it for me?

2004-01-23 18:13

 

scribus_list.png (22,477 bytes)   
scribus_list.png (22,477 bytes)   

2004-01-23 18:13

 

ooffice_liste.png (29,846 bytes)   
ooffice_liste.png (29,846 bytes)   

plinnell

2004-04-25 14:57

viewer   ~0001186

Can you upload a sample file to test this with ?

louisdesjardins

2005-02-10 22:16

developer   ~0003686

Hope you don't mind if I send a reminder about this issue. :)

I faced the same with a first line indent that became a no-indent-at-all with a picture overlapping a bit the column to the left (so text flow along the right side of the picture frame). All other indents at beginning of paragraphs were ok except the ones alongside this picture frame... Basically, the indent doesn't care about surrounding elements and doesn't care either about the runaround option. Bad guy!

louisdesjardins

2005-04-29 01:02

developer   ~0004452

Reminder sent to: cbradney

Hi Craig!
Sorry this reminder falls on you! (first time I use this feature on bugs.scribus)
Since the question was raised again on the list, I thought of letting you know this wasn't solved as we're approaching 1.2.2 ...
The bug is well described imo but if you need screenshot examples or case description, please let me know.

fschmid

2005-05-11 04:29

administrator   ~0004578

Could possibly be fixed now in 1.3.0cvs

plinnell

2005-05-15 09:47

viewer   ~0004635

tested the fix in 1.2.2cvs and its correct now from what i can see

Issue History

Date Modified Username Field Change
2004-01-23 18:10 ale New Issue
2004-01-23 18:12 ale Note Added: 0000297
2004-01-23 18:13 ale File Added: scribus_list.png
2004-01-23 18:13 ale File Added: ooffice_liste.png
2004-01-23 19:17 cbradney Category Documentation => General
2004-02-18 20:35 cbradney Category General => Styles
2004-04-25 14:57 plinnell Note Added: 0001186
2005-02-10 22:16 louisdesjardins Note Added: 0003686
2005-04-29 01:02 louisdesjardins Note Added: 0004452
2005-04-29 05:09 cbradney Status new => assigned
2005-04-29 05:09 cbradney Assigned To => fschmid
2005-04-29 05:09 cbradney Product Version => 1.2.2cvs
2005-05-11 04:29 fschmid Note Added: 0004578
2005-05-14 09:43 fschmid Status assigned => resolved
2005-05-14 09:43 fschmid Fixed in Version => 1.2.2cvs
2005-05-14 09:43 fschmid Resolution open => fixed
2005-05-15 09:47 plinnell Note Added: 0004635
2005-05-15 09:47 plinnell Status resolved => closed