View Issue Details

IDProjectCategoryView StatusLast Update
0002114ScribusUser Interfacepublic2006-04-20 23:26
ReporterringercAssigned Tocbradney  
PrioritynoneSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
Platformx86 LinuxOSFedora CoreOS Version3
Product Version 
Target VersionFixed in Version 
Summary0002114: Visual warning of low-res images
DescriptionLots of people seem to have trouble understanding image resolution, and that they can't usually just use a picture from a website at whatever size they feel like ("it looks good on screen"). Perhaps it's worth visually indicating when an image is outside the minimum resolution permitted by the active preflight profile - for example, by dithering the image in red and printing "LOW RES" on it?

Questions open:
   - How to make it obvious what's happening and where to get more info
   - Best way to indiciate below min res
   - Best, most "discoverable" way to handle turning it off if you want to.
TagsNo tags attached.
Patch

Relationships

duplicate of 0003623 closedfschmid preflight should report the dpi value if it too low 
related to 0002931 acknowledged Metabug: SVG 

Activities

christoph_s

2005-07-23 21:31

administrator   ~0005679

Last edited: 2005-07-24 02:07

>>>Lots of people seem to have trouble understanding image resolution, and that they can't usually just use a picture from a website at whatever size they feel like ("it looks good on screen").

Yep, costs me a lot of time and therefore money to explain it to customers.

>>>Perhaps it's worth visually indicating when an image is outside the minimum resolution permitted by the active preflight profile - for example, by dithering the image in red and printing "LOW RES" on it?

Excellent idea!!! Here's what I usually do: I make the image transparent and place a symbol on it, depending on my sympathies it's a warning sign, a skull, or a red cross (unless the picture is red, of course). So the customer will see in the PDF or the printout that this picture can't be printed.

>>>How to make it obvious what's happening and where to get more info

If it's your customer, you have your knowledge and can explain the problem to him. If it's PEBKAC problem, maybe we need a section in the docs (IIRC, the problem is already mentioned somewhere).

>>>Best way to indiciate below min res

A set of symbols, perhaps, to choose from. Additionally, the picture could be made transparent or inverted.

>>>Best, most "discoverable" way to handle turning it off if you want to

Preferences -> Preflight check (or a dialog/tab of its own). What we need here are check boxes for:

[] Check for image resolutions below [^](insert number or choose from the list
[] Mark images in
   [] PDF output
   [] EPS output
   [] Print

Markup options:

[] Manipulate image: [^] (invert, transparency, opacity ...)

[] Add symbol: [^] (choose from list of symbols)

[] Add coloured frame [^] (choose *really ugly* colour)

[] more/others I don't think of right now


[] Show in preflight check (in the preflight check dialog, a tooltip could hint to the chapter in the docs)



Some problems will unfortunately remain:

1) If people only resample www-pictures (happens all the time), the check will fail

2) What about low-res pictures in EPS, SVG ... files?

cbradney

2006-04-20 23:25

administrator   ~0010220

Preflight Verifier...

Issue History

Date Modified Username Field Change
2005-06-22 00:06 ringerc New Issue
2005-06-22 01:13 ringerc Status new => acknowledged
2005-07-23 21:31 christoph_s Note Added: 0005679
2005-07-24 02:07 christoph_s Note Edited: 0005679
2006-04-20 23:25 cbradney Relationship added duplicate of 0003623
2006-04-20 23:25 cbradney Duplicate ID 0 => 3623
2006-04-20 23:25 cbradney Status acknowledged => resolved
2006-04-20 23:25 cbradney Resolution open => duplicate
2006-04-20 23:25 cbradney Assigned To => cbradney
2006-04-20 23:25 cbradney Note Added: 0010220
2006-04-20 23:26 cbradney Status resolved => closed
2006-05-17 18:46 christoph_s Relationship added related to 0002931