View Issue Details

IDProjectCategoryView StatusLast Update
0002425ScribusStory Editor / Text Framespublic2005-09-25 20:00
Reporterchristoph_s Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Platformx86OSLinuxOS VersionSuSE 9.3
Product Version1.3.1cvs 
Target VersionFixed in Version 
Summary0002425: Scribus ignores "No" in dialogs
DescriptionOn SuSE 9.3, scribus ignores "No" in warnings dialogs for text frames and the story editor. This happens with *all* current versions of scribus (1.2.2.1, 1.2.2.99, 1.3.0, and 1.3.1cvs).
Additional Information(copied from bug # 0002411:)
Recipe for Story Editor

1. Open an existing text frame.
2. Enter new text.
3. Click on icon for "clear text"
4. Get Warning message "Do you really want to clear all your Text"?
5. Click on "no", but it happens anyway.

Recipe for Sample Text.

1. Right click on text frame.
2. Select "Insert sample text"
3. Get same Warning message: "Do you really want to clear all your Text"?
4. Click "no"
5. Sample text is inserted.
TagsNo tags attached.
Patch

Relationships

has duplicate 0002411 closedfschmid answering "No" to warning messages has no effect 
has duplicate 0002443 closed Layers Dialog show Yes and Yes on Suse 9.3 and ignores No 
has duplicate 0002543 closedplinnell Blank Print Preview 
related to 0002763 closedplinnell Additional Font paths get the font path clipped by 1 character 
related to 0004232 closedplinnell Importing SVG distorted in kubuntu 

Activities

fschmid

2005-08-11 23:17

administrator   ~0006082

Thats very odd, i tested this here, and it works as it should. I'm using Suse 9.1 and i checked all the code in question. The code is written exactly following the Qt Documentation. So i think thats a Suse 9.3 bug.

2005-08-13 05:02

 

messagetest.cpp (538 bytes)

ringerc

2005-08-13 05:04

reporter   ~0006096

I'd be curious to see what the console output of the attached program is for each of its buttons.

first:

mkdir messagetest
cd messagetest

copy messagetest.cpp into the directory, then:

qmake -project
qmake
make

and run as ./messagetest .

fschmid

2005-08-13 06:59

administrator   ~0006100

Compiled and tested the sample app:
Button "Yes" pressed = Output is "Yes"
Button "No" pressed = Outpus is "No"
just as expected.

ringerc

2005-08-13 07:14

reporter   ~0006102

Sorry Franz, that was directed more at Christoph - it's just a test to see if maybe his Qt is really amazingly broken as you suggested, or if there's something more subtle going on.

christoph_s

2005-08-13 15:04

administrator   ~0006107

Hi Craig,
the results on SuSE 9.3 are the same as Franz':

Clicking "Yes" results in "Yes", clicking "No" results in "No".

Odd ...

fschmid

2005-08-16 23:54

administrator   ~0006133

Please check the file qmessagebox.h, usually to be found at /usr/lib/qt3/include on a Suse installation.

At line 71 starts an enumeration which should be like this:
enum { NoButton = 0, Ok = 1, Cancel = 2, Yes = 3, No = 4, Abort = 5,
       Retry = 6, Ignore = 7, YesAll = 8, NoAll = 9, ButtonMask = 0xff,
       Default = 0x100, Escape = 0x200, FlagMask = 0x300 };

Seems that under Suse 9.3 the values for Yes and No are messed up.

2005-08-17 02:54

 

qmessagebox.h (7,519 bytes)

christoph_s

2005-08-17 02:58

administrator   ~0006135

Hi Franz,

I just uploaded the qmessagebox.h file from SuSE 9.3. Everything you mentioned seems to be as expected. Did you contact the SuSE developers already?

ringerc

2005-08-17 05:26

reporter   ~0006136

Before doing that, we should really be able to provide a test case that shows the problem.

The fact that the simple test program I attached does not implies that there's something else going on, somewhere, beyond just qmessagebox.h and QMessageBox in libqt-mt .

2005-08-17 09:48

 

qtpatches.tar.bz (187,322 bytes)

plinnell

2005-08-17 09:49

viewer   ~0006138

uploaded all the patches applied to qt 3.3.4-11.3 for suse 9.3 - qt.patch has some changes to qmessagebox.cpp

plinnell

2005-08-17 10:23

viewer   ~0006139

3.3.4-24 (latest Qt shippped with kde 3.4.2 for 9.3) has the same issue.

christoph_s

2005-08-18 23:35

administrator   ~0006150

OK, here is the next part of the saga: In 1.3.1cvs from the 18th of August, in the dialogs mentioned above, "Yes" and "No" are inverted (Yes on the right, No on the left). No matter what you click, the action will be executed.

fschmid

2005-08-29 21:02

administrator   ~0006297

Just for completeness there is an interesting thread on the Qt-interest mailing list: http://lists.trolltech.com/qt-interest/2005-08/thread01346-0.html
Seems to be exactly the same problem.

cbradney

2005-09-15 21:44

administrator   ~0006590

Last edited: 2005-09-15 21:45

Try this: export QT_NO_KDE_INTEGRATION=1
and run Scribus

plinnell

2005-09-15 21:53

viewer   ~0006594

export QT_NO_KDE_INTEGRATION=1 fixes the issue

plinnell

2005-09-15 22:41

viewer   ~0006595

Suse Bug Ticket [20050916990000010]

ringerc

2005-09-16 02:08

reporter   ~0006599

It seems reasonable to resolve this as NOTABUG. Might want to leave it resolved but not closed so people find it in default searches, though.

christoph_s

2005-09-16 18:57

administrator   ~0006607

export QT_NO_KDE_INTEGRATION=1 changes nothing on my machine. Scribus behaves exactly as it did before.

cbradney

2005-09-16 19:51

administrator   ~0006608

You have to export it and run Scribus from the same shell, or make that appear in your environment by putting it in your shell's startup file like .bashrc.

ringerc

2005-09-17 07:05

reporter   ~0006620

If I'm repeating things you already know christoph, then sorry - but better to explain these things than assume.

That command sets an environment variable. It takes effect only for programs run from the shell in which the environment variable was set, and it's not saved anywhere so it is lost on reboot.

To make the effect persistent, you might want to add the command to $HOME/.bashrc or your X login script.

Alternately, if you want it to only affect Scribus, you can make a wrapper script containing:

#!/bin/bash
QT_NO_KDE_INTEGRATION=1 /path/to/scribus $@

save those two lines to a file somewhere, then run "chmod a+x" on it, and run that script instead of Scribus when starting up. In general, tweaking your .bashrc is simpler and easier.

ringerc

2005-09-17 07:15

reporter   ~0006621

Updated. Worth resolving now?

christoph_s

2005-09-17 18:34

administrator   ~0006630

Hi Craig,

thanks for your advice. I already had ~bash.rc edited when you added your instructions. The former error seemed to be a result of too many open shells, thus my fault.

If there was a short article on the Wiki for this workaround, the issue might be resolved, IMHO.

christoph_s

2005-09-17 21:44

administrator   ~0006634

Added an article to the Wiki:
h++p://wiki.scribus.net/index.php/A_workaround_for_a_Qt3_bug_under_SuSE_9.3

This is something that can easily be referenced to when questions on the issue arise on the list or on IRC.

Issue History

Date Modified Username Field Change
2005-08-11 18:37 christoph_s New Issue
2005-08-11 23:17 fschmid Note Added: 0006082
2005-08-13 04:55 ringerc Status new => acknowledged
2005-08-13 05:02 ringerc File Added: messagetest.cpp
2005-08-13 05:04 ringerc Note Added: 0006096
2005-08-13 06:59 fschmid Note Added: 0006100
2005-08-13 07:14 ringerc Note Added: 0006102
2005-08-13 15:04 christoph_s Note Added: 0006107
2005-08-16 23:50 fschmid Relationship added related to 0002411
2005-08-16 23:54 fschmid Note Added: 0006133
2005-08-17 02:54 christoph_s File Added: qmessagebox.h
2005-08-17 02:58 christoph_s Note Added: 0006135
2005-08-17 05:26 ringerc Note Added: 0006136
2005-08-17 09:48 plinnell File Added: qtpatches.tar.bz
2005-08-17 09:49 plinnell Note Added: 0006138
2005-08-17 10:23 plinnell Note Added: 0006139
2005-08-17 10:32 plinnell Relationship added related to 0002443
2005-08-18 23:35 christoph_s Note Added: 0006150
2005-08-29 21:02 fschmid Note Added: 0006297
2005-09-04 21:22 plinnell Relationship replaced has duplicate 0002411
2005-09-12 20:47 plinnell Relationship replaced has duplicate 0002443
2005-09-15 21:44 cbradney Note Added: 0006590
2005-09-15 21:45 cbradney Note Edited: 0006590
2005-09-15 21:53 plinnell Note Added: 0006594
2005-09-15 22:41 plinnell Note Added: 0006595
2005-09-16 02:08 ringerc Note Added: 0006599
2005-09-16 11:05 plinnell Relationship added has duplicate 0002543
2005-09-16 18:57 christoph_s Note Added: 0006607
2005-09-16 19:51 cbradney Note Added: 0006608
2005-09-17 07:05 ringerc Note Added: 0006620
2005-09-17 07:15 ringerc Note Added: 0006621
2005-09-17 07:15 ringerc Status acknowledged => confirmed
2005-09-17 07:15 ringerc Resolution open => no change required
2005-09-17 18:34 christoph_s Note Added: 0006630
2005-09-17 21:44 christoph_s Note Added: 0006634
2005-09-25 20:00 cbradney Status confirmed => closed
2005-10-26 16:24 ringerc Relationship added related to 0002763
2006-09-11 06:00 ringerc Relationship added related to 0004232
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames