View Issue Details

IDProjectCategoryView StatusLast Update
0002591ScribusGeneralpublic2008-02-08 19:42
Reportermhanski Assigned Tofschmid  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformAMD Athlon XP 3000+OSGentoo LinuxOS Versioncurrent
Product Version1.2.3cvs 
Target VersionFixed in Version1.3.3.10svn 
Summary0002591: Hyphenation: Wrong behaviour in connection with "t" glyph
DescriptionSee the attached screen shot - the hyphenator leaves the "t" glyph in the same line behind a hyphen, instead of moving the "t" to the next line.
Additional Informationgerman text, german hyphenation
TagsNo tags attached.
Patch

Relationships

child of 0003828 acknowledged Metabug: Hyphenation 

Activities

2005-09-21 10:41

 

de_hyphenation_error.png (143,085 bytes)
de_hyphenation_error.png (143,085 bytes)

fschmid

2005-09-21 11:17

administrator   ~0006663

Seeing the screenshot i must say you have an old version running, please try the latest CVS.

cbradney

2005-09-21 13:09

administrator   ~0006664

Err, what version is this for? 1.3.1cvs or 1.2.4cvs? You had selected 1.3.2cvs which we are not up to yet..

mhanski

2005-09-21 13:19

developer   ~0006665

Sorry for the wrong version: it happens with Scribus 1.2.99 from August 30, and not in the 1.3.x series as far as I can tell. I cannot update to 1.2.3 right now, since I'm in the middle of designing a leaflet for my company and don't like to risk an additional delay. As soon as I can update to 1.2.3 (probably tomorrow), I'm going to test it elaborately once again -- I'll let you know, then.

cbradney

2005-09-21 13:27

administrator   ~0006666

ok, thanks

2005-09-21 21:21

 

de_hyphenation_1.2.99.png (111,870 bytes)
de_hyphenation_1.2.99.png (111,870 bytes)

2005-09-21 21:22

 

de_hyphenation_1.3.1.png (93,806 bytes)
de_hyphenation_1.3.1.png (93,806 bytes)

2005-09-21 21:23

 

de_hyph_test123.sla (30,816 bytes)

2005-09-21 21:23

 

de_hyph_test131.sla (42,245 bytes)

mhanski

2005-09-21 21:28

developer   ~0006667

- Ok, I updated to 1.2.3 and discovered yet another issue with "f" (see de_hyphenation_1.2.99.png and de_hyph_test123.sla)

- I also opened this file in 1.3.1cvs, saved it in the new format and played a little bit with it. I could reproduce the same issue with "t" as in 1.2.99 (see de_hyphenation_1.3.1.png and de_hyph_test131.sla)

Hope it helps :)

fschmid

2005-09-25 10:27

administrator   ~0006720

Backported fix to the 1.2.x branch.

plinnell

2005-09-25 13:15

viewer   ~0006724

teted both branches and it is fixed

plinnell

2005-09-25 21:08

viewer   ~0006743

Maciej, Please test this some more, but I am convinced its fixed. Thanks.

mhanski

2005-09-26 17:44

developer   ~0006755

Tested the fixes once more in 1.2.3.99 from September 25 and 1.3.2cvs, everything works fine now. Well done, thanks!

christoph_s

2006-10-05 23:33

administrator   ~0012819

I'm sorry to say it, but the issue is back. See uploaded screenshot made in 1.3.3.5cvs, 5 October 2006.

2006-10-05 23:34

 

single-glyph.png (35,952 bytes)
single-glyph.png (35,952 bytes)

christoph_s

2006-10-05 23:38

administrator   ~0012820

I also ran across the issue more than once in 1.2.5.

mhanski

2007-12-19 22:47

developer   ~0018361

works fine for me with 1.3.3.10cvs (opensuse 10.3). Christoph, can this one be closed?

christoph_s

2007-12-20 18:05

administrator   ~0018370

At least it does work with your test files.

mhanski

2007-12-20 18:42

developer   ~0018371

thx, closing

Issue History

Date Modified Username Field Change
2005-09-21 10:41 mhanski New Issue
2005-09-21 10:41 mhanski File Added: de_hyphenation_error.png
2005-09-21 10:44 mhanski Summary Hyphanation: Wrong behaviour in connection with "t" glyph => Hyphenation: Wrong behaviour in connection with "t" glyph
2005-09-21 11:17 fschmid Note Added: 0006663
2005-09-21 13:09 cbradney Product Version 1.3.2cvs => 1.3.1cvs
2005-09-21 13:09 cbradney Note Added: 0006664
2005-09-21 13:12 mhanski Product Version 1.3.1cvs => 1.2.3
2005-09-21 13:19 mhanski Note Added: 0006665
2005-09-21 13:27 cbradney Note Added: 0006666
2005-09-21 13:27 cbradney Product Version 1.2.3 => 1.2.3cvs
2005-09-21 21:21 mhanski File Added: de_hyphenation_1.2.99.png
2005-09-21 21:22 mhanski File Added: de_hyphenation_1.3.1.png
2005-09-21 21:23 mhanski File Added: de_hyph_test123.sla
2005-09-21 21:23 mhanski File Added: de_hyph_test131.sla
2005-09-21 21:28 mhanski Note Added: 0006667
2005-09-21 23:43 fschmid Status new => resolved
2005-09-21 23:43 fschmid Fixed in Version => 1.3.1cvs
2005-09-21 23:43 fschmid Resolution open => fixed
2005-09-21 23:43 fschmid Assigned To => fschmid
2005-09-25 10:27 fschmid Note Added: 0006720
2005-09-25 11:48 plinnell Fixed in Version 1.3.1cvs => 1.2.4cvs
2005-09-25 13:15 plinnell Status resolved => closed
2005-09-25 13:15 plinnell Note Added: 0006724
2005-09-25 21:08 plinnell Note Added: 0006743
2005-09-26 17:44 mhanski Status closed => feedback
2005-09-26 17:44 mhanski Resolution fixed => reopened
2005-09-26 17:44 mhanski Note Added: 0006755
2005-09-26 17:47 mhanski Resolution reopened => fixed
2005-09-26 19:06 fschmid Status feedback => resolved
2005-09-26 19:12 cbradney Status resolved => closed
2006-05-16 22:07 christoph_s Relationship added child of 0003828
2006-10-05 23:33 christoph_s Status closed => feedback
2006-10-05 23:33 christoph_s Resolution fixed => reopened
2006-10-05 23:33 christoph_s Note Added: 0012819
2006-10-05 23:34 christoph_s File Added: single-glyph.png
2006-10-05 23:38 christoph_s Note Added: 0012820
2007-12-19 22:47 mhanski Note Added: 0018361
2007-12-20 18:05 christoph_s Note Added: 0018370
2007-12-20 18:42 mhanski Note Added: 0018371
2007-12-20 18:42 mhanski Status feedback => closed
2007-12-20 18:42 mhanski Fixed in Version 1.2.4cvs => 1.3.3.10cvs
2008-02-08 19:42 christoph_s Status closed => resolved
2008-02-08 19:42 christoph_s Resolution reopened => fixed
2008-02-08 19:42 christoph_s Status resolved => closed