View Issue Details

IDProjectCategoryView StatusLast Update
0003255ScribusStory Editor / Text Framespublic2006-11-26 21:55
ReporterOliver Klee Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntu LinuxOS Version5.10
Product Version1.2.4.1 
Target VersionFixed in Version1.3.4cvs 
Summary0003255: Changed style doesn't persist when typing
DescriptionWhen you change the text size within a text frame and then type some more text in the middle of the text, it doesn't have the same size.

Steps to reproduce:
1. Create a style "test" with font size 16pt.
2. Create a text frame.
3. Write some text into it.
4. Assign the style "test" to the text.
5. Change the text size of the typed text to 22pt.
6. Put the cursor somewhere into the text.
7. Type a letter.

Expected result:
The typed text has the same size as the surrounding text (22pt).

Expected result:
The typed text has the style's size (16pt) instead of the surrounding text's size.
TagsNo tags attached.
Patch

Relationships

related to 0003261 confirmed Changing text alignment from the properties palette does behave weird sometimes 
related to 0003566 closed Changing font doesn't reload the text correctly sometimes. 
related to 0003157 acknowledged Metabug: Cursor placement fixes 

Activities

christoph_s

2006-02-17 19:19

administrator   ~0008788

I don't think this is an issue, since it is the expected behaviour in word processors and DTP apps alike. Simply said: manual formatting overrides styles. Try the same in OO.o Writer, Word or Quark or whatever. All behave the same.

Oliver Klee

2006-02-20 21:09

reporter   ~0008839

Sorry for the confusion, I had the subheadings mixed. This should read:

Expected result:
The typed text has the same size as the surrounding text (22pt).

Actual result:
The typed text has the style's size (16pt) instead of the surrounding text's size.

christoph_s

2006-02-20 21:19

administrator   ~0008842

Yes, you're right. Tested with 1.2.4.1. IMHO it is inconsistent if a style can only be partially overwritten. Either no changes at all if a style is applied (no good idea) or overwriting of all style attributes manually.

Issue History

Date Modified Username Field Change
2006-02-17 15:21 Oliver Klee New Issue
2006-02-17 19:19 christoph_s Note Added: 0008788
2006-02-20 21:09 Oliver Klee Note Added: 0008839
2006-02-20 21:19 christoph_s Note Added: 0008842
2006-04-17 16:33 mhanski Relationship added related to 0003261
2006-04-20 20:18 mhanski Relationship added related to 0003566
2006-04-28 10:53 mhanski Status new => confirmed
2006-04-28 10:53 mhanski Product Version 1.2.2.1cvs => 1.2.4.1
2006-04-28 10:53 mhanski Build 05 July 2005C-C-T =>
2006-11-26 21:55 cbradney Status confirmed => closed
2006-11-26 21:55 cbradney Resolution open => fixed
2006-11-26 21:55 cbradney Fixed in Version => 1.3.4cvs
2007-05-23 21:18 christoph_s Relationship added related to 0003157
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames