View Issue Details

IDProjectCategoryView StatusLast Update
0004195ScribusImport / Exportpublic2008-02-26 23:40
Reportermalex Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSLinuxOS Version2.6
Product Version1.3.3.3 
Target VersionFixed in Version1.3.5svn 
Summary0004195: SVG import is broken - example image available.
Descriptionhttp://websvn.kde.org/*checkout*/trunk/playground/artwork/Oxygen/theme/svg/actions/chronometer.svg?rev=546749 import is totally broken. I've tried plain svg, inkscape svg, svg->eps in the inkscape - nothing worked.
TagsNo tags attached.
Patch

Relationships

child of 0002931 acknowledged Metabug: SVG 

Activities

2006-08-30 17:59

 

chronometer.svg (152,377 bytes)

jghali

2006-09-03 23:24

administrator   ~0012423

Patches which noticeably improve radial gradient handling and text positioning have been committed to both 1.3.3.4cvs and 1.3.4cvs. All is not perfect, but far better already.

jghali

2006-09-04 16:24

administrator   ~0012432

Another part of the problem is that we are currently unable to handle gradients whose starting and ending points are outside frame bounds

jghali

2006-09-06 00:43

administrator   ~0012450

A patch has now been applied to 1.3.4cvs which allow to define gradient end points outside of frame bounds. That patch gonna be backported in 133x branch for 1.3.3.5 latest. Except text elements, chronometer.svg import works well now.

cbradney

2007-01-01 22:37

administrator   ~0014356

Downgrading to minor now it works kind of ok. Its import, not export, PDF etc so major doesnt apply.

jghali

2007-09-17 15:45

administrator   ~0017308

Text is now imported as vector and chronometer.svg can now be imported almost perfectly. What is missing is gradient repeat mode : that svg uses gradient reflect mode which is not supported by scribus yet.

jghali

2008-02-26 22:56

administrator   ~0019112

Closing that one now as support for gradient reflect and repeat is part of 0004293

Issue History

Date Modified Username Field Change
2006-08-30 17:59 malex New Issue
2006-08-30 17:59 malex File Added: chronometer.svg
2006-08-30 20:26 plinnell Relationship added child of 0002931
2006-08-30 20:26 plinnell Status new => acknowledged
2006-09-03 23:24 jghali Note Added: 0012423
2006-09-04 16:24 jghali Note Added: 0012432
2006-09-06 00:43 jghali Note Added: 0012450
2006-09-06 00:44 jghali Status acknowledged => assigned
2006-09-06 00:44 jghali Assigned To => jghali
2007-01-01 22:37 cbradney Note Added: 0014356
2007-01-01 22:37 cbradney Severity major => minor
2007-09-17 15:45 jghali Note Added: 0017308
2008-02-26 22:56 jghali Status assigned => resolved
2008-02-26 22:56 jghali Fixed in Version => 1.3.5svn
2008-02-26 22:56 jghali Resolution open => fixed
2008-02-26 22:56 jghali Note Added: 0019112
2008-02-26 23:40 jghali Status resolved => closed