View Issue Details

IDProjectCategoryView StatusLast Update
0004263ScribusStory Editor / Text Framespublic2006-11-16 23:42
ReporterPLucAuclair Assigned Toavox  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSSuse 10.0OS VersionCVS 1.3.4
Product Version 
Target VersionFixed in Version1.3.4cvs 
Summary0004263: First letter problem & last letter cannot be reached. (text cursor bug)
DescriptionWhen you start typing in a text frame the first letter you type is always put in front of all the other. Also similar the last letter cannot be selected, since the cursor will never put itself at the end.

e.g.: Valéri|e

Even when moving the cursor with the keyboard, it's impossible to select the last letter. All you can do is press delete to remove it since it's in front of it.

This seems to be the cause of the first letter bug, but I cannot be sure.

e.g.: (every new line is a new key pressed)
oT
omT
om T
om, T
om, hT
om, hiT
om, hi!T

Hope this makes sense.
TagsNo tags attached.
Patch

Relationships

has duplicate 0004348 closedcbradney Weired text field 
child of 0003157 acknowledged Metabug: Cursor placement fixes 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2006-09-17 21:34 PLucAuclair New Issue
2006-10-03 09:33 cbradney Relationship added has duplicate 0004348
2006-11-16 23:41 cbradney Status new => assigned
2006-11-16 23:41 cbradney Assigned To => avox
2006-11-16 23:42 cbradney Status assigned => resolved
2006-11-16 23:42 cbradney Fixed in Version => 1.3.4cvs
2006-11-16 23:42 cbradney Resolution open => fixed
2006-11-16 23:42 cbradney Status resolved => closed
2007-05-23 21:19 christoph_s Relationship added child of 0003157
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames