View Issue Details

IDProjectCategoryView StatusLast Update
0004387ScribusWebsitepublic2007-12-19 22:48
Reportermhanski Assigned Toltning  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platform-OS-OS Version-
Product Version 
Target VersionFixed in Version 
Summary0004387: bugs.scribus.net and wiki.scribus.net: Long response times
DescriptionBug tracker and Wiki: we have had very long webserver response times for a longer period of time by now. It's definitely something to be looked on and tweaked by the webserver administrator.

Tested with Firefox (long responce times) on both Linux and Win32 platforms and with IE 6.* (desastrous responce times)

TagsNo tags attached.
Patch

Activities

cbradney

2006-10-10 12:12

administrator   ~0012879

Response is immediate for me.

mhanski

2006-10-10 12:22

developer   ~0012881

Last edited: 2006-10-10 12:29

Current (meaning now) response times for the Wiki Main Page http://wiki.scribus.net/index.php/Main_Page, measured in my office in Vienna, 2 MBit downstream:

IE 6.*: ~ 90 sec
Firefox 1.5.0.7: ~ 20 sec

For http://bugs.scribus.net/my_view_page.php :

IE 6.*: ~ 40 sec
Firefox 1.5.0.7: ~ 4 sec

mhanski

2006-10-10 13:13

developer   ~0012883

Measured somewhere in Australia:

"Takes around 9-10 seconds here to load wiki thi scribus icon in rh
corner seems to be the last object? to load
on Linux using FireFox. A little bit slower using konqueror

catchya
Dean"

mhanski

2006-10-10 18:04

developer   ~0012887

Tested at home on Linux and http://wiki.scribus.net/index.php/Main_Page

- Firefox 1.5.0.7: ~ 17 sec
- Konqueror 3.5.3: ~ 4 sec

jghali

2006-10-10 18:20

administrator   ~0012888

Tested from a small town in France:
http://wiki.scribus.net/index.php/Main_Page :
IE6: immediate
Firefox 1.5.0.7: immediate

http://bugs.scribus.net/my_view_page.php
IE6: 0000036:0000010 sec
Firefox 1.5.0.7: 0000011:0000003 sec

christoph_s

2006-10-10 18:49

administrator   ~0012891

Tested from Germany, SuSE Linux 10.1:

Konqueror: 4 seconds
SeaMonkey 1.0.5: Forever, more than 20 seconds

Using a DSL connection.

I have also been wondering why the Scribus sites have become extremely slow recently, esp. in Mozilla/Firefox/SeaMonkey.

plinnell

2006-10-10 19:19

viewer   ~0012893

Seems Ok here on 8Mb DSL with FF, seamonkey and Konqui Suse 10.1

christoph_s

2006-10-10 19:39

administrator   ~0012894

Some recent updates made by Peter are also gone since the last server downtime. See e.g. http://docs.scribus.net/index.php?lang=en&page=install1

ltning

2006-10-11 06:13

developer   ~0012903

I have a hunch what the problem might be. Can someone please confirm that it is working fine right now? Once I get that confirmation, I'll apply the change I'm planning.

mhanski

2006-10-11 08:29

developer   ~0012909

ltning: Yes, I can confirm, it's radically better now:)

Measured from my office in Vienna:

http://wiki.scribus.net/index.php/Main_Page

IE 6.*: ~ 4 sec
Firefox 1.5.0.7: ~ 4 sec

http://bugs.scribus.net/my_view_page.php

IE 6.*: ~ 4 sec
Firefox 1.5.0.7: ~ 4 sec

Just out of curiosity: What was it?

ltning

2006-10-11 08:43

developer   ~0012910

The problem seems to be PF-related. I am using PF (packet filter, originally from OpenBSD, now also standard firewall in FreeBSD) to redirect incoming traffic to a transparent proxy server. As the proxy server in question is used at some of the busiest (including *the* busiest), I looked at PF to find the problem.

The current theory is that I have a problem with packet reordering. As PF redirects from/to the same IP address, there could theoretically be a problem with TCP sequence numbers when re-using a connection. I will try to work around this by having the proxy server listen on a different IP address, thereby making the sequence numbers irrelevant to packet identification.

Anyone with hints or tips around this are welcome to get in touch with me ;)

mhanski

2006-10-12 18:05

developer   ~0012944

Last edited: 2006-10-12 18:08

ltning: I'm so happy with the current speed (what a feeling! Working with Scribus Wiki is fun again:), that I simply have to ask, if you just couldn't leave it the way it is now -- I assume, you pass the incoming traffic directly to the webserver machine.

<quote>I am using PF (packet filter, originally from OpenBSD, now also standard firewall in FreeBSD) to redirect incoming traffic to a transparent proxy server. As the proxy server in question is used at some of the busiest (including *the* busiest)</quote>

I don't have any experience with proxies (only with our Cisco Pix firewall), but what exactly would be the advantage of redirecting _incoming_ traffic to a transparent proxy? No irony, it's a serious question, since I've just read that transparent proxies were useful for outcoming requests for obvious reasons (no need to manually add proxies in client configuration, less traffic).

ltning

2006-10-13 05:54

developer   ~0012945

By having that proxy there I'm cutting server load by >50%.
The alternative is to have someone buy me more hardware.... ;)
Good enough reason to use it, if I can make it work right?

Btw: If the problem is what I suspect, it's actually your PC/router/whatever that is causing the problem by re-using an outgoing port number for a new connection before 90 seconds or so has passed. This violates the TCP RFC. Just FYI ;)

mhanski

2006-10-13 07:45

developer   ~0012946

Last edited: 2006-10-13 08:01

<quote>Btw: If the problem is what I suspect, it's actually your PC/router/whatever that is causing the problem by re-using an outgoing port number for a new connection before 90 seconds or so has passed. This violates the TCP RFC. Just FYI ;)</quote>

ltning: just to make clear what's about: my "PC/router/whatever" is a number of PC's (over 20), connecting to the internet through a Cisco PIX 506E firewall and a Cisco router, no proxies, no DMZ or such stuff -- I've observed the behaviour over a longer period of time. Then there is my PC at home: pretty much the same, a stock Linksys router between me and the internet. Then there are some other users over the world which encounter the issue, e.g. see the c_schaefer's report above. Or there was a user, for whom I'd created a wiki account, who reported the following:
"Thanks; I have successfully logged on and started editing. Can you tell me why the page loading is so slow? It takes about a minute to load the Wiki preview, for example."

mhanski

2006-10-13 10:09

developer   ~0012947

<quote>The alternative is to have someone buy me more hardware.... ;)</quote>

Just an additional idea: what kind of hardware at what estimated cost would it be? If you deliver your IBAN/SWIFT or PAY PAL account number (soon:), we could place a request for donations on the wiki main page, and post to the mailing list. I would gladly donate a few euros myself.

ltning

2006-10-13 14:21

developer   ~0012952

I agree, the problem I describe seems highly unlikely to be the cause. I'll do some further digging. It could also be a timing issue. Do you have a special MTU setting on your connection? Using PPPoE or something?

As for hardware, I'm doing some upgrades today (more memory, disk). Some on the Scribus team has already donated some to that end, others are of course welcome to do so, though it hasn't been widely announced. I believe there's some work going on to set up a non-profit organization that can collect donations directly, and distribute where needed - which is a much cleaner approach.

Of course if you wish to donate to the hosting specifically, you're most welcome to. There is info about that on some of the scribus pages (wiki?).

mhanski

2006-10-13 14:32

developer   ~0012953

<quote>Of course if you wish to donate to the hosting specifically, you're most welcome to. There is info about that on some of the scribus pages (wiki?).</quote>

There is no such info about it on any of the scribus pages (we've been asking Scribus team for years now to provide such info:), that's why I'd suggested that you provide your IBAN/SWIFT or PAYPAL account number and the roughly estimated price of the hardware -- I would put this info on the wiki page then, with a short description, why this donation is needed.

ltning

2006-10-13 19:21

developer   ~0012955

You can use http://anduin.net/donate.php for cc donations, or paypal to ltning@anduin.net .

cbradney

2006-10-13 19:42

administrator   ~0012956

We are still awaiting the creation of the not-for-profit org in France. The forms are in and we await the publication. The day after that, I expect we will have an account.

mhanski

2006-10-13 19:58

developer   ~0012957

Just to be sure: what do I need do to use the "CC donation" form? Is this "CC account" something I can get from this page: http://donorge.org/ ?

Also, as mentioned before, I would like to know to what kind of hardware at what price I'm going to donate for.

ltning

2006-10-13 20:38

developer   ~0012958

Sorry, by cc i meant credit card. As for which hardware, the initial need is for more memory and hard drive space. I have added more of both today, next up is a dedicated RAID controller (using software RAID today, which is a performance bottleneck), for which i also need a riser card.

ltning

2006-10-13 20:39

developer   ~0012959

Sorry, by cc i meant credit card. As for which hardware, the initial need is for more memory and hard drive space. I have added more of both today, next up is a dedicated RAID controller (using software RAID today, which is a performance bottleneck), for which i also need a riser card.

mhanski

2006-10-13 21:23

developer   ~0012961

Last edited: 2006-10-13 22:07

ltning, thx, I've just sent you a small donation with paypal and placed a request for donations on the Wiki: http://wiki.scribus.net/index.php/Scribus_Public_Wiki:Site_support

cbradney: bad news:) I've just learned that to be able to receive a paypal donation you don't even have to have a paypal account, an e-mail address is sufficient. This means, our eager mailing list donators could pick their favourite Scribus team member and donate to him personally, until you'll be able to receive donations for your non-profit organisation.

cbradney

2006-10-13 22:17

administrator   ~0012963

I'm not sure how to get money via email tho :)..

In any case, we have resisted taking personal donations generally unless we have really been in need, hence the org requirement.

ltning

2006-10-13 22:22

developer   ~0012964

mhanski, haven't seen anything from paypal at this end.. Mail me if you have any questions. Thanks for your support! ;)

mhanski

2006-10-13 22:24

developer   ~0012965

<quote>I'm not sure how to get money via email tho :)..</quote>
 
:) That would be just email money, I guesss:) Speaking seriously, you would be notified by PayPal about the donation and would have to create a PayPal account to pick the donation up.

mhanski

2006-10-13 22:36

developer   ~0012966

Last edited: 2006-10-14 06:43

ltning, sorry, this time I managed to click the second "send money" button, I'd missed the first time:) (Transaction code: 9W62591445618484C - this was my first experience with paypal).

cbradney

2006-10-22 12:38

administrator   ~0013083

Can we close this now?

ltning

2006-10-22 12:43

developer   ~0013084

Nah, I'd prefer to keep it open until I've finished investigating. I need to be able to use PF (it's an absolute must), and I need to use a proxy to get the load down to a sensible level.

Just need to find the time.

mhanski

2007-12-19 22:39

developer   ~0018360

I think, this one is ripe to be closed now

Issue History

Date Modified Username Field Change
2006-10-10 08:43 mhanski New Issue
2006-10-10 12:12 cbradney Note Added: 0012879
2006-10-10 12:22 mhanski Note Added: 0012881
2006-10-10 12:23 mhanski Note Edited: 0012881
2006-10-10 12:23 mhanski Note Edited: 0012881
2006-10-10 12:29 mhanski Note Edited: 0012881
2006-10-10 13:13 mhanski Note Added: 0012883
2006-10-10 18:04 mhanski Note Added: 0012887
2006-10-10 18:20 jghali Note Added: 0012888
2006-10-10 18:49 christoph_s Note Added: 0012891
2006-10-10 19:19 plinnell Note Added: 0012893
2006-10-10 19:39 christoph_s Note Added: 0012894
2006-10-11 06:13 ltning Note Added: 0012903
2006-10-11 08:29 mhanski Note Added: 0012909
2006-10-11 08:30 mhanski Status new => assigned
2006-10-11 08:30 mhanski Assigned To => ltning
2006-10-11 08:43 ltning Note Added: 0012910
2006-10-12 18:05 mhanski Note Added: 0012944
2006-10-12 18:08 mhanski Note Edited: 0012944
2006-10-13 05:54 ltning Note Added: 0012945
2006-10-13 07:45 mhanski Note Added: 0012946
2006-10-13 07:48 mhanski Note Edited: 0012946
2006-10-13 07:49 mhanski Note Edited: 0012946
2006-10-13 08:01 mhanski Note Edited: 0012946
2006-10-13 08:01 mhanski Note Edited: 0012946
2006-10-13 10:09 mhanski Note Added: 0012947
2006-10-13 14:21 ltning Note Added: 0012952
2006-10-13 14:32 mhanski Note Added: 0012953
2006-10-13 19:21 ltning Note Added: 0012955
2006-10-13 19:22 ltning Note View State: 12955: public
2006-10-13 19:42 cbradney Note Added: 0012956
2006-10-13 19:58 mhanski Note Added: 0012957
2006-10-13 20:38 ltning Note Added: 0012958
2006-10-13 20:39 ltning Note Added: 0012959
2006-10-13 21:23 mhanski Note Added: 0012961
2006-10-13 21:24 mhanski Note Edited: 0012961
2006-10-13 22:07 mhanski Note Edited: 0012961
2006-10-13 22:07 mhanski Note Edited: 0012961
2006-10-13 22:17 cbradney Note Added: 0012963
2006-10-13 22:22 ltning Note Added: 0012964
2006-10-13 22:24 mhanski Note Added: 0012965
2006-10-13 22:36 mhanski Note Added: 0012966
2006-10-13 22:57 mhanski Note Edited: 0012966
2006-10-13 22:58 mhanski Note Edited: 0012966
2006-10-14 06:43 mhanski Note Edited: 0012966
2006-10-22 12:38 cbradney Note Added: 0013083
2006-10-22 12:43 ltning Note Added: 0013084
2007-12-19 22:39 mhanski Note Added: 0018360
2007-12-19 22:47 jghali Status assigned => resolved
2007-12-19 22:47 jghali Resolution open => fixed
2007-12-19 22:48 jghali Status resolved => closed