View Issue Details

IDProjectCategoryView StatusLast Update
0000045ScribusGraphics / Image Framespublic2005-02-18 08:27
Reportercbradney Assigned Tofschmid  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionnot fixable 
Product Version 
Target VersionFixed in Version 
Summary0000045: Dragging of images to Scribus from Konqueror or desktop crashes Scribus
DescriptionI have dragged a png (created by ksnapshot) and a jpg from a digital camera over to Scribus and it immediately crashes.
When I tried dragging the jpg over a new picture frame, instead of just dragging over the blank page it didnt crash until I let go of the mouse button. Importing by "Get Picture" still works fine.
TagsNo tags attached.
Patch

Relationships

has duplicate 0001919 closedcbradney drag and drop picture 

Activities

plinnell

2003-11-22 06:16

viewer   ~0000012

On RH9 test box at my clients, no drag and drop EPS, TIF or PNG KDE 3.1.3 Qt 3.1.2 - Peter

plinnell

2003-12-08 00:37

viewer   ~0000061

Last edited: 2003-12-09 17:27

When I try this from KDE 3.2 beta: QClipboard: internal error, qt_xclb_wait_for_event recursed

and instant crash

References: http://www.newplanetsoftware.com/xdnd/

http://freedesktop.org/Standards/clipboards-spec

also : http://freedesktop.org/Main/Draganddropwarts

edited on: 12-08-03 01:47

Same on kwin 3.2 beta 2

edited on: 12-09-03 18:27

plinnell

2004-01-03 23:38

viewer   ~0000131

Jan 3 1.1.5 cvs build does not crash on RH9 Qt 3.1.2 /KDE 3.1.4
Drag and Drop from Desktop or Konqueror does nothing.

cbradney

2004-01-04 00:01

administrator   ~0000132

Still crashes here.

plinnell

2004-02-29 17:31

viewer   ~0000614

This might be a Qt bug see : http://bugs.kde.org/show_bug.cgi?id=61412

plinnell

2004-02-29 17:33

viewer   ~0000615

Reminder sent to cbradney, fschmid, subik

cbradney

2004-02-29 18:08

administrator   ~0000616

The patch at the address mrdocs removes the crash here although the images are not dropped onto the canvas at all. Franz, did we disable this?

subik

2004-03-01 20:19

manager   ~0000624

Last edited: 2004-03-02 19:36

hm. qt3.3.0(r1) and QClipboard: internal error, qt_xclb_wait_for_event recursed confirmed. i'm planning to upgrade to 3.3.1 in a few days.
today (qt3.3.1) same behaviour :-/

edited on: 03-02-04 20:36

plinnell

2004-03-08 19:35

viewer   ~0000709

This apparently is a long standing bug, which has been might have fixed in Qt 3.3.1 It works beautifully on SuSE 9.0 with Qt 3.3.1-2 :) Drag and Drop functionality includes dropping PDF's right on the page :) I tested xbm,gif,png and xpm..

Craig, can you check this against the Gentoo build of Qt 3.3.1 ?

plinnell

2004-03-08 19:41

viewer   ~0000710

Reminder sent to cbradney, fschmid

fschmid

2004-03-08 23:13

administrator   ~0000713

Since this is appearantly a Qt Bug, only in Versions > 3.1.1 and < 3.3.1
what should we do with this Bug? A fix for the Qt Versions 3.1.1+ and 3.2.x
would require to patch Qt itself.

cbradney

2004-03-08 23:48

administrator   ~0000715

I think we should leave this open until Qt fixes it. We should be reporting issues like this to the developers of the libs etc we rely on. When they fix it, we close it. We know we dont have to work on it.

plinnell

2004-03-23 17:13

viewer   ~0000777

Bug report submitted upstream to RH and fixed in rawhide see:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=118368

Issue History

Date Modified Username Field Change
2003-11-21 00:30 cbradney New Issue
2003-11-21 00:31 cbradney Summary Dragging of images to Scribus from Konqueor or desktop crashes Scribus => Dragging of images to Scribus from Konqueror or desktop crashes Scribus
2003-11-21 00:38 cbradney Assigned To => fschmid
2003-11-21 00:38 cbradney Status new => assigned
2003-11-22 06:16 plinnell Note Added: 0000012
2003-12-08 00:37 plinnell Note Added: 0000061
2003-12-08 00:47 plinnell Note Edited: 0000061
2003-12-09 17:27 plinnell Note Edited: 0000061
2004-01-03 23:38 plinnell Note Added: 0000131
2004-01-04 00:01 cbradney Note Added: 0000132
2004-02-29 17:31 plinnell Note Added: 0000614
2004-02-29 17:33 plinnell Note Added: 0000615
2004-02-29 18:08 cbradney Note Added: 0000616
2004-03-01 20:19 subik Note Added: 0000624
2004-03-02 19:36 subik Note Edited: 0000624
2004-03-08 19:35 plinnell Note Added: 0000709
2004-03-08 19:41 plinnell Note Added: 0000710
2004-03-08 23:13 fschmid Note Added: 0000713
2004-03-08 23:48 cbradney Note Added: 0000715
2004-03-23 17:13 plinnell Note Added: 0000777
2004-03-23 17:45 plinnell Resolution open => not fixable
2004-03-23 17:46 plinnell Status assigned => resolved
2005-02-18 08:27 plinnell Status resolved => closed
2005-04-25 20:44 cbradney Relationship added has duplicate 0001919
2015-09-17 20:10 Kunda Category Graphics / Image Frames => Graphics/Img Frames
2015-09-17 20:11 Kunda Category Graphics/Img Frames => Graphics / Image Frames