View Issue Details

IDProjectCategoryView StatusLast Update
0004884ScribusStory Editor / Text Framespublic2015-03-10 06:25
Reportercbradney Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSLinuxOS VersionSuSE 9.3
Product Version1.3.4cvs 
Target VersionFixed in Version1.5.0svn 
Summary0004884: Cursor in Story Editor always moves to top when switching window focus
DescriptionThe cursor in the SE doesn't keep its position when the user switches to another program and then back to scribus
Steps To ReproduceOpen text in SE, set cursor somehwere in the text, switch to any open program, then back to scribus. The cursor is placed at the beginning of the text.
TagsNo tags attached.
Patch

Relationships

related to 0003198 closedavox Cursor in Story Editor always moves to top when switching window focus 
has duplicate 0007817 closedcbradney Story Editor scrolls up after focus switching 
has duplicate 0008127 closedchristoph_s Story Editor doesnt open at precise edited place 
has duplicate 0008231 closedcbradney Cursor position get lost when switching to story editor and back 
has duplicate 0008750 closedcbradney story-editor resets scroll-position if focus reenters text-widget 
has duplicate 0009647 closedjghali Cursor in Story Editor always moves to top when switching window focus in 1.3.9 
has duplicate 0009172 closedcbradney Story editor auto jumps the scroll bar to top of text on text update 
has duplicate 0010373 closedjghali Story editor reset to the begining of the text when alt-tab 
has duplicate 0010524 closedjghali cursor in story-editor resets when changing focus 
has duplicate 0012348 closedjghali Story editor jumps to beginning of text after switching to/from another application 
has duplicate 0012935 closedjghali Story Editor resets cursor to top of text document when switching between applications 
related to 0012924 confirmed Dont jump to previously selected page when applying masterpage with dragndrop 
child of 0003157 acknowledged Metabug: Cursor placement fixes 

Activities

cbradney

2007-02-12 21:54

administrator   ~0015225

[22:19] <MrB> avox: i think this will be a quick fix for u.. at least u know the code somewhat: 0004884. the bug is fixed, but if you now change the position in the SE with the mouse and then change app and come back it moves back to the originally set position

avox

2007-02-13 05:57

administrator   ~0015230

sorry, cant find the cause for this behaviour. for some reason loadItemText() is called when focus is switched back to SE, tho that shouldnt reset the cursor to (0,0).

IMHO not worth the effort before 1.3.5

cbradney

2007-11-30 00:14

administrator   ~0018051

still in 1.3.5svn

zoffix

2010-03-01 15:12

reporter   ~0023424

still in 1.3.6svn. The cursor resets even if moved by keyboard.

plantarum

2014-09-21 18:54

reporter   ~0033790

still in Debian Scribus:

Scribus Version 1.4.3.svn,
22 March 2013
Build ID: C-C-T-F-C1.12.16-64bit
Using Ghostscript version 9.05

Very irritating when editing long articles!

Kunda

2015-02-26 16:38

manager   ~0034616

Issue still persists in 1.5svn r19885

Kunda

2015-02-27 01:42

manager   ~0034621

So after implementing fix r19886 behavior is not ideal but much much better. Instead of jumping back to beginning of the text block, now switching from and to Scribus will trigger the screen to move the active cursor line to the last line of the visible SE window. This is much better then beginning of the text block.

PeterBenedek

2015-03-05 07:05

developer   ~0034649

"So after implementing fix r19886 behavior is not ideal but much much better. Instead of jumping back to beginning of the text block, now switching from and to Scribus will trigger the screen to move the active cursor line to the last line of the visible SE window. This is much better then beginning of the text block."

Only the search again does not work!

Look: http://bugs.scribus.net/view.php?id=12091
It was a temporary solution: in video from 1.40 (this is not working) :-(

jghali

2015-03-05 19:56

administrator   ~0034650

Last edited: 2015-03-05 19:57

View 2 revisions

Kunda, 0012091 is not closed, so this is not necessary to reopen that one.

Issue History

Date Modified Username Field Change
2006-12-18 22:58 cbradney New Issue
2006-12-18 22:58 cbradney Status new => assigned
2006-12-18 22:58 cbradney Assigned To => avox
2006-12-18 22:58 cbradney Issue generated from: 0003198
2006-12-18 22:58 cbradney Relationship added related to 0003198
2007-01-04 09:54 cbradney Relationship added child of 0003964
2007-02-12 21:54 cbradney Note Added: 0015225
2007-02-13 05:57 avox Note Added: 0015230
2007-02-13 05:57 avox Relationship deleted child of 0003964
2007-02-13 22:32 cbradney Relationship added child of 0003964
2007-02-13 22:33 cbradney Relationship deleted child of 0003964
2007-02-13 22:39 cbradney Relationship added child of 0003964
2007-02-13 22:49 cbradney Relationship deleted child of 0003964
2007-02-13 22:49 cbradney Relationship added child of 0003964
2007-02-13 22:59 cbradney Relationship deleted child of 0003964
2007-05-23 21:08 christoph_s Relationship added child of 0003157
2007-11-30 00:14 cbradney Note Added: 0018051
2009-02-23 21:22 cbradney Relationship added has duplicate 0007817
2009-06-07 21:40 christoph_s Relationship added has duplicate 0008127
2009-07-02 17:38 cbradney Relationship added has duplicate 0008231
2010-01-27 19:56 cbradney Relationship added has duplicate 0008750
2010-03-01 15:12 zoffix Note Added: 0023424
2011-01-06 16:00 jghali Relationship added has duplicate 0009647
2011-04-19 21:30 cbradney Relationship added has duplicate 0009172
2011-11-13 23:14 jghali Relationship added has duplicate 0010373
2012-01-17 17:36 jghali Relationship added has duplicate 0010524
2014-06-05 13:12 jghali Relationship added has duplicate 0012348
2014-06-05 13:13 jghali Summary Cursor in Story Editor always moves to top when switching window focus in 1.3.4cvs => Cursor in Story Editor always moves to top when switching window focus
2014-09-21 18:54 plantarum Note Added: 0033790
2015-02-26 16:29 jghali Relationship added has duplicate 0012935
2015-02-26 16:38 Kunda Note Added: 0034616
2015-02-26 22:49 cbradney Status assigned => resolved
2015-02-26 22:49 cbradney Fixed in Version => 1.5.0svn
2015-02-26 22:49 cbradney Resolution open => fixed
2015-02-26 22:49 cbradney Assigned To avox => cbradney
2015-02-27 01:42 Kunda Note Added: 0034621
2015-02-27 09:52 JLuc Relationship added related to 0012924
2015-03-05 07:05 PeterBenedek Note Added: 0034649
2015-03-05 17:04 Kunda Status resolved => feedback
2015-03-05 17:04 Kunda Resolution fixed => reopened
2015-03-05 19:56 jghali Note Added: 0034650
2015-03-05 19:56 jghali Status feedback => resolved
2015-03-05 19:56 jghali Resolution reopened => fixed
2015-03-05 19:57 jghali Note Edited: 0034650 View Revisions
2015-03-10 06:25 cbradney Status resolved => closed
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames