View Issue Details

IDProjectCategoryView StatusLast Update
0005408ScribusPDFpublic2007-12-28 09:04
Reporterharaldmebus Assigned Tofschmid  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformINTELOSWIN XP SP2OS Version
Product Version1.3.3.8 
Target Version1.3.3.10Fixed in Version1.3.3.10svn 
Summary0005408: Generated PDF-form doesn't show/accept äöüÄÖÜ
DescriptionWhen exporting the attached Scribus-Form to PDF and then opening it in Acrobat 8 or equal PDF-readers, the special characters do not show - only spaces are indicated. I checked this behaviour with the following programs:
- Acrobat 8
- Foxit-Reader 2.0
- Cabaret Stage 2.1

Harald
Steps To ReproduceOpen the attached file with scribus and export to PDF, then re-open the PDF with an appropriate reader and try to enter äöü or ÄÖÜ into any textfield.
The field "Kunden" must be filled out !
TagsNo tags attached.
Patch

Relationships

related to 0003282 closedfschmid Fonts don't work with text fields of forms. 
related to 0005435 closedjghali Generated PDF-Forms do not show background color of fields in some PDF-readers 
related to 0005442 closedfschmid PDF forms export broken: Scribus 1.3.3.9cvs generates forms without fields, checkboxes etc. 
child of 0003831 acknowledged Metabug: PDF Forms 
child of 0005640 closedplinnell 1.3.3.10 Release 

Activities

2007-03-02 11:40

 

Auftrag-und-Leistungsnachweis-V1-scr-master-fehler.pdf (192,395 bytes)

2007-03-02 12:19

 

Auftrag-und-Leistungsnachweis-V1-scr-master-fehler.sla (307,558 bytes)

mhanski

2007-03-02 21:06

developer   ~0015429

fschmid: it works fine in 1.3.4cvs, I wonder if backporting 0003282 to 1.3.3.* would solve the issue

mhanski

2007-03-03 13:56

developer   ~0015438

Last edited: 2007-03-03 13:59

I tested it once again with today's 1.3.4cvs and the German glyphs won't work with 1.3.4cvs either (see the attached files: 134form.sla and 134form.pdf).

It's very strange, since it worked for sure some time ago, and the pdf file works flowlessly with all Polish glyphs like "lstroke", "aogonek", or "zacute".

mhanski

2007-03-03 19:16

developer   ~0015442

Reminder sent to: haraldmebus

haraldmebus: sorry for bothering you with this question, but how did you manage to add options (Esch,Himmel,Hinrichs, etc) to your "Monteur" combo boxes in your pdf form? Did you edit the SLA file by hand in a text editor? I'm asking because I want to create a simple demo pdf form with most common pdf form features and some simple javascript examples and attach it to our pdf form howto http://wiki.scribus.net/index.php/Your_first_PDF_form_with_Scribus
You can also contact me off the bug tracker, my email is ma_han2000@yahoo.de (in German)

mhanski

2007-03-03 21:59

developer   ~0015443

Reminder sent to: haraldmebus

I've already found out how it works (story editor, this is weird). no need to answer my previous question

mhanski

2007-03-05 19:21

developer   ~0015467

I'm afraid, it's not fixed. After the change there is even more brokenness, there are neither text fields nor check boxes in the resulting PDF form.

fschmid

2007-03-05 22:07

administrator   ~0015469

Just retested it with the original doc. It works perfect if you do embed all Fonts into the PDF. You should not convert a Font used in PDF-Fields into Curves. And in this doc one font that's used in the Fields was converted to Curves, changing this results in a perfect working doc.

cbradney

2007-03-05 22:12

administrator   ~0015470

Franz, would it be possible to lock the fonts for embedding when used in forms?

mhanski

2007-03-05 22:28

developer   ~0015471

Last edited: 2007-03-05 22:29

1. retested with the original form:

- there is no way a can export a working pdf form now (regardless what I do with the 2 fonts in the font tab) -- see the attached file form_after_fix.pdf

2. created a new 1-field form (one_field_form.sla):
-- on exporting, there are no fonts to embed in the Fonts tab
-- the resulting pdf form is empty (the attached one_field_form.pdf)

fschmid

2007-03-05 22:42

administrator   ~0015472

mhanski, which version of scribus are you using for testing?
re 2. if you use 1.3.4cvs you must currently add a textbox with the font for the field, otherwise the font used in the pdf form field will not be recognized. This is a bug we will fix soon.

mhanski

2007-03-05 22:51

developer   ~0015473

fschmid: in both test cases 1. and 2. I used only 1.3.3.9cvs from today evening

haraldmebus

2007-03-06 12:05

reporter   ~0015477

Checked the glyphs-problem with 1.3.3.9 cvs as of 01.03.07 and it works. Also checkboxes and list-/comboboxes work.

mhanski

2007-03-07 22:33

developer   ~0015498

fschmid, just to be sure: this issue doesn't occur with the current 1.3.4cvs (just tested), it's only about 1.3.3.9cvs

mhanski

2007-03-08 14:29

developer   ~0015501

haraldmebus has delivered in 0005435 a new version of his PDF form which confirmes the behaviour I'd reported: there are no text fields, checkboxes, list boxes, or any form elements to be seen in the PDF form while opened in Adobe Reader 7.08/Cabaret on Linux or Adobe Reader 7.05 on Windows.

mhanski

2007-03-12 14:20

developer   ~0015526

since these side effects are much more serious than the original report, I've submitted a separate bug report 0005442 for the PDF forms brokenness

cbradney

2007-03-28 20:28

administrator   ~0015656

Franz: where is this one up to?

mhanski

2007-07-01 21:22

developer   ~0016714

tested with today's 1.3.3.10cvs, this major bug is there (again), Scribus replaces Polish glyphs in form fields with question marks (to be sure -- it's verdana which contains all needed glyphs). I'm attaching new test files

2007-07-01 21:27

 

Dokument-4.sla.gz (7,894 bytes)

2007-07-01 21:27

 

Dokument-4.pdf (312,357 bytes)

2007-10-12 21:17

 

5408_forms_133x.patch (2,953 bytes)
Index: scribus/pdflib.cpp
===================================================================
--- scribus/pdflib.cpp	(revision 10838)
+++ scribus/pdflib.cpp	(working copy)
@@ -4491,7 +4491,7 @@
 		case 0:
 		case 10:
 			PutDoc("/Subtype /Text\n");
-			PutDoc("/Contents "+EncString("("+bm+")",ObjCounter-1)+"\n");
+			PutDoc("/Contents "+EncStringUTF16("("+bm+")",ObjCounter-1)+"\n");
 			break;
 		case 1:
 		case 11:
@@ -4521,9 +4521,9 @@
 		case 6:
 			Seite.FormObjects.append(ObjCounter-1);
 			PutDoc("/Subtype /Widget\n");
-			PutDoc("/T "+EncString("("+ite->itemName()+")",ObjCounter-1)+"\n");
+			PutDoc("/T "+EncString(QString("(annot_obj_%1)").arg(ite->ItemNr),ObjCounter-1)+"\n");
 			if (!ite->annotation().ToolTip().isEmpty())
-				PutDoc("/TU "+EncString("("+PDFEncode(ite->annotation().ToolTip())+")",ObjCounter-1)+"\n");
+				PutDoc("/TU "+EncStringUTF16("("+PDFEncode(ite->annotation().ToolTip())+")",ObjCounter-1)+"\n");
 			PutDoc("/F ");
 			QString mm[] = {"4", "2", "0", "32"};
 			PutDoc(mm[ite->annotation().Vis()]);
@@ -4567,8 +4567,8 @@
 					break;
 				case 3:
 					PutDoc("/FT /Tx\n");
-					PutDoc("/V "+EncString("("+bm+")",ObjCounter-1)+"\n");
-					PutDoc("/DV "+EncString("("+bm+")",ObjCounter-1)+"\n");
+					PutDoc("/V "+EncStringUTF16("("+bm+")",ObjCounter-1)+"\n");
+					PutDoc("/DV "+EncStringUTF16("("+bm+")",ObjCounter-1)+"\n");
 					PutDoc("/Q "+QString::number(QMIN(ite->textAlignment,2))+"\n");
 					PutDoc("/AP << /N "+QString::number(ObjCounter)+" 0 R >>\n");
 					if (ite->annotation().MaxChar() != -1)
@@ -4590,10 +4590,10 @@
 					if (bmst.count() > 0)
 						cnx += bmst[0];
 					cnx += ")";
-					PutDoc(EncString(cnx,ObjCounter-1)+"\n");
+					PutDoc(EncStringUTF16(cnx,ObjCounter-1)+"\n");
 					PutDoc("/Opt [ ");
 					for (uint bmc = 0; bmc < bmst.count(); ++bmc)
-						PutDoc(EncString("("+bmst[bmc]+")",ObjCounter-1)+"\n");
+						PutDoc(EncStringUTF16("("+bmst[bmc]+")",ObjCounter-1)+"\n");
 					PutDoc("]\n");
 					PutDoc("/AP << /N "+QString::number(ObjCounter)+" 0 R >>\n");
 					break;
@@ -4824,13 +4824,13 @@
 			cc += "1 0 0 1 0 0 Tm\n0 0 Td\n";
 			for (uint mz = 0; mz < bmst.count(); ++mz)
 			{
-				cc += EncString("("+bmst[mz]+")",ObjCounter-1);
+				cc += EncStringUTF16("("+bmst[mz]+")",ObjCounter-1);
 				cc += " Tj\nT*\n";
 			}
 			cc += "ET\nEMC";
 		}
 		else
-			cc += "1 0 0 1 0 0 Tm\n0 0 Td\n"+EncString("("+bm+")",ObjCounter-1)+" Tj\nET\nEMC";
+			cc += "1 0 0 1 0 0 Tm\n0 0 Td\n"+EncStringUTF16("("+bm+")",ObjCounter-1)+" Tj\nET\nEMC";
 		PDF_xForm(ite->width(), ite->height(), cc);
 	}
 	if (ite->annotation().Type() == 4)
@@ -4862,7 +4862,7 @@
 		cc += " "+FToStr(ite->fontSize() / 10.0)+" Tf\n";
 		cc += "1 0 0 1 0 0 Tm\n0 0 Td\n";
 		if (bmst.count() > 0)
-			cc += EncString("("+bmst[0]+")",ObjCounter-1);
+			cc += EncStringUTF16("("+bmst[0]+")",ObjCounter-1);
 		cc += " Tj\nET\nQ\nEMC";
 		PDF_xForm(ite->width(), ite->height(), cc);
 	}
5408_forms_133x.patch (2,953 bytes)

jghali

2007-10-12 21:21

administrator   ~0017592

Last edited: 2007-10-12 21:22

I've uploaded a beta patch (13310svn) for whose who want to have a look. Feedback heavily welcomed!

christoph_s

2007-10-14 22:45

administrator   ~0017634

The bug with Umlauts is fixed with jghali's patch, but the polish text still looks weird, since the letters are displaced.

2007-10-14 22:47

 

Dokument-4-1.pdf (312,816 bytes)

jghali

2007-10-15 00:08

administrator   ~0017641

There is another bug for character placement in pdf forms. It seems that exporting to PDF 1.3 is a workaround for this specific issue.

jghali

2007-10-15 20:54

administrator   ~0017644

Patch has now been commited to 1.3.3.10svn and 1.3.5svn

jghali

2007-10-17 18:01

administrator   ~0017664

Last edited: 2007-10-17 18:01

This issue should be fixed now. Remaining kerning issues is the subject of another bug (0005444)

christoph_s

2007-10-17 19:25

administrator   ~0017680

Tested, fixed. Thanks.

Issue History

Date Modified Username Field Change
2007-03-02 11:40 haraldmebus New Issue
2007-03-02 11:40 haraldmebus File Added: Auftrag-und-Leistungsnachweis-V1-scr-master-fehler.pdf
2007-03-02 12:19 haraldmebus File Added: Auftrag-und-Leistungsnachweis-V1-scr-master-fehler.sla
2007-03-02 12:39 plinnell Status new => assigned
2007-03-02 12:39 plinnell Assigned To => fschmid
2007-03-02 20:41 mhanski Relationship added child of 0003831
2007-03-02 21:02 mhanski Relationship added related to 0003282
2007-03-02 21:06 mhanski Note Added: 0015429
2007-03-03 13:51 mhanski File Added: 134form.sla
2007-03-03 13:52 mhanski File Added: 134form.pdf
2007-03-03 13:56 mhanski Note Added: 0015438
2007-03-03 13:59 mhanski Note Edited: 0015438
2007-03-03 19:16 mhanski Note Added: 0015442
2007-03-03 21:59 mhanski Note Added: 0015443
2007-03-04 14:26 fschmid Status assigned => resolved
2007-03-04 14:26 fschmid Fixed in Version => 1.3.3.9cvs
2007-03-04 14:26 fschmid Resolution open => fixed
2007-03-05 19:21 mhanski Status resolved => feedback
2007-03-05 19:21 mhanski Resolution fixed => reopened
2007-03-05 19:21 mhanski Note Added: 0015467
2007-03-05 22:07 fschmid Note Added: 0015469
2007-03-05 22:12 cbradney Note Added: 0015470
2007-03-05 22:21 mhanski File Added: form_after_fix.pdf
2007-03-05 22:24 mhanski File Added: one_field_form.sla
2007-03-05 22:24 mhanski File Added: one_field_form.pdf
2007-03-05 22:28 mhanski Note Added: 0015471
2007-03-05 22:29 mhanski Note Edited: 0015471
2007-03-05 22:42 fschmid Note Added: 0015472
2007-03-05 22:51 mhanski Note Added: 0015473
2007-03-06 12:05 haraldmebus Note Added: 0015477
2007-03-07 22:33 mhanski Note Added: 0015498
2007-03-08 14:09 mhanski Relationship added related to 0005435
2007-03-08 14:29 mhanski Note Added: 0015501
2007-03-12 14:17 mhanski Relationship added related to 0005442
2007-03-12 14:20 mhanski Note Added: 0015526
2007-03-28 20:28 cbradney Note Added: 0015656
2007-03-28 20:34 cbradney Status feedback => resolved
2007-03-28 20:34 cbradney Resolution reopened => fixed
2007-03-28 22:00 cbradney Status resolved => closed
2007-07-01 21:22 mhanski Status closed => feedback
2007-07-01 21:22 mhanski Resolution fixed => reopened
2007-07-01 21:22 mhanski Note Added: 0016714
2007-07-01 21:27 mhanski File Added: Dokument-4.sla.gz
2007-07-01 21:27 mhanski File Added: Dokument-4.pdf
2007-07-01 21:30 mhanski File Deleted: 134form.sla
2007-07-01 21:30 mhanski File Deleted: 134form.pdf
2007-07-01 21:30 mhanski File Deleted: form_after_fix.pdf
2007-07-01 21:30 mhanski File Deleted: one_field_form.sla
2007-07-01 21:30 mhanski File Deleted: one_field_form.pdf
2007-07-01 21:39 cbradney Relationship added child of 0005640
2007-10-12 21:17 jghali File Added: 5408_forms_133x.patch
2007-10-12 21:21 jghali Note Added: 0017592
2007-10-12 21:22 jghali Note Edited: 0017592
2007-10-14 22:45 christoph_s Note Added: 0017634
2007-10-14 22:47 christoph_s File Added: Dokument-4-1.pdf
2007-10-15 00:08 jghali Note Added: 0017641
2007-10-15 20:54 jghali Note Added: 0017644
2007-10-17 18:01 jghali Status feedback => resolved
2007-10-17 18:01 jghali Fixed in Version 1.3.3.9cvs => 1.3.3.10cvs
2007-10-17 18:01 jghali Resolution reopened => fixed
2007-10-17 18:01 jghali Note Added: 0017664
2007-10-17 18:01 jghali Note Edited: 0017664
2007-10-17 19:25 christoph_s Status resolved => closed
2007-10-17 19:25 christoph_s Note Added: 0017680
2007-12-20 22:50 cbradney Target Version => 1.3.3.10cvs
2007-12-28 09:04 cbradney Target Version 1.3.3.10cvs => 1.3.3.10