View Issue Details

IDProjectCategoryView StatusLast Update
0005442ScribusPDFpublic2007-12-28 09:04
Reportermhanski Assigned Tofschmid  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.3.9cvs 
Target Version1.3.3.10Fixed in Version 
Summary0005442: PDF forms export broken: Scribus 1.3.3.9cvs generates forms without fields, checkboxes etc.
DescriptionAs stated above.

Tested with 1.3.3.9cvs and Adobe Reader 7.05/Linux, 7.08/Windows XP

See also test files delivered with 0005408 and 0005435
TagsNo tags attached.
Patch

Relationships

related to 0005408 closedfschmid Generated PDF-form doesn't show/accept äöüÄÖÜ 
related to 0005435 closedjghali Generated PDF-Forms do not show background color of fields in some PDF-readers 
related to 0005953 closedfschmid Scribus 1.3.4 generates wrong PDF 
related to 0005444 closedjghali PDF forms: broken kerning in text fields, list boxes, buttons, etc. 
child of 0003831 acknowledged Metabug: PDF Forms 
child of 0005640 closedplinnell 1.3.3.10 Release 

Activities

fschmid

2007-03-12 14:22

administrator   ~0015528

This is due to the use of outlined fonts in the PDF fields, current CVS has now a Preflight Check for this.

mhanski

2007-03-12 14:28

developer   ~0015529

I'll get fresh 1.3.3.9cvs in the evening and let you know about the test results

mhanski

2007-03-12 15:44

developer   ~0015531

-- OK: works fine with simple new forms, apart from kerning on buttons (will submit a separate report)

-- NOT OK: doesn't work fine with Auftrag-und-Leistungsnachweis-V1-scr-master-fehler.sla from 0005408 -- no fields and checkboxes to be seen in the resulting PDF form in Acroread 7.05

mhanski

2007-03-13 10:08

developer   ~0015537

Reminder sent to: christoph_s

christoph, could you test this one?

haraldmebus

2007-04-02 07:28

reporter   ~0015705

Is there any new W32-Version to test with ?

mhanski

2007-07-01 21:26

developer   ~0016715

tested again with today's cvs, this issue is gone -- Christoph, could you confirm?

the other two major issues which make Scribus unusable for working with PDF forms are still there: 0005408 (I've just had to reopen this one) and 0005444

christoph_s

2007-07-02 21:46

administrator   ~0016728

Confirmed. The issue is gone.

mhanski

2007-07-03 10:10

developer   ~0016732

thx Christoph, I assume the recently fixed 0005953 influenced this one too. Resolving

Issue History

Date Modified Username Field Change
2007-03-12 14:16 mhanski New Issue
2007-03-12 14:17 mhanski Relationship added related to 0005408
2007-03-12 14:17 mhanski Relationship added related to 0005435
2007-03-12 14:18 mhanski Relationship added child of 0003831
2007-03-12 14:22 fschmid Note Added: 0015528
2007-03-12 14:28 mhanski Note Added: 0015529
2007-03-12 15:44 mhanski Note Added: 0015531
2007-03-12 18:50 mhanski Relationship added related to 0005444
2007-03-13 10:08 mhanski Note Added: 0015537
2007-03-13 23:33 christoph_s Status new => confirmed
2007-03-14 06:12 cbradney Status confirmed => assigned
2007-03-14 06:12 cbradney Assigned To => fschmid
2007-03-18 21:19 plinnell Relationship added child of 0005438
2007-04-02 07:28 haraldmebus Note Added: 0015705
2007-05-06 18:29 plinnell Relationship added child of 0005640
2007-05-06 18:32 plinnell Relationship deleted child of 0005438
2007-07-01 21:26 mhanski Note Added: 0016715
2007-07-02 21:46 christoph_s Note Added: 0016728
2007-07-03 09:35 mhanski Relationship added related to 0005953
2007-07-03 10:10 mhanski Status assigned => resolved
2007-07-03 10:10 mhanski Resolution open => fixed
2007-07-03 10:10 mhanski Note Added: 0016732
2007-07-03 20:30 christoph_s Status resolved => closed
2007-12-20 22:50 cbradney Target Version => 1.3.3.10cvs
2007-12-28 09:04 cbradney Target Version 1.3.3.10cvs => 1.3.3.10