View Issue Details

IDProjectCategoryView StatusLast Update
0005479ScribusFontspublic2007-03-23 09:06
Reporterkhem Assigned Toplinnell 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformLinux and WindowsOSAllOS VersionSUSE 10.2 and XP
Product Version1.3.3.6 
Target VersionFixed in Version 
Summary0005479: Scribus does not support Khmer language
DescriptionI have tested Khmer script in Scribus 1.3.3.6 and the rendering is not correct. Please see the files attached for more detail about this. In the files attached both in correct and incorrect rendering.

If it supports Khmer script, it would be great because many people here(Cambodia) wait for using it. and we have a plan to translate it to Khmer language as well.

We have translate some applications into Khmer such as: Firefox, Thunderbird, OpenOffice, KDE,... for more detail about my project please visit: www.khmeros.info

Thank in advance for your help!

  
TagsNo tags attached.
Patch

Relationships

duplicate of 0002920 closedFahad Khmer script is rendered wrong 
child of 0003965 acknowledged Metabug: Support for non-latin languages 

Activities

2007-03-23 03:27

 

scribus-khmer.tar.gz (145,487 bytes)

plinnell

2007-03-23 08:39

viewer   ~0015596

Thanks for your offer for translation which we will want in the future. Supporting non-Latin scripts is a priority for us, but it requires a lot refactoring of code which is ongoing.

http://rants.scribus.net/2006/10/31/boston-text-layout-summit/ has more info about what is involved.

Issue History

Date Modified Username Field Change
2007-03-23 03:27 khem New Issue
2007-03-23 03:27 khem File Added: scribus-khmer.tar.gz
2007-03-23 07:40 mhanski Relationship added child of 0003965
2007-03-23 07:40 mhanski Relationship added duplicate of 0002920
2007-03-23 08:39 plinnell Status new => resolved
2007-03-23 08:39 plinnell Resolution open => duplicate
2007-03-23 08:39 plinnell Assigned To => plinnell
2007-03-23 08:39 plinnell Note Added: 0015596
2007-03-23 09:06 plinnell Status resolved => closed