View Issue Details

IDProjectCategoryView StatusLast Update
0006084ScribusPrintingpublic2014-07-12 18:54
ReporterBrian Assigned To 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Platformi386OSUbuntuOS VersionFeisty
Product Version1.3.4 
Target VersionFixed in Version 
Summary0006084: Unable to print
DescriptionPrinting does not occur. CUPS error log as follows:
/var/log/cups/error.log shows:
E [08/Aug/2007:13:07:02 +0930] [Job 71] /undefined in G2
E [08/Aug/2007:13:07:02 +0930] PID 17762
(/usr/lib/cups/filter/foomatic-rip) stopped with status 3!
E [08/Aug/2007:13:08:29 +0930] [Job 72] /undefined in G2
E [08/Aug/2007:13:08:29 +0930] PID 17796
(/usr/lib/cups/filter/foomatic-rip) stopped with status 3!
Additional InformationExport to PDF results in document that freezes Adobe Reader - there is no output whatsoever,
TagsNo tags attached.
Patch

Activities

jghali

2007-08-10 13:32

administrator   ~0017006

This may be related to 0005977 i fixed recently. Could you have a try at a recent 1.3.5svn snapshot?

avox

2007-08-10 18:18

administrator   ~0017011

can you attach the problematic PDF?

2007-08-11 12:29

 

bulletin_20july07_NG.sla (279,674 bytes)

Brian

2007-08-11 12:43

reporter   ~0017014

0005077 is about missing pages in PDF's exported from Scribus in WinXP. I doubt its relevance to this problem. I could not find 1.3.5svn - because it isn't available for Linux?
Have sent "my" PDF direct to Andreas - it is over 6G!

jghali

2007-08-11 13:33

administrator   ~0017015

Last edited: 2007-08-11 13:36

No, 0005977 is not about missing pages but about an error which trigger elements not to be drawn after corresponding page has been viewed. That precise error can easily cause postscript errors and consequently unability to print.

avox

2007-08-11 14:44

administrator   ~0017016

PDF opens here without problems in Acrobat Reader 8.
Can you reproduce the problem with less fonts? It might be that one of the fonts makes problems or that the memory consumption makes AR or PostScript crash.

2007-08-12 07:16

 

bulletin_0707onefont_NG.sla (278,441 bytes)

Brian

2007-08-12 07:17

reporter   ~0017020

Thanks for the gracious explanation about missing PDF pages.
bulletin_0707onefont_NG.sla is an attempt to change all fonts to Gargi1.7, which seems to be a Scribus default. On p1 near the top are two groups of six items. I cannot change the font from Nimbus Sans, though I might have done so, see p2.
On p2 "Happy Birthday" has been changed to Gargi1.7, but Properties still shows it as Bailey Script. Conversely, "Jesus is watching you" has clearly not changed but Properties shows it as Gargi1.7. So fonts aew an issue

2007-08-12 07:57

 

bulletin_0707onefont_NG.pdf (964,453 bytes)

Brian

2007-08-12 07:58

reporter   ~0017022

bulletin_0707onefont_NG.PDF prints just fine - and with only two embedded fonts is MUCH smaller. Here is the access log.
localhost - - [12/Aug/2007:16:51:16 +0930] "POST / HTTP/1.1" 200 350 CUPS-Get-Classes successful-ok
localhost - - [12/Aug/2007:16:51:16 +0930] "POST / HTTP/1.1" 200 350 CUPS-Get-Classes successful-ok
localhost - - [12/Aug/2007:16:51:17 +0930] "POST / HTTP/1.1" 200 350 CUPS-Get-Classes successful-ok
localhost - - [12/Aug/2007:16:51:17 +0930] "POST / HTTP/1.1" 200 129 Get-Jobs successful-ok
localhost - - [12/Aug/2007:16:51:17 +0930] "GET /ppd/ColourDeskjet.ppd HTTP/1.1" 200 20162 - -
localhost - - [12/Aug/2007:16:51:26 +0930] "POST / HTTP/1.1" 200 350 CUPS-Get-Classes successful-ok
localhost - - [12/Aug/2007:16:51:29 +0930] "POST / HTTP/1.1" 200 350 CUPS-Get-Classes successful-ok
localhost - - [12/Aug/2007:16:51:29 +0930] "POST /printers/ColourDeskjet HTTP/1.1" 200 2499881 Print-Job successful-ok

The sla file doesn't print and produces the same "status 31" error as before.

Brian

2007-08-26 02:25

reporter   ~0017160

We can probably eliminate fonts as a cause of PDF not printing.
bulletin_0707multifont_NG-Page1.PDF was created from bulletin_0707onefont_NG by successively adding an additional font and testing until it now contains seven different fonts and still prints just fine.
There might be a rogue font somewhere,which might cause a PDF not to print, but I haven't found it.
Note also that this printable PDF is much smaller (1.3M) than the not-printable version sent to Andreas (6M) even though there is little visual difference between them.

2007-08-26 02:26

 

bulletin_0707multifont_NG-Page1.pdf (1,355,316 bytes)

Brian

2007-08-26 02:27

reporter   ~0017161

Printing directly from Scribus (1.3.3.9.dfsg+20070808svn-1) remains impossible.
Even bulletin_17aug07_stripped does not print.

2007-08-26 02:28

 

bulletin_17aug07_stripped.sla (170,848 bytes)

Kunda

2014-07-08 03:49

updater   ~0032572

Brian, can you still reproduce this with current builds?

FirasH

2014-07-12 18:54

developer   ~0032705

Closing, very old report.

Issue History

Date Modified Username Field Change
2007-08-10 12:53 Brian New Issue
2007-08-10 13:32 jghali Note Added: 0017006
2007-08-10 18:18 avox Note Added: 0017011
2007-08-11 12:29 Brian File Added: bulletin_20july07_NG.sla
2007-08-11 12:43 Brian Note Added: 0017014
2007-08-11 13:33 jghali Note Added: 0017015
2007-08-11 13:36 jghali Note Edited: 0017015
2007-08-11 14:44 avox Note Added: 0017016
2007-08-12 07:16 Brian File Added: bulletin_0707onefont_NG.sla
2007-08-12 07:17 Brian Note Added: 0017020
2007-08-12 07:57 Brian File Added: bulletin_0707onefont_NG.pdf
2007-08-12 07:58 Brian Note Added: 0017022
2007-08-26 02:25 Brian Note Added: 0017160
2007-08-26 02:26 Brian File Added: bulletin_0707multifont_NG-Page1.pdf
2007-08-26 02:27 Brian Note Added: 0017161
2007-08-26 02:28 Brian File Added: bulletin_17aug07_stripped.sla
2014-07-08 03:49 Kunda Note Added: 0032572
2014-07-08 03:49 Kunda Status new => feedback
2014-07-08 03:51 Kunda Priority normal => low
2014-07-08 03:51 Kunda Severity major => minor
2014-07-12 18:54 FirasH Note Added: 0032705
2014-07-12 18:54 FirasH Status feedback => closed
2014-07-12 18:54 FirasH Resolution open => unable to reproduce