View Issue Details

IDProjectCategoryView StatusLast Update
0006971ScribusCanvaspublic2008-10-22 19:55
Reportercbradney Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.5svn 
Target Version1.3.5Fixed in Version1.3.5svn 
Summary0006971: Faint diagonal line appearing when in edit mode of text frame
Descriptionsee screenshot
TagsNo tags attached.
Patch

Activities

2008-04-22 21:35

 

snapshot17.png (51,440 bytes)
snapshot17.png (51,440 bytes)

cbradney

2008-04-22 21:44

administrator   ~0019536

cairo 1.6.4

fschmid

2008-04-23 06:34

administrator   ~0019540

Some remarks here:
a) It does happen only in Edit-Mode.
b) It happens only when there is at least 1 glyph in the frame
c) The length of the line seems to be dependend on the position of frame relative
   to other frames on the page.

fschmid

2008-04-23 12:08

administrator   ~0019541

I could track it down to the call to cairo_set_dash in scpainter. If you remove that call everything is normal.

fschmid

2008-04-23 12:55

administrator   ~0019542

Seems to be a cairo bug, as it doesn't happen with cairo-1.4.14

2008-04-24 07:41

 

WeiredFrame.png (113,352 bytes)
WeiredFrame.png (113,352 bytes)

fschmid

2008-04-24 07:42

administrator   ~0019543

Sometimes its even worse, see WeiredFrame.png for an oval text frame.

fschmid

2008-04-24 08:22

administrator   ~0019544

Further investigation shows that this is clearly a cairo bug.
The last working version of cairo is 1.5.8, version 1.5.10 shows the bug.

cbradney

2008-04-24 08:34

administrator   ~0019545

Franz, can you please get the cairo guys to have a look at this?

fschmid

2008-04-24 09:13

administrator   ~0019546

Have already send a mail to Cworth pointing him to this bug.

fschmid

2008-04-24 18:51

administrator   ~0019547

Committed now an ugly hack to fix at least parts of that problem.
Final fix is only possible with a fixed cairo lib.

fschmid

2008-07-01 09:10

administrator   ~0019917

Can we close that bug as its a cairo bug?

fschmid

2008-10-21 07:14

administrator   ~0020473

This issue is fixed with cairo 1.8.0

Issue History

Date Modified Username Field Change
2008-04-22 21:35 cbradney New Issue
2008-04-22 21:35 cbradney File Added: snapshot17.png
2008-04-22 21:44 cbradney Note Added: 0019536
2008-04-22 21:54 cbradney Severity major => minor
2008-04-23 06:34 fschmid Note Added: 0019540
2008-04-23 12:08 fschmid Note Added: 0019541
2008-04-23 12:55 fschmid Note Added: 0019542
2008-04-24 07:41 fschmid File Added: WeiredFrame.png
2008-04-24 07:42 fschmid Note Added: 0019543
2008-04-24 08:22 fschmid Note Added: 0019544
2008-04-24 08:34 cbradney Note Added: 0019545
2008-04-24 09:13 fschmid Note Added: 0019546
2008-04-24 18:51 fschmid Note Added: 0019547
2008-07-01 09:10 fschmid Note Added: 0019917
2008-10-21 07:14 fschmid Note Added: 0020473
2008-10-21 07:14 fschmid Status new => resolved
2008-10-21 07:14 fschmid Fixed in Version => 1.3.5svn
2008-10-21 07:14 fschmid Resolution open => fixed
2008-10-21 07:14 fschmid Assigned To => fschmid
2008-10-22 19:55 cbradney Status resolved => closed