View Issue Details

IDProjectCategoryView StatusLast Update
0000740ScribusStory Editor / Text Framespublic2019-05-31 22:32
Reporterjkyro Assigned Tocbradney  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionwon't fix 
PlatformallOSallOS Versionall
Product Version1.3 
Target VersionFixed in Version 
Summary0000740: Ability to scale text according to frame size and vice versa
DescriptionIt would be nice to be able to lock down the size of a text frame and have the text within scale as typed (like Powerpoint :). For example, the font size could be set according to the frame height and kerning/possible word spacing according to frame width. Or just set the font size so that the text bounding box just fits into the frame.

Also the opposite, or the ability to adjust the size of the frame according to the bounding box of the contents would be good.

Does this make sense when using non-rectangular shapes for the frame?
Tagsresize
PatchNo

Relationships

related to 0008195 feedback New text frame options (fontsize:linespace or linespace:fontsize) 
related to 0009079 new Wrong font settings in textframe visible 
has duplicate 0002877 closed Option to fit frame to text and text to frame 
has duplicate 0007400 closedjghali fit text to frame and fit frame to text 
related to 0001069 closedjghali Auto-adjust size of text box to the text 

Activities

plinnell

2004-06-03 22:04

viewer   ~0001648

>It would be nice to be able to lock down the size of a text frame and have the >text within scale as typed (like Powerpoint :).

Be careful mentioning Powerpoint around print people. It is one of the most difficult to get printed properly in commericial printing. ;) Almost as detested as MS Publisher files.

That said, you can convert a text frame into postscript outlines and then group and scale by Ctrl- left dragging with the mouse.

>For example, the font size could be set according to the frame height and >kerning/possible word spacing according to frame width. Or just set the font >size so that the text bounding box just fits into the frame.

I do not see a great deal of usefulness for this honestly and it would probably come at a terrific performance hit. PP can do this because, no MS Office app handles type in the way a professional DTP app would IMO.

>Also the opposite, or the ability to adjust the size of the frame according to >the bounding box of the contents would be good.

Or "Shrink Frame" command - that could be useful.

jkyro

2004-06-04 16:27

reporter   ~0001662

OK, I don't necessarily mean adjusting the text on the fly while typing.

For me, there would be value in a command like
'Fit text inside frame' to adjust the font size to the maximum at which the text is completely inside the frame.
Hmm, how about "Fit text width" which would set the kerning according to the frame size?

cbradney

2004-06-04 16:52

administrator   ~0001663

dont forget theres also control shift drag to resize text with the frame.

ringerc

2004-09-05 19:17

reporter   ~0002299

"Snap frame to text" would actually be very useful for headlines, bylines, etc where excess space is a problem. Doubly so where text is set to flow around the object. It would be best done as a one-off action IMO, somewhat like the current "Snap frame to image" command.

louisdesjardins

2006-04-23 19:01

developer   ~0010370

[quote]"Snap frame to text" would actually be very useful for headlines, bylines, etc where excess space is a problem. Doubly so where text is set to flow around the object. It would be best done as a one-off action IMO, somewhat like the current "Snap frame to image" command.
[unquote]

The headlines example is a good one, imo. This feature could prove to be useful in many circumstances where the design it very tight and space a rarity like in newspapers.

I don't know just how much work (or is it feasible at all) it would be to have the opportunity to fit text within the selected [margins] or [guides] because the text frame can by itself be a bit limitative.

Also wonder just how much this would be worth the effort...

cezaryece

2010-01-20 08:31

developer   ~0023116

In Ventura is feature automatically add interline value and/or above/below paragraph spacing for fitting text into frame height.
In CorelDRAW is feature to fit text into frame which resize font for this purpose.
If we combine these both and add stretching and kerning possibilities we get powerful feature.

aliB

2010-01-20 10:51

reporter   ~0023117

Last edited: 2016-03-22 15:14

View 2 revisions

Sounds like issue 0008195

But I think this feature could also be implemented as a script.
Will do this when I have some time left.

ale

2019-03-21 08:43

manager   ~0046030

i don't see much chances for this feature to be implemented.

the effect (without scaling the text while typing) can be achieved the other way round:

- adjust frame to text
- alt can be used to scale the text when resizing the frame

i suggest to close this ticket.

Issue History

Date Modified Username Field Change
2004-06-02 10:04 jkyro New Issue
2004-06-03 22:04 plinnell Note Added: 0001648
2004-06-04 16:27 jkyro Note Added: 0001662
2004-06-04 16:52 cbradney Note Added: 0001663
2004-09-05 19:17 ringerc Note Added: 0002299
2005-11-28 17:43 plinnell Relationship added has duplicate 0002877
2006-02-06 18:10 jo-hannes Relationship added related to 0001069
2006-04-12 10:29 mhanski OS Fedora Core => all
2006-04-12 10:29 mhanski OS Version 1 => all
2006-04-12 10:29 mhanski Platform PC => all
2006-04-12 10:29 mhanski Product Version 1.2CVS => 1.3.4cvs
2006-04-12 10:29 mhanski Description Updated
2006-04-13 13:33 plinnell Product Version 1.3.4cvs => 1.3
2006-04-23 16:46 mhanski Status new => feedback
2006-04-23 19:01 louisdesjardins Note Added: 0010370
2008-09-18 20:46 jghali Relationship added has duplicate 0007400
2010-01-20 08:31 cezaryece Note Added: 0023116
2010-01-20 10:51 aliB Note Added: 0023117
2015-05-21 18:53 Kunda Relationship added related to 0008195
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames
2016-03-22 15:14 Kunda Note Edited: 0023117 View Revisions
2016-03-22 15:14 Kunda Patch => No
2016-03-22 15:14 Kunda Summary Ability to scale text according to frame sizeand vice versa => Ability to scale text according to frame size and vice versa
2016-03-31 16:13 Kunda Tag Attached: resize
2016-04-04 03:16 Kunda Relationship added related to 0009079
2019-03-21 08:43 ale Note Added: 0046030
2019-05-31 22:32 cbradney Assigned To => cbradney
2019-05-31 22:32 cbradney Status feedback => closed
2019-05-31 22:32 cbradney Resolution open => won't fix