View Issue Details

IDProjectCategoryView StatusLast Update
0007563ScribusGraphics / Image Framespublic2015-02-02 00:29
Reporterflorian Assigned Tosubik  
PrioritynormalSeverityfeatureReproducibilityalways
Status assignedResolutionfixed 
PlatformIntel 32-bitOSLinuxOS VersionopenSuSE 10.3
Product Version1.3.5svn 
Target Version1.7 milestoneFixed in Version1.5.0svn 
Summary0007563: Preflight Verifier: report underfull image frames
DescriptionSuppose I have a rectangular image (width: 40 mm, height: 30 mm) in an image frame (width: 40 mm, height: 30 mm). The image frame fits the image exactly; that is what I want.

Suppose I have a rectangular image (width: 40 mm, height: 30 mm) in an image frame (width: 20 mm, height: 20 mm). The image frame clips the image; that is what I want.

Now the problem:

Suppose I have a rectangular image (width: 40 mm, height: 30 mm) in an image frame (width: 40 mm, height: 40 mm). The image frame is partly blank; that could be a mistake.

I'd like to have the preflight checker report this underfull image frame.
TagsPreflightChecker
PatchNo

Relationships

child of 0012524 acknowledged Metabug: Preflight Verifier (1.5.0.svn) 

Activities

subik

2011-01-31 21:05

manager   ~0025505

Committed revision 16329.

ale

2011-02-01 12:36

manager   ~0025510

nice!

ale

2011-02-02 12:56

manager   ~0025518

Last edited: 2011-02-02 12:56

View 2 revisions

just one question: wouldn't be better to have a setting to enable/disable it?
i can think of some people who like to have underflowed frames and may be annoyed if they get warned each time.

ale

2011-02-02 14:39

manager   ~0025519

Last edited: 2011-02-02 14:40

View 2 revisions

sorry, it does not work correctly...

- create an image frame
- import an image into it
- adjust frame to image
- launch the preflight verifier
- you get a warning that the image dimension is smaller than its frame

ale

2011-02-02 16:01

manager   ~0025520

since reactivating the debug line shows

REGULAR: ImageUnderfullsFrame 57 43.5 57 43.5

for a fitting icon.

if i add some more details, i get:

REGULAR: ImageUnderfullsFrame 28.5 29 0.75 21.75 28.5 29 0.75 21.75

for

qDebug() << "REGULAR: ImageUnderfullsFrame" << currItem->height() << currItem->pixm.height() << currItem->imageYScale() << currItem->imageYScale()*currItem->pixm.height() << currItem->width() << currItem->pixm.width() << currItem->imageXScale() << currItem->imageXScale()*currItem->pixm.width();

it does not seem to match...

cbradney

2011-02-02 20:18

administrator   ~0025522

No, there is a missing variable.. I saw this the other night too.. reopening bug

ale

2011-02-05 08:07

manager   ~0025540

btw, i wonder if it should not also test the left (imageXOffset > 0) and right margin (imageXOffset+pixm.width < curritem.width)

subik

2011-02-13 12:54

manager   ~0025575

ok, prefs implemented. Unfortunately I'm still searching for right algorithm...

subik

2011-03-07 19:30

manager   ~0025758

bump. Can you test it, please?

ale

2011-03-08 09:40

manager   ~0025762

is the correct algorithm in 1.5svn?

subik

2011-03-08 10:28

manager   ~0025763

in trunk. Is it 1.5svn?

pygmee

2012-10-21 08:53

developer   ~0029068

what's the state of this ? say it's in trunk but i can't see any errors in 150 preflight when testing

cezaryece

2012-10-22 06:28

developer   ~0029074

I have exactly different problem - every (or almost) image causing this warning in preflight.

Kunda

2014-09-04 23:32

manager   ~0033506

bumped to 1.7 due to all the work done on it so far but seemingly not high enough priority for 1.6 (feedback?)

Issue History

Date Modified Username Field Change
2008-10-24 14:45 florian New Issue
2009-01-28 08:38 subik Status new => assigned
2009-01-28 08:38 subik Assigned To => subik
2011-01-31 21:05 subik Note Added: 0025505
2011-01-31 21:05 subik Status assigned => resolved
2011-01-31 21:05 subik Fixed in Version => 1.5.0svn
2011-01-31 21:05 subik Resolution open => fixed
2011-02-01 12:36 ale Note Added: 0025510
2011-02-02 12:56 ale Note Added: 0025518
2011-02-02 12:56 ale Note Edited: 0025518 View Revisions
2011-02-02 14:39 ale Note Added: 0025519
2011-02-02 14:40 ale Note Edited: 0025519 View Revisions
2011-02-02 16:01 ale Note Added: 0025520
2011-02-02 20:18 cbradney Note Added: 0025522
2011-02-02 20:18 cbradney Status resolved => assigned
2011-02-05 08:07 ale Note Added: 0025540
2011-02-13 12:54 subik Note Added: 0025575
2011-03-07 19:30 subik Note Added: 0025758
2011-03-08 09:40 ale Note Added: 0025762
2011-03-08 10:28 subik Note Added: 0025763
2012-10-21 08:53 pygmee Note Added: 0029068
2012-10-22 06:28 cezaryece Note Added: 0029074
2014-07-10 20:42 JLuc Tag Attached: PreflightChecker
2014-09-04 23:32 Kunda Note Added: 0033506
2014-09-04 23:32 Kunda Target Version => 1.7 milestone
2014-09-18 22:58 Kunda Relationship added child of 0012524
2015-02-02 00:29 Kunda Patch => No
2015-02-02 00:29 Kunda Summary Preflight checker: report underfull image frames => Preflight Verifier: report underfull image frames
2015-09-17 20:10 Kunda Category Graphics / Image Frames => Graphics/Img Frames
2015-09-17 20:11 Kunda Category Graphics/Img Frames => Graphics / Image Frames