View Issue Details

IDProjectCategoryView StatusLast Update
0007904ScribusStory Editor / Text Framespublic2014-07-10 02:55
ReporteraliB Assigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformDell Inspiron 9400OSLinuxOS VersionOpenSuSE 11.1
Product Version1.3.5svn 
Target VersionFixed in Version 
Summary0007904: Opening the Story Editor takes a long time.
DescriptionOpening the Story Editor takes a long time even when the textframe is empty!
TagsNo tags attached.
Patch

Activities

jghali

2009-03-27 09:11

administrator   ~0021415

Last edited: 2009-03-27 09:11

Unable to reproduce, instant here.

subik

2009-03-27 20:08

manager   ~0021423

the same as in the Jean case - instant time to open.

What Qt version are you using? What desktop environment? Window effects?

aliB

2009-03-29 14:05

reporter   ~0021435

I use KDE 3.5.10. Where can I see which qt version is used?

If I have many pages ( > 40) with much text, opening the story editor takes longer (even on an empty text frame).
Opening the story editor of an empty textframe:
empty doc: 1 sec
doc with > 15 pages 2-3 sec
doc with 45 pages 3-4 sec

I consider 2 secs for opening an empty text frame as long

subik

2009-03-29 17:09

manager   ~0021436

well, sample doc: 50 pages with auto-frames fully filled with Lorem Ipsum text.

new empty andunlinked text frame - SE appears immediatelly.

opening SE on linked frame (page 36) takes about 3s.

So there is slowdown a bit.

subik

2009-03-31 17:53

manager   ~0021454

a little "benchmark":

Index: storyeditor.cpp
===================================================================
--- storyeditor.cpp (revision 13365)
+++ storyeditor.cpp (working copy)
@@ -1,3 +1,4 @@
+#include "util.h"
 /*
 For general Scribus (>=1.3.2) copyright and licensing information please refer
 to the COPYING file provided with the program. Following this notice may exist
@@ -615,28 +616,38 @@
 
 void SEditor::loadItemText(PageItem *currItem)
 {
+tDebug("1");
     StyledText.clear();
     FrameItems.clear();
+tDebug("1.1.1");
     StyledText.setDefaultStyle(currItem->itemText.defaultStyle());
+tDebug("1.1.2");
     StyledText.append(currItem->itemText);
+tDebug("1.1.3");
     updateAll();
+tDebug("1.2");
     int npars = currItem->itemText.nrOfParagraphs();
     SelParaStart = 0;
     while (currItem->CPos >= (SelCharStart = currItem->itemText.endOfParagraph(SelParaStart))
            && SelParaStart < npars)
         ++SelParaStart;
+tDebug("1.3");
     if (currItem->CPos < SelCharStart)
         SelCharStart = currItem->CPos;
+tDebug("1.4");
     SelCharStart -= currItem->itemText.startOfParagraph(SelParaStart);
     StoredSel = false;
     //qDebug() << "SE::loadItemText: cursor";
 // setCursorPosition(SelParaStart, SelCharStart);
+tDebug("1.5");
     emit setProps(SelParaStart, SelCharStart);
     SelParaStart = 0;
+tDebug("2");
 }


19:51:11:681 1
19:51:11:682 1.1.1
19:51:11:682 1.1.2
19:51:16:387 1.1.3
19:51:18:119 1.2
19:51:18:157 1.3
19:51:18:157 1.4
19:51:18:157 1.5
19:51:18:157 2

so the main issue is:
StyledText.append(currItem->itemText);

and
updateAll();

subik

2009-03-31 17:54

manager   ~0021455

Reminder sent to: avox

Andreas, any hints about StoryText usage, please?

Kunda

2014-07-08 16:11

updater   ~0032588

Running OSX 1.5svn r19331 I can't say this is true from my experience.
Proposing to close this issue because of the age of the discussion, any objections?

Kunda

2014-07-10 02:55

updater   ~0032648

Old issue that has been unreproducible. Closing

Issue History

Date Modified Username Field Change
2009-03-27 08:40 aliB New Issue
2009-03-27 09:11 jghali Note Added: 0021415
2009-03-27 09:11 jghali Note Edited: 0021415
2009-03-27 20:08 subik Note Added: 0021423
2009-03-29 14:05 aliB Note Added: 0021435
2009-03-29 17:09 subik Note Added: 0021436
2009-03-31 17:53 subik Note Added: 0021454
2009-03-31 17:54 subik Note Added: 0021455
2014-07-08 16:11 Kunda Note Added: 0032588
2014-07-08 16:11 Kunda Status new => feedback
2014-07-10 02:55 Kunda Note Added: 0032648
2014-07-10 02:55 Kunda Status feedback => closed
2014-07-10 02:55 Kunda Resolution open => unable to reproduce
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames