View Issue Details

IDProjectCategoryView StatusLast Update
0008132ScribusStory Editor / Text Framespublic2009-06-10 09:06
Reporterodile Assigned Tojghali  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
PlatformPC - LinuxOSUbuntuOS Version8.04
Product Version1.3.3.11 
Target VersionFixed in Version 
Summary0008132: Scribus 1.3.3.11 does not properly display some non-ASCII set with an AZERTy keyboard (French accents)
DescriptionNeed to use a tab characters out of scribus, to copy/paste value like U+00E9 LATIN SMALL LETTER E WITH ACUTE because Scribus 1.3.3.11 cannot properly manage some non-ASCII characters :'(
Steps To Reproduce1. With a configured french keyboard (AZERTY)
2. try to add a accentued character like "é" or "â"
Additional InformationI do not know if this is related to SCIM support ?
But it sounds better on text editor !
TagsNo tags attached.
Patch

Relationships

duplicate of 0001908 closedavox Dead Keys do not work 

Activities

odile

2009-06-10 08:18

reporter   ~0021910

Last edited: 2009-06-10 08:20

"é" ( set on keyboard) => will be displayed as "è" on text field (Scribus)

U+00E9 LATIN SMALL LETTER E WITH ACUTE = U+00E8 LATIN SMALL LETTER E WITH GRAVE
U+0065 LATIN SMALL LETTER E U+0301 COMBINING ACUTE ACCENT = U+0065 LATIN SMALL LETTER E U+0300 COMBINING GRAVE ACCENT

UTF-8 : 0xC3 0xA9 = 0xC3 0xA8
UTF-16 : 0x00E9 = 0x00E8

UTF-8 en C octal échappé : \303\251 = \303\250
Entité décimale XML : & # 233 ; = & # 232 ;

odile

2009-06-10 08:24

reporter   ~0021911

Last edited: 2009-06-10 08:27

seems to be duplicate of or related to 0001512, 0001713, 0001720 ...

jghali

2009-06-10 09:05

administrator   ~0021912

Yep duplicate of issue 0001908

Issue History

Date Modified Username Field Change
2009-06-10 08:11 odile New Issue
2009-06-10 08:18 odile Note Added: 0021910
2009-06-10 08:20 odile Note Edited: 0021910
2009-06-10 08:24 odile Note Added: 0021911
2009-06-10 08:27 odile Note Edited: 0021911
2009-06-10 09:05 jghali Note Added: 0021912
2009-06-10 09:05 jghali Relationship added duplicate of 0001908
2009-06-10 09:05 jghali Duplicate ID 0 => 1908
2009-06-10 09:05 jghali Status new => resolved
2009-06-10 09:05 jghali Resolution open => duplicate
2009-06-10 09:05 jghali Assigned To => jghali
2009-06-10 09:06 jghali Status resolved => closed
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames