View Issue Details

IDProjectCategoryView StatusLast Update
0008404ScribusUser Interfacepublic2014-07-19 02:32
Reporterale Assigned To 
PrioritylowSeverityminorReproducibilityN/A
Status closedResolutionwon't fix 
Product Version1.3.6svn 
Target VersionFixed in Version 
Summary0008404: screen/web > RGB // printer > CMYK
Descriptionplease, rename "screen/web" to RGB and "printer" to CMYK: the current labels don't really make sense.
Tags#tobeclosed
Patch

Activities

jghali

2009-09-03 18:56

administrator   ~0022458

Renaming "printer" to CMYK do not make really sense either as checking the "use profiles" options will trigger use of RGB. Such renaming will only be possible in 1.5.0svn after a lot of internal work and quite some changes in color management options.

cbradney

2009-09-03 20:36

administrator   ~0022459

They were renamed a long time ago from RGB/CMYK btw

ale

2009-09-04 20:20

manager   ~0022461

maybe there should be no "use profile" checkbox but a choice between:
- cmyk
- rgb
- grayscale
- use profiles

(i don't know if cmyk without color management makes much sense, though)

@cbradney: they may have been renamed at a time when a printer was either b/w or cmyk... today this is not true anymore...

imo, the wording of the options must not be what i suggests, but it surely has to be less equivocal than it is right now!

jghali

2009-09-05 01:01

administrator   ~0022462

>> maybe there should be no "use profile" [...]

Having a specific item for "use profile" does not make sense. Currently the "use profiles" options mainly allows to tune pdf/x-3 output and consequently it does not make sense to have those options elsewhere than in "Printer" options. Using distinct cmyk/rgb/grayscale items would also put limits to what we can do when outputting pdf especially x-3. Remember pdf/x-3 explicitly allows to use both rgb cmykon a same page... Also will your convert a grayscale image to cmyk when the "cmyk" item would be selected? That's what we'll have to do if we adopt such categories. Practically that's just stupid however... Using output intent such as "Screen/Web" and "Printer" allows to produce a more optimal output than targeting a specific type of color space.

>> they may have been renamed at a time when a printer was either b/w or cmyk

No, when they were renamed rgb printer were already on the market and for quite a long time even. Rgb printers have existed since at least gdi first days on Windows, that means well before 1995 and consequently well before Scribus existed. True rgb output device have been used in professional photography and digital effects for quite a long time too.

>> but it surely has to be less equivocal than it is right now

The problem is in fact not in the "Screen/Web" and "Printer" options naming. The real problem is the confusion around the "use profiles" options and what they do.

christoph_s

2009-09-05 03:14

administrator   ~0022463

Last edited: 2009-09-05 03:14

>>Such renaming will only be possible in 1.5.0svn after a lot of internal work and quite some changes in color management options.

What this discussion tells us, though, that it needs a better documentation, both in the Help Browser and the next edition of the manual.

Jean, since you seem to be the only one who knows exactly what is doing what, could you send me list with explanations of all CM and output options that enable me to write a (hopefully) useful text?

GurgiONE

2009-10-05 06:51

reporter   ~0022618

Just want you to know:
I had trouble to find the CMYK PDF output option. I was close to write a letter until i found this bugreport. PLEASE rename it! I whould never figured it out that "printer" should be CMYK.... why did you change it anyway?

jghali

2009-10-05 06:58

administrator   ~0022619

Because "Printer" is not necessarily CMYK, enable the "use profiles" options and you will have RGB in your output files.

FirasH

2014-07-05 17:54

developer   ~0032495

In the tooltip there is "Choose Printer when printing to a true 4 color CMYK printer." Can be closed?

Issue History

Date Modified Username Field Change
2009-09-03 15:19 ale New Issue
2009-09-03 18:56 jghali Note Added: 0022458
2009-09-03 20:36 cbradney Note Added: 0022459
2009-09-03 23:41 christoph_s Priority high => low
2009-09-04 20:20 ale Note Added: 0022461
2009-09-05 01:01 jghali Note Added: 0022462
2009-09-05 03:14 christoph_s Note Added: 0022463
2009-09-05 03:14 christoph_s Note Edited: 0022463
2009-10-05 06:51 GurgiONE Note Added: 0022618
2009-10-05 06:58 jghali Note Added: 0022619
2014-07-05 17:54 FirasH Note Added: 0032495
2014-07-09 22:31 Kunda Tag Attached: #tobeclosed
2014-07-19 02:32 FirasH Status new => closed
2014-07-19 02:32 FirasH Resolution open => won't fix