View Issue Details

IDProjectCategoryView StatusLast Update
0008471ScribusFontspublic2016-04-11 00:02
Reporter386sky Assigned To 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
PlatformDaokoreaOSWindows XPOS VersionM010
Product Version1.3.3.13 
Target VersionFixed in Version 
Summary0008471: Crash during Microsoft IMEs (Chinese, Japanese, Korean)
DescriptionYou found that Scribus v1.34 has great improvement in handling Microsoft input method editors, and become less crash now. However, 2 bugs still remain here:

1. Cannot input CJK directly in Text box. User have to right click the Text Box => Edit Text (0013612)

2. If you forget choosing and CJK Font before inputting CJK, it cannot show CJK successfully, and must crash!!! With error message as "Exception_Access_Violate"
(However, notice that copy and paste CJK directly into that box is okay!) (0003173)
TagsNo tags attached.
PatchNo

Relationships

related to 0003173 closed Japanese (CJK) text in story editor is not entered into text frame. Frequent crashes. 
has duplicate 0008568 closedjghali No Support Chinese 
related to 0013612 confirmed No input method preedit when one inputs CJ text directly into a text frame 

Activities

386sky

2009-10-05 17:49

reporter   ~0022621

can you use Microsoft's error reporter, rather than the default error reporter

lyp069

2010-03-10 05:49

reporter   ~0023478

I think this report is true.I have the same state of affairs.I use ubuntu 9.10.It will crash when you choose chinese font.

Kunda

2015-06-30 16:55

manager   ~0035581

Added relationship with 0003173 though not sure that is relevant.

Kunda

2016-01-23 21:44

manager   ~0038380

Ftake, can you help me understand if this issue is still relevant. I'm resolving this unless you think it should stay open.

1. Cannot input CJK directly in Text box. User have to right click the Text Box => Edit Text
This seems like a duplicate of 0013612

2. If you forget choosing and CJK Font before inputting CJK, it cannot show CJK successfully, and must crash!!! With error message as "Exception_Access_Violate"
(However, notice that copy and paste CJK directly into that box is okay!)
This seems like it's was fixed in 0003173

Kunda

2016-02-12 22:13

manager   ~0038683

Closing since all mentioned issue have tickets that are either resolved or duplicate.

Kunda

2016-04-11 00:02

manager   ~0040034

we need testers and test files for ScribusCTL that could support Vertical Text: https://github.com/HOST-Oman/scribus/issues/143

Issue History

Date Modified Username Field Change
2009-09-29 12:48 386sky New Issue
2009-10-05 17:49 386sky Note Added: 0022621
2009-11-05 11:45 jghali Relationship added has duplicate 0008568
2010-03-10 05:49 lyp069 Note Added: 0023478
2015-06-30 16:54 Kunda Relationship added related to 0003173
2015-06-30 16:55 Kunda Note Added: 0035581
2016-01-23 21:36 Kunda Relationship added related to 0013612
2016-01-23 21:40 Kunda Patch => No
2016-01-23 21:40 Kunda Description Updated View Revisions
2016-01-23 21:41 Kunda Description Updated View Revisions
2016-01-23 21:44 Kunda Note Added: 0038380
2016-01-23 21:45 Kunda Status new => resolved
2016-01-23 21:45 Kunda Resolution open => fixed
2016-02-12 22:13 Kunda Note Added: 0038683
2016-02-12 22:13 Kunda Status resolved => closed
2016-04-11 00:02 Kunda Note Added: 0040034