View Issue Details

IDProjectCategoryView StatusLast Update
0009057ScribusIntegrationpublic2016-12-08 22:04
Reportersubeditor Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status confirmedResolutionunable to reproduce 
PlatformPC AMD64 X2, Ati Radeon 3200OSUbuntuOS Version9.10
Product Version1.3.7svn 
Target Version1.5.4Fixed in Version 
Summary0009057: Scribus floating toolbars are visible in other applications
Descriptionsubj
Moreover, they don't respond for my OS "show desktop" button.
Steps To ReproduceRun Scribus.
Drag some toolbar to make it float.
Switch to another application - toolbar still visible in front.

Updated steps: by subeditor 2010-04-25 10:24

I manage to reproduce this bug stably (so please keep it status as "always").
Tested on 1.3.6, 1.3.7, 1.5.0. - it persists. Moreover, on picture you can see three toolbars in front of all other windows simultaneously.

Steps to reproduse:
- run Scribus;
- drag toolbar to make it float;
- close Scribus;
- run Scribus - toolbars appear on their previous positions;
- minimize Scribus window or switch to other app - floating toolbars float in front of all windows.
If you move toolbars after you run Scribus, they will start to hide/show together with Scribus window. But there is still some unpredictable behavior - randomly they won't pop up with Scribus.

And one more related bug (may should be posted separately) - when switching to Scribus window by clicking on GNOME panel Scrubus pops up, but doesn't become active. It happens only if you have moved one of floating toolbars.
When all toolbars are docked there is no bug.

Update from mapreri 2015-09-27 13:58
Note that you really need to close+reopen scribus to trigger it.
Tags#please_test, indigodock, Qt5.8
PatchNo

Relationships

related to 0011399 closedFirasH Dialogs are hidden by Palettes docked and then undocked 
related to 0011929 confirmed FontSample script pushes the Scribus main window to the foreground under KDE 
related to 0012073 closedFirasH Master Pages always on top even when switching applications 

Activities

subeditor

2010-04-24 11:06

reporter  

floatingtoolbars.png (33,040 bytes)
floatingtoolbars.png (33,040 bytes)

jghali

2010-04-24 11:22

administrator   ~0023801

Cannot reproduce on Windows

subeditor

2010-04-24 11:42

reporter   ~0023804

Last edited: 2010-04-24 11:48

View 2 revisions

Sorry, change Reproducibility to random, after moving toolbar a bit it starts to hide with main windows.
But don't close this bug, I'll play around with it, there is some issues, f.e. sometimes toolbars are not restored when restoring main Scribus windows.

subeditor

2010-04-25 08:24

reporter   ~0023811

I manage to reproduce this bug stably (so please keep it status as "always").
Tested on 1.3.6, 1.3.7, 1.5.0. - it persists. Moreover, on picture you can see three toolbars in front of all other windows simultaneously.

Steps to reproduse:
- run Scribus;
- drag toolbar to make it float;
- close Scribus;
- run Scribus - toolbars appear on their previous positions;
- minimize Scribus window or switch to other app - floating toolbars float in front of all windows.
If you move toolbars after you run Scribus, they will start to hide/show together with Scribus window. But there is still some unpredictable behavior - randomly they won't pop up with Scribus.

And one more related bug (may should be posted separately) - when switching to Scribus window by clicking on GNOME panel Scrubus pops up, but doesn't become active. It happens only if you have moved one of floating toolbars.
When all toolbars are docked there is no bug.

subeditor

2010-04-25 08:25

reporter  

multitoolbars.png (91,617 bytes)
multitoolbars.png (91,617 bytes)

subeditor

2010-06-21 10:18

reporter   ~0024171

Bug still exists in 1.3.8svn on Ubuntu 10.04.

Kunda

2014-07-24 04:26

manager   ~0032953

Not reproducible on OSX 10.8.5 1.5svn r19366

FirasH

2014-07-24 04:35

developer   ~0032954

Confirming with 1.4.5.svn (19364) and 1.5.0.svn (19365) on FreeBSD + XFCE.
(Should be the same on openSUSE + KDE)

FirasH

2015-09-26 21:53

developer   ~0036405

Cannot reproduce with current openSUSE

Kunda

2015-09-26 22:55

manager   ~0036406

Looks like this is not reproducible anymore. Resolving for now.

mapreri

2015-09-27 11:58

developer   ~0036415

I'm able to reproduce it with 1.5.1svn (r20425) on Ubuntu 14.04 with unity. Can't test with the current ubuntu development release, but can't think why it should be fixed there, so I assert this is still a bug.

Note that you really need to close+reopen scribus to trigger it.

Kunda

2015-11-30 23:50

manager   ~0037758

mapreri, can you test on a more recent version of Ubuntu ?

mapreri

2015-12-11 13:47

developer   ~0037898

I just tried with an up-to-date ubuntu xenial (=> current development release) in virtualbox and scribus 1.5.1svn r20615.

The bug is still there.

Kunda

2015-12-13 14:36

manager   ~0037912

mapreri, thanks for the update
What Qt version are you using btw ?

mapreri

2015-12-13 14:46

developer   ~0037913

5.5.1

Kunda

2016-03-08 17:23

manager   ~0039064

we need to test this with Qt5.6

Kunda

2016-03-18 21:40

manager   ~0039246

mapreri, 5.6 was just released. Would you be so kind to test when you have moment? Thanks!

mapreri

2016-03-18 23:02

developer   ~0039250

Yeah, reproducible with Qt 5.6 too. This time on today Debian Unstable + Qt 5.6 from experimental with scribus r21089.

Kunda

2016-05-12 13:07

manager   ~0040967

Martin over at indigodock recently fixed an issue like this. I've tagged this ticket with the indigodock tag so that we can keep track of it when the times comes when the devs consider indigodock as a replacement for current GUI

Kunda

2016-12-07 17:51

manager   ~0042775

Last edited: 2016-12-07 17:57

View 2 revisions

Issue still exists in 1.5.3svn r21584 using instructions from 0009057:0023811
Manjaro 16.10
Qt 5.7

Issue History

Date Modified Username Field Change
2010-04-24 11:06 subeditor New Issue
2010-04-24 11:06 subeditor File Added: floatingtoolbars.png
2010-04-24 11:22 jghali Note Added: 0023801
2010-04-24 11:42 subeditor Note Added: 0023804
2010-04-24 11:48 subeditor Note Edited: 0023804 View Revisions
2010-04-25 08:24 subeditor Note Added: 0023811
2010-04-25 08:25 subeditor File Added: multitoolbars.png
2010-06-21 10:18 subeditor Note Added: 0024171
2014-07-24 04:26 Kunda Note Added: 0032953
2014-07-24 04:35 FirasH Note Added: 0032954
2014-07-24 04:35 FirasH Status new => confirmed
2014-07-24 04:37 Kunda Relationship added related to 0011399
2014-07-24 04:38 Kunda Target Version => 1.5.1
2014-09-12 13:25 Kunda Relationship added related to 0012073
2014-09-19 18:36 Kunda Relationship added related to 0011929
2015-09-26 21:53 FirasH Note Added: 0036405
2015-09-26 22:55 Kunda Note Added: 0036406
2015-09-26 22:55 Kunda Status confirmed => resolved
2015-09-26 22:55 Kunda Resolution open => unable to reproduce
2015-09-26 22:55 Kunda Assigned To => Kunda
2015-09-27 11:27 Kunda Patch => No
2015-09-27 11:27 Kunda Steps to Reproduce Updated View Revisions
2015-09-27 11:58 mapreri Note Added: 0036415
2015-09-27 14:37 Kunda Assigned To Kunda =>
2015-09-27 14:37 Kunda Status resolved => confirmed
2015-09-28 15:07 Kunda Steps to Reproduce Updated View Revisions
2015-11-30 23:50 Kunda Note Added: 0037758
2015-11-30 23:50 Kunda Tag Attached: #please_test
2015-12-11 13:47 mapreri Note Added: 0037898
2015-12-13 14:36 Kunda Note Added: 0037912
2015-12-13 14:46 mapreri Note Added: 0037913
2016-01-23 17:17 cbradney Target Version 1.5.1 => 1.5.3
2016-03-08 17:23 Kunda Note Added: 0039064
2016-03-08 17:23 Kunda Tag Attached: Qt5.6
2016-03-18 21:40 Kunda Note Added: 0039246
2016-03-18 23:02 mapreri Note Added: 0039250
2016-05-12 13:06 Kunda Tag Attached: indigodock
2016-05-12 13:07 Kunda Note Added: 0040967
2016-12-07 17:51 Kunda Note Added: 0042775
2016-12-07 17:57 Kunda Note Edited: 0042775 View Revisions
2016-12-07 18:05 Kunda Tag Detached: Qt5.6
2016-12-07 19:40 Kunda Tag Attached: Qt5.8
2016-12-08 22:04 Kunda Target Version 1.5.3 => 1.5.4