View Issue Details

IDProjectCategoryView StatusLast Update
0009113ScribusGeneralpublic2016-05-21 13:33
Reportersubeditor Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformPC AMD64 X2, Ati Radeon 3200OSUbuntuOS Version10.04
Product Version1.3.7svn 
Target VersionFixed in Version 
Summary0009113: Rotated frames are poorly editable
DescriptionBoth image and text frames are difficult to edit when they are rotated. There is bunch of issues:
1) text is not selectable with mouse when angle is 180 (see selctable-text-180-degrees.gif) and tricky selectable at other angles (see selctable-text-varying-degrees.gif)
2) frames with borders don't snap correctly; see 0010678
3) text frames have unpredictable text flow and/or redraw. see 0012118
Steps To ReproduceJust rotate frames and play with it.
Tagsrotate
PatchNo

Relationships

related to 0010678 confirmed Resizing rotated items moving handles does not snap to Guides 
related to 0012118 closedjghali Resizing rotated items going over 0 width/height behaves strangely 

Activities

Kunda

2016-05-19 14:22

manager  

Kunda

2016-05-19 14:32

manager  

Kunda

2016-05-19 14:34

manager   ~0041220

Last edited: 2016-05-19 15:58

View 2 revisions

Can't reproduce main issue of this ticket (unable to select or edit text at varying degrees)
Issues 2 and 3 are dupes.
I'm resolving this ticket for now

OSX 10.10.5 1.5.3svn r21338

Kunda

2016-05-21 13:33

manager   ~0041276

Closing

Issue History

Date Modified Username Field Change
2010-05-19 08:06 subeditor New Issue
2016-05-10 18:15 Kunda Relationship added related to 0010678
2016-05-10 18:16 Kunda Patch => No
2016-05-10 18:16 Kunda Description Updated View Revisions
2016-05-10 18:17 Kunda Tag Attached: rotate
2016-05-10 20:05 Kunda Tag Attached: duplicate
2016-05-19 14:16 Kunda Tag Detached: duplicate
2016-05-19 14:22 Kunda File Added: selctable-text-180-degrees.gif
2016-05-19 14:31 Kunda Description Updated View Revisions
2016-05-19 14:32 Kunda File Added: selctable-text-varying-degrees.gif
2016-05-19 14:34 Kunda Note Added: 0041220
2016-05-19 14:34 Kunda Status new => resolved
2016-05-19 14:34 Kunda Resolution open => unable to reproduce
2016-05-19 14:34 Kunda Assigned To => Kunda
2016-05-19 14:34 Kunda Assigned To Kunda =>
2016-05-19 15:58 Kunda Note Edited: 0041220 View Revisions
2016-05-21 13:01 Kunda Relationship added related to 0012118
2016-05-21 13:33 Kunda Note Added: 0041276
2016-05-21 13:33 Kunda Status resolved => closed