View Issue Details

IDProjectCategoryView StatusLast Update
0009163ScribusPlug-inspublic2014-06-28 16:25
Reporterfm Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.3.7 
Target VersionFixed in Version1.4.5.svn 
Summary0009163: InfoBox Script crashes in case one just presses Escape ;)
DescriptionI opened the InfoBox and pressed several times Escape I got the following:

Traceback (most recent call last):
  File "", line 8, in
  File "/usr/share/scribus/scripts/InfoBox.py", line 156, in
    main(sys.argv)
  File "/usr/share/scribus/scripts/InfoBox.py", line 142, in main
    new_image = scribus.createImage(new_left, float(new_top), new_width, float(new_height),framename)
ValueError: empty string for float()
TagsNo tags attached.
Patch

Activities

FirasH

2014-06-28 13:08

developer   ~0032353

Reproduced with 1.4.5.svn (19285) and 1.5.0.svn (19288).

Steps:
0) Create a new document
1) Insert a Text Frame
2) Select the Text Frame and Script > Scribus Scripts > InfoBox
3) Press 4 times ESC

The Script will report the error (no values inserted?).

FirasH

2014-06-28 16:25

developer   ~0032358

Thanks jghali!
Could not reproduce this issue with 1.4.5.svn (19291) and 1.5.0.svn (19292).
Closing as fixed.

Issue History

Date Modified Username Field Change
2010-06-12 15:44 fm New Issue
2014-06-28 13:08 FirasH Note Added: 0032353
2014-06-28 13:08 FirasH Status new => confirmed
2014-06-28 15:35 jghali Status confirmed => resolved
2014-06-28 15:35 jghali Fixed in Version => 1.4.5.svn
2014-06-28 15:35 jghali Resolution open => fixed
2014-06-28 15:35 jghali Assigned To => jghali
2014-06-28 16:25 FirasH Note Added: 0032358
2014-06-28 16:25 FirasH Status resolved => closed