View Issue Details

IDProjectCategoryView StatusLast Update
0009331ScribusScripterpublic2014-10-22 11:45
Reporterrobertsoakes Assigned To 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionduplicate 
PlatformAllOSAllOS Version
Product Version1.3.8 
Target VersionFixed in Version1.5.0svn 
Summary0009331: Allow command line switch so that a user may specify a start-up script
DescriptionThere may be times when a user wishes to start a custom Scribus environment. The existing startup script preference (which currently does not work), offers some flexibility.

It would also be nice if launching Scribus from the command line also allowed for a user to specify a different startup script (other than that in the preferences). Example:

scribus-ng --script '/path/to/script.py' 'file.sla'

This particular feature would be particularly valuable to developers who are working on Scribus extensions and modifications, since they would be able to test those extensions without needing to change their existing preferences.
Steps To ReproduceNA
TagsNo tags attached.
Patch

Relationships

duplicate of 0012572 closedcbradney [patch] Add a --python-script command line option to run a script and exit 

Activities

Kunda

2014-10-22 11:45

manager   ~0034123

Duplicate of 0012572

Issue History

Date Modified Username Field Change
2010-08-24 20:04 robertsoakes New Issue
2014-07-21 00:08 Kunda Relationship added related to 0000967
2014-07-21 00:08 Kunda Relationship added related to 0000238
2014-07-21 00:09 Kunda Relationship deleted related to 0000967
2014-07-21 00:09 Kunda Relationship deleted related to 0000238
2014-07-30 03:48 Kunda Relationship added related to 0012572
2014-07-30 03:50 Kunda Relationship added related to 0008697
2014-07-30 03:53 Kunda Relationship deleted related to 0008697
2014-10-22 11:45 Kunda Relationship replaced duplicate of 0012572
2014-10-22 11:45 Kunda Note Added: 0034123
2014-10-22 11:45 Kunda Status new => closed
2014-10-22 11:45 Kunda Resolution open => duplicate
2014-10-22 11:45 Kunda Fixed in Version => 1.5.0svn