View Issue Details

IDProjectCategoryView StatusLast Update
0009349ScribusStory Editor / Text Framespublic2010-09-08 19:04
ReporterYannUbuntu Assigned Tocbradney  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformOSUbuntuOS Version
Product Version1.3.8 
Target VersionFixed in Version 
Summary0009349: Can't write Japanese/Chinese/Korean in Scribus
DescriptionOn Ubuntu, Scribus 1.3.8.

It is not possible to activate iBus (nor SCIM) in Scribus text editor, so it is impossible to write directly in Scribus for many people all around the world !

Workaround : type your text in a separate text editor (Gedit for example), then copy/paste it into Scribus text editor.

TagsNo tags attached.
Patch

Relationships

duplicate of 0003928 closedFahad Support line breaking for Thai text 
duplicate of 0008568 closedjghali No Support Chinese 
duplicate of 0008465 closedfschmid failure of Chinese glyph to transfer from character palette to SE or frame 
duplicate of 0007813 closedcbradney Not suppose cope & paste in Chinese characters 
duplicate of 0007152 closedjghali Wrongly change bi-byte Chinese space to Single space 
duplicate of 0007128 closedcbradney Crash during using Traditional Chinese 
duplicate of 0003173 closed Japanese (CJK) text in story editor is not entered into text frame. Frequent crashes. 
duplicate of 0006380 closedjghali Partially disabled Japanese IME causes crash 

Activities

YannUbuntu

2010-09-08 02:53

reporter   ~0024564

Dear cbradney,
thank you for your feedback.
Therefore, I am not familiar with this tracker, I cannot find the link to the Duplicate Bug, could you give me the link please ?

ale

2010-09-08 15:58

manager   ~0024565

hi yann,

for now scribus only really works with languages using latin characters (+ cyrillic).

you can expect support for non latin languages in the near future, though.

and there are already several bug reports on this matter... no need to worry, that it won't be noticed as soon as scribus can support all those languages!

cbradney

2010-09-08 19:04

administrator   ~0024567

I have added a few duplicates, and now I am closing.

Issue History

Date Modified Username Field Change
2010-09-06 07:16 YannUbuntu New Issue
2010-09-07 21:21 cbradney Status new => closed
2010-09-07 21:21 cbradney Assigned To => cbradney
2010-09-07 21:21 cbradney Resolution open => duplicate
2010-09-08 02:53 YannUbuntu Note Added: 0024564
2010-09-08 02:53 YannUbuntu Status closed => feedback
2010-09-08 02:53 YannUbuntu Resolution duplicate => reopened
2010-09-08 15:58 ale Note Added: 0024565
2010-09-08 19:02 cbradney Relationship added duplicate of 0003928
2010-09-08 19:02 cbradney Relationship added duplicate of 0008568
2010-09-08 19:03 cbradney Relationship added duplicate of 0008465
2010-09-08 19:03 cbradney Relationship added duplicate of 0007813
2010-09-08 19:03 cbradney Relationship added duplicate of 0007152
2010-09-08 19:03 cbradney Relationship added duplicate of 0007128
2010-09-08 19:03 cbradney Relationship added duplicate of 0003173
2010-09-08 19:03 cbradney Relationship added duplicate of 0006380
2010-09-08 19:04 cbradney Note Added: 0024567
2010-09-08 19:04 cbradney Status feedback => closed
2010-09-08 19:04 cbradney Resolution reopened => duplicate
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames