View Issue Details

IDProjectCategoryView StatusLast Update
0009400ScribusFontspublic2016-12-08 22:04
Reporterchappaai Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status confirmedResolutionopen 
PlatformPCOSWindowsOS VersionXP
Product Version1.3.8 
Target Version1.5.4Fixed in Version 
Summary0009400: Fonts installed via shortcut not found
DescriptionVersion 1.3.3.14 finds installed Type1 outline fonts in the Windows/Fonts folder and they work perfectly. Versions 1.3.6 and 1.3.8 fail to find the installed fonts if they are not copied to the fonts folder when installed. The newer versions of Scribus fail to evaluate installed font shortcuts as 1.3.3.14 seems to do.
Steps To ReproduceInstall a Type1 font to the Windows/Fonts folder from another location on the hard drive, but do not copy the font to the folder - install it as a link to the font file. Launch Scribus 1.3.6 or 1.3.8, cancel the New Document automatic dialog, select File > Preferences..., go to the Fonts tab, the installed font is not listed under Available Fonts. Also, if a document created in version 1.3.3.14 with the installed Type1 font is opened in 1.3.6 or 1.3.8 then font substitutions occur. Next, delete the font shortcut and install the font again, this time copying the font to the Fonts folder. Re-open Scribus and now the font is available.
Additional InformationThe fonts are not corrupt and work correctly with other applications (MS Office, PageMaker, Freehand, PhotoShop, etc) and even with Scribus 1.3.3.14. They also export to PDF correctly (from 1.3.3.14). The font files should not be required to physically exist in the Fonts folder to be usable.
TagsNo tags attached.
Patch

Relationships

related to 0003861 closedjghali Scribus + Adobe Type Manager 

Activities

jghali

2010-10-09 15:23

administrator   ~0024634

Apparently this is caused by a change of behavior of Qt on Windows which does not list shortcuts in directories unless we tell it to list system files too. No sure that's what we want when searching fonts... Need a bit of thinking to find an appropriate solution.

Kunda

2016-12-08 20:47

manager   ~0042801

@jghali is this still an issue for windows in 1.4 and 1.5 ?

Issue History

Date Modified Username Field Change
2010-10-09 14:20 chappaai New Issue
2010-10-09 15:23 jghali Note Added: 0024634
2010-10-09 15:23 jghali Summary Installed Type1 Fonts Not Found => Fonts installed via shortcut not found
2010-10-09 15:23 jghali Status new => confirmed
2010-10-09 15:24 jghali Target Version => 1.4.0
2011-02-16 12:28 plinnell Target Version 1.4.0 => 1.4.1.svn
2011-04-16 10:04 cbradney Target Version 1.4.1.svn => 1.4.1
2012-04-29 21:14 cbradney Target Version 1.4.1 => 1.4.2
2013-01-13 21:33 cbradney Target Version 1.4.2 => 1.4.3
2013-07-04 20:24 cbradney Target Version 1.4.3 => 1.5.0
2014-07-03 19:41 Kunda Target Version 1.5.0 => 1.5.1
2016-01-23 17:17 cbradney Target Version 1.5.1 => 1.5.3
2016-12-07 11:54 Kunda Relationship added related to 0003861
2016-12-08 20:47 Kunda Note Added: 0042801
2016-12-08 22:04 Kunda Target Version 1.5.3 => 1.5.4