View Issue Details

IDProjectCategoryView StatusLast Update
0009409ScribusImport / Exportpublic2014-07-08 03:31
Reporterwexfordpress Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platform32 bit pc compatible SystemaxOSSlackware LinuxOS Version13.0
Product Version1.5.0svn 
Target VersionFixed in Version1.5.0svn 
Summary0009409: Imprt of pdf and ps blank.
DescriptionI can't import either a pdf or a ps in Scribus 1.5.0 Oct 4 compile.
The frame is empty and the wrong size. My workaround is to import to 1.3.8, and then open that sla in 1.5.0.

John Culleton
Steps To Reproduce1. Fire up 1.5.0
2. select import->vector->pdf
TagsNo tags attached.
Patch

Activities

fschmid

2010-10-17 20:14

administrator   ~0024667

As a workaround you can right click onto the page and then select "Insert File".

cbradney

2010-10-17 20:44

administrator   ~0024668

No issues here. What version of ghostscript do you have installed?

wexfordpress

2010-10-17 20:59

reporter   ~0024669

Scribus splash screen shows Ghostscript 8.70

John Culleton

wexfordpress

2010-10-17 21:14

reporter   ~0024670

Right click and "paste file" has same effect on ps and pdf, but will accept svg.
All samples are of same file as produced by inkscape in all three formats.

John Culleton

fschmid

2010-10-17 22:34

administrator   ~0024672

Then it looks for me like a problem with ghostscript. Can you upload a small sample pdf or ps file?
BTW which version of Inkscape are you using?

wexfordpress

2010-10-20 18:26

reporter   ~0024679

I use 1.3.8 and 1.5.0. My ghostscript is 8.7.0 The bug relates to 1.5.0.

A (large) sample file is here:
http://wexfordpress.com/ink600.ps

wexfordpress

2010-10-25 17:17

reporter   ~0024726

When an svg file from Inkscape is imported the images show but the text has overlaps and other artifacts. When the original pdf file from customer is imported
the graphics disappear and only large type is shown, and it is in outline.

I am now up to the Scribus 1.5.0 dated October 24 2010.

cbradney

2010-10-25 19:21

administrator   ~0024729

John, you mention SVG.. this bug is NOT about SVG. SVG issues could (and probably do) relate solely to the SVG importer code. Its unrelated to PDF and PS code.

Kunda

2014-07-04 04:00

updater   ~0032468

Hey John,
This seems to be fixed. I'm using 1.5svn r19309 on OSX 10.8.5
Screenshot: https://www.dropbox.com/s/jpl66mghyvlip7j/Screenshot%202014-07-03%2022.56.31.png
Does this issue still persist for you or can it be closed?

Kunda

2014-07-08 03:31

updater   ~0032568

wexfordpress reports that this is fixed now in current 1.5.0svn

Issue History

Date Modified Username Field Change
2010-10-17 18:48 wexfordpress New Issue
2010-10-17 20:14 fschmid Assigned To => fschmid
2010-10-17 20:14 fschmid Status new => confirmed
2010-10-17 20:14 fschmid Note Added: 0024667
2010-10-17 20:15 fschmid Assigned To fschmid =>
2010-10-17 20:44 cbradney Note Added: 0024668
2010-10-17 20:59 wexfordpress Note Added: 0024669
2010-10-17 21:14 wexfordpress Note Added: 0024670
2010-10-17 22:34 fschmid Note Added: 0024672
2010-10-20 18:26 wexfordpress Note Added: 0024679
2010-10-25 17:17 wexfordpress Note Added: 0024726
2010-10-25 19:21 cbradney Note Added: 0024729
2014-07-04 04:00 Kunda Note Added: 0032468
2014-07-04 04:00 Kunda Status confirmed => feedback
2014-07-08 03:31 Kunda Note Added: 0032568
2014-07-08 03:31 Kunda Status feedback => closed
2014-07-08 03:31 Kunda Resolution open => fixed
2014-07-08 03:31 Kunda Fixed in Version => 1.5.0svn