View Issue Details

IDProjectCategoryView StatusLast Update
0009610ScribusStylespublic2012-06-24 13:17
Reporteryoonminsoo Assigned Tocbradney  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSwindowsOS VersionXP SP3
Product Version1.3.9 
Target VersionFixed in Version1.4.2.svn 
Summary0009610: Chars style does not work in Paragraph style
DescriptionOnly Paragraph style does works.
only Character stle does works.
But Chars style does not work on sentence on which paragraph style is applied.
TagsNo tags attached.
Patch

Activities

jghali

2010-12-23 01:56

administrator   ~0025181

Unable to reproduce. Can you provide more details?

yoonminsoo

2010-12-23 10:48

reporter  

Bug Report.pdf (1,464,989 bytes)

yoonminsoo

2010-12-23 11:03

reporter   ~0025185

Now, I uploaded pdf file(capture and comment).

I am a Korean and contents consist of Korean and English....

Now, I create a new scribus doc. it works well.
But the doc which was made does not work with style.

yoonminsoo

2010-12-23 11:07

reporter  

church.sla (406,281 bytes)

yoonminsoo

2010-12-23 11:09

reporter   ~0025186

I uploaded source document file. but missing fonts, and missing image....

But make new para. and char. styles and test on my sla doc.

yoonminsoo

2010-12-23 23:10

reporter   ~0025189

Ureka!
When paragraph name is Korean, it dows not work.
When paragraph name is English(it has no spaces(?)), it works.
So I hope that you support non-Latin languages(On my cases, Korean).

cbradney

2010-12-24 15:01

administrator   ~0025194

No, Korean is not supported, although we have a project working on non-latin at the moment. If this is the cause of this bug, then this bug needs closing as we have other bugs for this issue.

yoonminsoo

2011-01-05 06:46

reporter   ~0025276

No, In English-named paragraph, charater style does not work too.
Only in default paragraph style, character style works.
On 1.4.0 svn, the same phenomenon is encountered.

jghali

2011-01-05 10:31

administrator   ~0025280

Cannot reproduce here, works also with custom paragraph styles

yoonminsoo

2011-01-07 07:34

reporter   ~0025304

I open doc.sla with XML editor.
I Found that style name is the same as PARENT name.
So I deleted PARENT="(...)" item.
Now it works well.

louisdesjardins

2011-11-26 16:51

developer   ~0027281

I can confirm that when a paragraph style is applied, there is no way to apply a char style to any portion of that paragraph. While Scribus recognizes that the style exists and it correctly tags the formatted text as being set with that particular char style, the formatting is that of the paragraph style.

When there is no paragraph style applied, then the char style can be applied and displays properly.

I tested using various language settings and it makes no difference.

I thought it was related to the presence of a tab settings in the style sheet so I removed it without better results.

Tested on OS X 10.6 (Snow Leopard) with 1.4RC6

louisdesjardins

2011-11-26 21:26

developer   ~0027284

Tested again with the new .dmg provided by Craig on Nov. 23, 2011 and both style types appear to work.

However when insterting a tabulator, the one on the first line is misaligned while all others align according to the value it was set.

cbradney

2012-06-24 13:17

administrator   ~0028286

Fixed in previous version.

Issue History

Date Modified Username Field Change
2010-12-23 01:45 yoonminsoo New Issue
2010-12-23 01:56 jghali Note Added: 0025181
2010-12-23 10:48 yoonminsoo File Added: Bug Report.pdf
2010-12-23 11:03 yoonminsoo Note Added: 0025185
2010-12-23 11:07 yoonminsoo File Added: church.sla
2010-12-23 11:09 yoonminsoo Note Added: 0025186
2010-12-23 23:10 yoonminsoo Note Added: 0025189
2010-12-24 15:01 cbradney Note Added: 0025194
2011-01-05 06:46 yoonminsoo Note Added: 0025276
2011-01-05 10:31 jghali Note Added: 0025280
2011-01-07 07:34 yoonminsoo Note Added: 0025304
2011-11-26 16:51 louisdesjardins Note Added: 0027281
2011-11-26 21:26 louisdesjardins Note Added: 0027284
2012-06-24 13:17 cbradney Note Added: 0028286
2012-06-24 13:17 cbradney Status new => closed
2012-06-24 13:17 cbradney Assigned To => cbradney
2012-06-24 13:17 cbradney Resolution open => fixed
2012-06-24 13:17 cbradney Fixed in Version => 1.4.2.svn