View Issue Details

IDProjectCategoryView StatusLast Update
0009646Infrastructure[All Projects] Generalpublic2014-10-24 23:02
Reporterale Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Summary0009646: [MANTIS] adding a status to mantis for request with a patch attached
Descriptionit would be nice to have a status to show that some user has attached a patch to a report.

it might be placed before "assigned" and be called "has patch" or "patched"...

here the manual page, which explains how to add a custom status:

http://manual.mantisbt.org/manual.customizing.mantis.customizing.status.values.php

that way, it might get easier for the team to track the patches which has been submitted, but not yet applied to svn.
TagsNo tags attached.

Relationships

has duplicate 0010822 closed in mantis create a new "status" called "patch" 
related to 0012544 assignedKunda [REQUEST] Augmentations to MantisBT 

Activities

plinnell

2011-01-06 20:34

viewer   ~0025298

Why not add a tag and we do not need to mess with Mantis ?

ale

2011-01-06 21:27

manager   ~0025300

the problem arose with 0009641. i could only set it to confirmed, even if the bug is probably solved.

personally, i would prefer to add [PATCH] in the title of the bug to using a tag... but i have the feeling that adding a status would be the best solution.

malex

2011-10-24 21:06

administrator   ~0027107

No really, this is what tags are for. Use the right tool for the job.

Kunda

2014-07-10 13:48

manager   ~0032666

Last edited: 2014-07-10 13:51

View 3 revisions

I think the issue is that there is a limitation when viewing the bugtracker list one can't tell which issue has patched uploaded with it visually. Unless AFAICT:
1. someone happens to clicks on an issue that has an attached patch
2. someone clicks on the #patch tag to list all patches
3. an informed someone prepends [PATCH] to the title of the report

Also, patches have tended in the past to 'fall off the radar'. This would be a good way to track them also.

Kunda

2014-07-20 23:49

manager   ~0032848

Follow-up comments to 0009646:0032666:
I think adding a status is a good idea. But due to lack of movement around this subject, I've take the liberty to just add [PATCH] in the 'summary' line of the bug. I think we should consider this a way to do this from here on out until a better solution presents.

Kunda

2014-07-28 22:03

manager   ~0033066

I think adding a status would be a good idea actually. The tag option is kind of useless.
Here is a recent conversation with a Mantis Plugin dev that made the mediawiki plugin.
https://github.com/tessus/mwExtensionMantis/issues/2

Kunda

2014-10-24 00:13

manager   ~0034133

This should be super easy to do. Lets do it. It doesn't make anything more complex for Mantis, as far as I've read.

Kunda

2014-10-24 22:50

manager   ~0034142

Discussed this on IRC Oct 24, 2014. Core devs are not keen on the idea. Instead they're opting to use custom fields. I've asked the mediawiki Mantis extension dev to add a feature to search via custom fields: https://github.com/tessus/mwExtensionMantis/issues/8

Kunda

2014-10-24 23:02

manager   ~0034143

a 'Patch' status was not accepted as a solution. Instead we now have a patch field when someone opens a ticket. All open patches can be sorted this way.

Issue History

Date Modified Username Field Change
2011-01-06 06:42 ale New Issue
2011-01-06 20:34 plinnell Note Added: 0025298
2011-01-06 21:27 ale Note Added: 0025300
2011-10-24 19:50 malex Project Scribus => Infrastructure
2011-10-24 19:50 malex Category Website => General
2011-10-24 21:06 malex Note Added: 0027107
2011-10-24 21:06 malex Status new => resolved
2011-10-24 21:06 malex Resolution open => fixed
2011-10-24 21:06 malex Assigned To => malex
2014-07-10 13:48 Kunda Note Added: 0032666
2014-07-10 13:48 Kunda Status resolved => feedback
2014-07-10 13:48 Kunda Resolution fixed => reopened
2014-07-10 13:49 Kunda Relationship added has duplicate 0010822
2014-07-10 13:51 Kunda Note Edited: 0032666 View Revisions
2014-07-10 13:51 Kunda Note Edited: 0032666 View Revisions
2014-07-20 23:49 Kunda Note Added: 0032848
2014-07-21 00:10 Kunda Summary adding a status to mantis for reques with a patch attached => [MANTIS] adding a status to mantis for request with a patch attached
2014-07-28 22:03 Kunda Note Added: 0033066
2014-10-24 00:13 Kunda Note Added: 0034133
2014-10-24 08:14 Kunda Relationship added related to 0012544
2014-10-24 22:50 Kunda Note Added: 0034142
2014-10-24 23:02 Kunda Note Added: 0034143
2014-10-24 23:02 Kunda Status feedback => closed
2014-10-24 23:02 Kunda Assigned To malex => cbradney
2014-10-24 23:02 Kunda Resolution reopened => fixed