Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000132ScribusGeneralpublic2004-01-09 07:422014-06-27 19:51
Reportercbradney 
Assigned Tojghali 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.3 
Target VersionFixed in Version1.5.0svn 
Summary0000132: Widow/orphan control
DescriptionMailing List request
TagsNo tags attached.
Patch
Attached Files

- Relationships
has duplicate 0002170closed inner spacings per column 
has duplicate 0009015closedjghali Orhpans and Widows + Keep with Next/Previous 
related to 0001155acknowledged Support non-breakable text blocks 
related to 0002558closedcbradney vertical justification in text frames 
related to 0002479assignedcezaryece Preflight check: orphans and widows 

-  Notes
(0002316)
ringerc (administrator)
2004-09-05 22:10

related: bug 128
(0009929)
mhanski (developer)
2006-04-14 00:04

Planned in Roadmap Extras http://wiki.scribus.net/index.php/1.3.x_Roadmap_Extras [^]
with no ETA

Changing the status to acknowledged
(0024793)
cezaryece (developer)
2010-11-02 12:40

I dont know if Indesign or Quark have any automatic feature for avoiding widows and orphans - Corel Ventura hasnt.
IMHO it is very intelligent and logic task and will be very hard to do it in way that satisfy all (if you have power for it - try to do it).

Instead I vote for including check for widows and orphans in output validator like now it check if all text is in text frame. I think this could be easier to implementing.
(0024796)
ale (manager)
2010-11-03 10:17

nice idea, yes!

now, we should try to define what a widow and or orphan is... and if there is a need for fine tuning its settings...
(0024797)
rdebel (reporter)
2010-11-03 10:38

Hi. I'm just working with layouting a book. Just with to avoid widows and orphans it would be very helpfull do have a function doing the following:
1) I mark a paragraph (or maybe it just uses the paragraph the cursor is in)
2) I choose to a) expand or to b) collapse the paragraph
3) The function would change the appropriate values so much until
   a) the paragraph get just one line longer or
   b) just one line shorter.
(0024813)
cezaryece (developer)
2010-11-05 08:53

Definitions are simple and should be well known.

Widow and orphans deal with paragraphs with more than single line.
Orphan is first line of paragraph at the bottom of text column - rest of paragraph is in next column.
Widow is last line of paragraph at the top of text column.
(0024924)
subeditor (reporter)
2010-11-29 19:50

Quark has such feature, but it is also incomplete indeed - it just left empty line when orphan or widow occurs, one have to manually shrink or expand text.
Validator is weak solution, but better than nothing.
(0024927)
cezaryece (developer)
2010-11-30 07:52

I think good automatically text formatting for orphan/widow solution is very complex task and need better if user do it by himself. I don't know any layout application which do it automatically. Ventura seems to working in Quark way - only insert empty lines and even not notice user about it (you must carefully check your publication).
Warning in Validator is perfect solution for me and I am going to code it.
(0024944)
subeditor (reporter)
2010-11-30 22:41

Not so complex for user view, since very few parameters can be used for expand/shrink text. At glance I guess only two: words and characters tracking, which is already flexible. For short paragraph with long lines it won't be enough, and then one have to tune previous paragraph (or call an editor/author and ask him to cut or add some text :)
(0024947)
cezaryece (developer)
2010-12-01 08:57

IMHO making Scribus serving coffee is not so complex for user view either, but...
I am working on document verifier for widows/orphan control and as I see it (only checking) takes noticeable additional time, so making Scribus try to solve these layout errors by itself can make him less responsible (which is not good even without widows/orphan control).
(0024949)
louisdesjardins (developer)
2010-12-01 12:03

Here is a definition:
http://en.wikipedia.org/wiki/Widows_and_orphans [^]
(0024953)
ale (manager)
2010-12-01 17:58

i dared to ask, what widows and orphans are, and it wasn't meant as a stupid or provocative question but as an invitation to define it for scribus.
(yes the question was very short and could be misunderstood.)

first, is there anything specific to the context of a frame based application (it may be different than a page based context)?

also, we may have a list of parameters to be tweaked while trying to avoid widows and orphans (see the wikipedia entry linked by louis): which one should have settings which could be set by the user (if any) and which ones should be used by scribus?

should the setting be adjusted on a style base or document base?

should scribus automatically fix widows and orphans or just warn in the preflight verifier if it finds some?

the answers to some of those questions may seem trivial to some of yours... i wonder if everybody has the same view on it...
(0024955)
subeditor (reporter)
2010-12-01 20:54

ale: is there anything specific to the context of a frame based application (it may be different than a page based context)?

No, it does not matter what object serves as container for text. All kinds of containers should not have single lines until allowed by user.

ale: we may have a list of parameters to be tweaked while trying to avoid widows and orphans. which one should have settings which could be set by the user (if any) and which ones should be used by scribus?

In my opinion while talking about automation we should talk only about parameters that wouldn't "brake" layout. So only words and characters tracking is acceptable, and may be (sometimes) spacing between lines/paragraphs. Any other tricks require user interference.

ale: should the setting be adjusted on a style base or document base?
Style (default style is equivalent document base imho) and paragraph properties.

ale: should scribus automatically fix widows and orphans or just warn in the preflight verifier if it finds some?

Scribus should have checkbox "fix automatically".

ale, did you receive my mail?
(0024959)
rdebel (reporter)
2010-12-02 08:57

It seems to go a little bit "automatically" contra "detect only".
But perhaps there could be something between which would be really helpfull.
While I agree that a fully automatic control is hard to do and maybe even has unwanted results, perhaps a "semi-automatic" tool would be helpfull.
Imagine a tool where to choose whether to expand or the shrink the paragraph the curser is currently placed in (or when defined even the lines/paragraph distances in the current frame)
You have to define (maybe as part of the paragraph style) how "full" the new line should be (if expanding maybe 10%, when shrinking maybe 95%) and then change the define named parameters until you hit the target.
I personally would prefer such a solution more than an "automatic" controll. In a book it would help me much.
The preflight verifier is of course nice. But I personally find it not so difficult to detect widows/orphan when proofreading or during typesetting.
(0031642)
JLuc (updater)
2014-04-07 17:24

Now to be closed ?
(Hurrah !)
(0032290)
jghali (administrator)
2014-06-25 00:00

Resolving/closing as this has been implemented by mecirt in 1.5.0svn

- Issue History
Date Modified Username Field Change
2004-01-09 07:42 cbradney New Issue
2004-01-09 07:43 cbradney Category Documentation => General
2004-09-05 22:10 ringerc Note Added: 0002316
2004-09-24 01:00 cbradney Product Version => 1.3
2004-09-30 16:54 deejay1 Relationship added related to 0001155
2005-09-14 18:05 ringerc Relationship added related to 0002228
2005-09-14 18:05 ringerc Relationship added related to 0002558
2005-10-11 00:57 avox Relationship added related to 0002479
2006-04-12 13:04 mhanski Relationship added child of 0000128
2006-04-14 00:04 mhanski Note Added: 0009929
2006-04-14 00:04 mhanski Status new => acknowledged
2006-04-30 00:48 mhanski Relationship added has duplicate 0002170
2008-01-30 13:14 christoph_s Relationship deleted child of 0000128
2010-04-14 14:02 jghali Relationship added has duplicate 0009015
2010-11-02 12:40 cezaryece Note Added: 0024793
2010-11-03 10:17 ale Note Added: 0024796
2010-11-03 10:38 rdebel Note Added: 0024797
2010-11-05 08:53 cezaryece Note Added: 0024813
2010-11-29 19:50 subeditor Note Added: 0024924
2010-11-30 07:52 cezaryece Note Added: 0024927
2010-11-30 22:41 subeditor Note Added: 0024944
2010-12-01 08:57 cezaryece Note Added: 0024947
2010-12-01 12:03 louisdesjardins Note Added: 0024949
2010-12-01 17:58 ale Note Added: 0024953
2010-12-01 20:54 subeditor Note Added: 0024955
2010-12-02 08:57 rdebel Note Added: 0024959
2014-04-07 17:24 JLuc Note Added: 0031642
2014-04-08 10:42 JLuc Tag Attached: #tobeclosed
2014-06-25 00:00 jghali Note Added: 0032290
2014-06-25 00:00 jghali Status acknowledged => resolved
2014-06-25 00:00 jghali Fixed in Version => 1.5.0svn
2014-06-25 00:00 jghali Resolution open => fixed
2014-06-25 00:00 jghali Assigned To => jghali
2014-06-25 00:00 jghali Status resolved => closed
2014-06-27 19:51 JLuc Tag Detached: #tobeclosed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker