Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011632ScribusInternalpublic2013-06-25 22:022014-07-04 15:23
ReporterHellstorm 
Assigned Tocbradney 
PrioritynormalSeverityfeatureReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version1.4.2 
Target Version1.5.0Fixed in Version1.5.0svn 
Summary0011632: Function to generate Chinese page numbers
DescriptionHello,

Sometimes, Chinese books show the page numbering in Chinese letters, not in arabic ones. Currently, Scribus does only support the automatic page numbering in arabic letters.

Well, I tried to do this in C++, but somehow... C++ is to difficult for me as a beginner :D Because I have no way to actually try the function in Scribus itself (compiling Scribus does not really work on my PC), I could only create the function on my pc, but without actually trying it. Also, the function would be so badly programmed that I thought you'd need more time to correct it rather than build it from scratch.

But because I didn't want to do nothing, I created it in Python. I know that Scribus is not written in Python, but...

Well, anyway, I hope you may implement it in C++. Actually the method is quite easy: Replace every roman digit by the appropriate Chinese one. For example, 123 will become ??? (\u4E00\u4E8C\u4E09).

After implementing this, it would then be good if there was a new item in Insert\Character with the name "Chinese page number", which is basically just the ordinary page number converted with this function to a Chinese number.

I hope this can be implemented :)
Thank you :)
TagsNo tags attached.
Patch
Attached Files? file icon cjknumber.py [^] (469 bytes) 2013-06-25 22:02

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2013-06-25 22:02 Hellstorm New Issue
2013-06-25 22:02 Hellstorm File Added: cjknumber.py
2013-06-26 07:49 christoph_s Assigned To => cbradney
2013-06-26 07:49 christoph_s Status new => assigned
2013-06-26 07:49 christoph_s Target Version => 1.5.1
2013-06-26 21:27 cbradney Assigned To cbradney =>
2013-06-26 21:39 jghali Status assigned => new
2014-06-22 22:21 cbradney Assigned To => cbradney
2014-06-22 22:21 cbradney Status new => assigned
2014-06-23 09:52 cbradney Status assigned => resolved
2014-06-23 09:52 cbradney Fixed in Version => 1.5.0svn
2014-06-23 09:52 cbradney Resolution open => fixed
2014-06-25 22:04 cbradney Status resolved => closed
2014-07-04 15:23 Kunda Target Version 1.5.1 => 1.5.0



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker