Mantis Issue Tracking for Scribus
· Hosting provided by / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0011661Scribus-public2013-07-13 02:282015-11-13 02:38
Assigned Tocezaryece 
PlatformLinuxOSKubuntuOS Version13.04
Product Version1.5.0svn 
Target Version1.5.1Fixed in Version 
Summary0011661: Numbering of all footnotes is zero
DescriptionI created a simple layout to see how the footnotes feature works, importing a LibreOffice document with footnotes. The footnotes were displayed properly at the bottom of the text frames, with their correct footnote numbers. I saved the file, then a few days later I checked out the latest version and built the updated version (Build-ID C-C-T-F-C1.12.14-64bit), then ran it and opened the same file that I had saved a few days earlier. The footnote references are correctly numbered in the text, but the footnotes all have zero (0) as their number. I'm attaching a zip file containing the actual source files, including a pdf showing how it looks on my screen.
TagsNo tags attached.
Attached Fileszip file icon [^] (400,962 bytes) 2013-07-13 02:28
? file icon DZ_LawAgainstLove.odt [^] (42,481 bytes) 2013-07-15 11:09
? file icon footnotes_fix odt import note numbers.sla [^] (42,057 bytes) 2013-10-23 19:53

- Relationships
related to 0013280closed [OSX] Importing an .sla crashes with Sig11 
child of 0012496acknowledged Metabug: Marks & Footnotes & Weld (1.5.0.svn) 

-  Notes
JLuc (developer)
2013-07-15 08:40

would you upload ODT imported document ?
cezaryece (developer)
2013-10-23 14:37

Fixed in footntoes_fix branch in scribus.git
jghali (administrator)
2013-10-23 15:27

This issue has not been reported against a contributor build. So please do not mark a bug as resolved unless it is fixed in *SVN*.
JLuc (developer)
2013-10-23 19:49

I tested importing the ODT document and found i could not reproduce the issue, neither with last QT4 1.5 svn (end of august version), nor with the footnotes_fix GIT version : the notes are imported and are correctly numbered from 1 to 7, and i can save and reopen the doc with notes being ok.

However i found a crash issue on the new GIT branch : after importing the uploaded ODT (and auto-creating the notes) into a set of 4 linked text frames, scribus crashes when :
- Double click first frame,
- Edit > Select all (or CTRL+A)
- Delete

bt is as follow :

ASSERT failure in QList<T>::at: "index out of range", file /usr/include/qt5/QtCore/qlist.h, line 454

Program received signal SIGABRT, Aborted.
0xb7fdd424 in __kernel_vsyscall ()
(gdb) bt
#0 0xb7fdd424 in __kernel_vsyscall ()
0000001 0xb6943b1f in raise () from /lib/i386-linux-gnu/
0000002 0xb69470b3 in abort () from /lib/i386-linux-gnu/
0000003 0xb7add553 in QMessageLogger::fatal(char const*, ...) const ()
   from /usr/lib/i386-linux-gnu/
0000004 0xb7ada143 in qt_assert_x(char const*, char const*, char const*, int) ()
   from /usr/lib/i386-linux-gnu/
0000005 0x08d0ac26 in QList<ScText*>::at (this=0xa087168, i=11861)
    at /usr/include/qt5/QtCore/qlist.h:454
0000006 0x08d02a7b in StoryText::hasMarkType (this=0xa084fb0, pos=11861,
    at /home/jluc1304/dev/git/Scribus/scribus/text/storytext.cpp:833
0000007 0x085793ba in PageItem_TextFrame::removeMarksFromText (this=0xa084cf8,
    at /home/jluc1304/dev/git/Scribus/scribus/pageitem_textframe.cpp:6042
0000008 0x0857025f in PageItem_TextFrame::deleteSelectedTextFromFrame (
    at /home/jluc1304/dev/git/Scribus/scribus/pageitem_textframe.cpp:4820
0000009 0x0856d874 in PageItem_TextFrame::handleModeEditKey (this=0xa084cf8,
    k=0xbfffee44, keyRepeat=@0x92e55eb: true)
    at /home/jluc1304/dev/git/Scribus/scribus/pageitem_textframe.cpp:4526
0000010 0x08788c8e in ScribusMainWindow::keyPressEvent (this=0x92e5428,
    k=0xbfffee44) at /home/jluc1304/dev/git/Scribus/scribus/scribus.cpp:1719
---Type <return> to continue, or q <return> to quit---
0000011 0x088a6494 in ScribusView::eventFilter (this=0x9ef2b38, obj=0x9ef2b38,
    at /home/jluc1304/dev/git/Scribus/scribus/scribusview.cpp:4402
0000012 0xb7c8a0cc in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/
0000013 0xb753e90d in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /usr/lib/i386-linux-gnu/
0000014 0xb754182e in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/i386-linux-gnu/
0000015 0xb7c89ebe in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /usr/lib/i386-linux-gnu/
0000016 0xb759f98c in ?? () from /usr/lib/i386-linux-gnu/
0000017 0xb75a2634 in ?? () from /usr/lib/i386-linux-gnu/
0000018 0xb753e93c in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /usr/lib/i386-linux-gnu/
0000019 0xb7540bce in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/i386-linux-gnu/
0000020 0xb7c89ebe in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /usr/lib/i386-linux-gnu/
0000021 0xb712789d in QGuiApplicationPrivate::processKeyEvent(QWindowSystemInterfacePrivate::KeyEvent*) () from /usr/lib/i386-linux-gnu/
0000022 0xb712af10 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/i386-linux-gnu/
0000023 0xb7117a66 in QWindowSystemInterface::sendWindowSystemEventsImplementation(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib/i386-linux-gnu/
0000024 0xb7117acf in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/
0000025 0xb17383a1 in ?? ()
   from /usr/lib/i386-linux-gnu/qt5/plugins/platforms/
0000026 0xb62b63b3 in g_main_context_dispatch ()
   from /lib/i386-linux-gnu/
0000027 0xb62b6750 in ?? () from /lib/i386-linux-gnu/
0000028 0xb62b6831 in g_main_context_iteration ()
   from /lib/i386-linux-gnu/
0000029 0xb7cd836f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/
0000030 0xb17385f6 in ?? ()
   from /usr/lib/i386-linux-gnu/qt5/plugins/platforms/
0000031 0xb7c88746 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/
0000032 0xb7c88bac in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib/i386-linux-gnu/
0000033 0xb7c8edf2 in QCoreApplication::exec() ()
   from /usr/lib/i386-linux-gnu/
---Type <return> to continue, or q <return> to quit---
0000034 0xb7122634 in QGuiApplication::exec() ()
   from /usr/lib/i386-linux-gnu/
0000035 0xb753d664 in QApplication::exec() ()
   from /usr/lib/i386-linux-gnu/
0000036 0x08cd93ea in mainApp (argc=1, argv=0xbffff2c4)
    at /home/jluc1304/dev/git/Scribus/scribus/main_nix.cpp:86
0000037 0x08cd9373 in main (argc=1, argv=0xbffff2c4)
    at /home/jluc1304/dev/git/Scribus/scribus/main_nix.cpp:54
JLuc (developer)
2013-10-23 19:55
edited on: 2013-10-23 19:55

I've uploaded the SLA resulting (with the footnotes_fix GIT branch) of the import of the spanking ODT.
To reproduce the crash, select all main text (from first frame) and delete.

cezaryece (developer)
2013-10-24 08:21

Thank JLuc very much.
But... please, do not report new issues in bug reports of other (quite different) issues.
If topic is solved then let close report. Feedback just "solved".
If you found new issue then create new report.
zerubbabel (reporter)
2014-08-25 02:09

I do not understand why the target version for fixing this bug has been changed from 1.5.0 to 1.5.1, since the automatic footnotes feature is useless with this bug.
Kunda (manager)
2014-08-25 06:20

zerubbabel, many issues that were labeled for 1.5.0 were automatically bumped to 1.5.1 per a decision by the devs. 1.5.0 only contains crash/major bugs. Unfortunately, cezaryece has his attention on work and personal things these days and so we don't have an ETA when any of the footnote issues will get fixed.
zerubbabel (reporter)
2015-08-07 20:50

Actually, this bug is fixed in version 1.5.0
Kunda (manager)
2015-08-07 21:55

zerubbabel, great news. Thanks for following up!
We should prolly to test this on Windows and OSX as well before closing.
Kunda (manager)
2015-10-29 05:54

testing needed
cezaryece (developer)
2015-10-29 07:23

Yes, I am out, but I am still looking bihind street corner what happens in Scribus.

About numbers of footnotes:
I decide not to update footnote`s numbers live during editing. Footnotes are used mainly in books, where document have long story in many linked frames and Scribus is not doing well in that case. So user have to update numbers by manually invoke of menu command Update Document. In this routine footnotes numbers (and other things like markers) are updated to proper state.
Update Document is also automaticaly invoked on Open, Print and Export.
If not - this is a bug. After opening document with footnotes all of them should have proper numbers.

I got this behaviour from Ventura Publisher where even much faster application have similiar feature for updating enumartions in document.
Update Document will update TOC, all markers and indexes (where they will implemented).
cezaryece (developer)
2015-10-29 07:25

And I am not sure if my last patch for footnotes (should be in branch on git) were aplied? If not it will be fine if someone take it and test it.
Kunda (manager)
2015-10-29 20:08

cez! Thanks for the feedback!
Kunda (manager)
2015-10-29 20:27

Ok, thx to jluc we have the patches all in one place, github. [^]

here are the listed commits: [^]

- Issue History
Date Modified Username Field Change
2013-07-13 02:28 zerubbabel New Issue
2013-07-13 02:28 zerubbabel File Added:
2013-07-13 14:19 jghali Target Version => 1.5.0
2013-07-15 08:40 JLuc Note Added: 0030445
2013-07-15 11:09 zerubbabel File Added: DZ_LawAgainstLove.odt
2013-10-15 23:04 cbradney Assigned To => cezaryece
2013-10-15 23:04 cbradney Status new => assigned
2013-10-23 14:37 cezaryece Note Added: 0030760
2013-10-23 14:37 cezaryece Status assigned => resolved
2013-10-23 14:37 cezaryece Resolution open => fixed
2013-10-23 15:27 jghali Note Added: 0030763
2013-10-23 15:27 jghali Status resolved => new
2013-10-23 19:49 JLuc Note Added: 0030765
2013-10-23 19:53 JLuc File Added: footnotes_fix odt import note numbers.sla
2013-10-23 19:55 JLuc Note Added: 0030766
2013-10-23 19:55 JLuc Note Edited: 0030766 View Revisions
2013-10-24 08:21 cezaryece Note Added: 0030771
2013-10-24 08:23 cezaryece Note Added: 0030772
2013-10-24 08:23 cezaryece Status new => resolved
2013-10-24 08:40 cezaryece Note Deleted: 0030772
2013-10-24 14:07 cezaryece Status resolved => feedback
2013-10-24 14:07 cezaryece Resolution fixed => reopened
2013-11-14 15:30 cezaryece Status feedback => assigned
2013-11-14 15:31 cezaryece Status assigned => acknowledged
2014-07-03 21:41 Kunda Target Version 1.5.0 => 1.5.1
2014-08-25 02:09 zerubbabel Note Added: 0033340
2014-08-25 06:20 Kunda Note Added: 0033341
2015-08-07 20:50 zerubbabel Note Added: 0035975
2015-08-07 21:55 Kunda Note Added: 0035976
2015-08-08 14:21 Kunda Issue cloned: 0013280
2015-08-08 14:21 Kunda Relationship added related to 0013280
2015-10-29 05:54 Kunda Note Added: 0037078
2015-10-29 07:23 cezaryece Note Added: 0037082
2015-10-29 07:25 cezaryece Note Added: 0037083
2015-10-29 20:08 Kunda Note Added: 0037111
2015-10-29 20:27 Kunda Note Added: 0037112
2015-11-13 02:38 Kunda Relationship added child of 0012496

Copyright © 2000 - 2015 MantisBT Team
Powered by Mantis Bugtracker