Mantis Issue Tracking for Scribus
· Hosting provided by Anduin.net / Øverby Consulting ·

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0012621ScribusShape Drawingpublic14-Aug-19 16:2414-Aug-31 20:24
ReporterFirasH 
Assigned Tofschmid 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSopenSUSEOS Version13.1
Product Version1.5.0svn 
Target Version1.4.5Fixed in Version1.4.5.svn 
Summary0012621: It is possible to create Bezier Curves with only 1 node
DescriptionIt is possible to create Bezier Curves with only 1 node.
Steps To Reproduce0) Create a new document
1) Insert a Bezier Curve with 3+ nodes
2) Double-click on the Bezier Curve so that "Nodes" window appears
3) Delete the nodes in sequence from the first to the last one

Doing so you will get a Bezier Curve with a single node.
Additional Information1.5.0.svn (19430)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0033287)
jghali (administrator)
14-Aug-19 16:50

I cannot reproduce this issue in current build. There is some specific step which must be missing.
(0033288)
FirasH (developer)
14-Aug-19 16:55

jghali, here are the corrected steps:

0) Create a new document
1) Insert a Bezier Curve with 3+ nodes
2) Double-click on the Bezier Curve so that "Nodes" window appears
3) Delete the nodes in sequence from the last to the first one
(0033312)
Kunda (developer)
14-Aug-21 14:09

Confirmed on 1.5svn r19430
In step 3 one need to delete the nodes from LAST to FIRST. Just needed to emphasize that.
Trying to reproduce this kept on triggering a crash when following the instructions in step 3) to delete the nodes from FIRST to LAST. Not sure which issue reports this.
(0033313)
Kunda (developer)
14-Aug-21 14:33

Bezier crash bugs for reference:
0012606
0012140
0012249
0012608
(0033338)
jghali (administrator)
14-Aug-24 15:35

Setting target to 1.4.5 for that one. In 1.4.5svn this issue triggers a hang.
(0033357)
jghali (administrator)
14-Aug-28 20:04

Fix also backported to 1.4.5svn
(0033410)
FirasH (developer)
14-Aug-31 20:24

Thanks jghali!
Fixed in 1.4.5.svn (19469) and 1.5.0.svn (19468).

- Issue History
Date Modified Username Field Change
14-Aug-19 16:24 FirasH New Issue
14-Aug-19 16:50 jghali Note Added: 0033287
14-Aug-19 16:55 FirasH Note Added: 0033288
14-Aug-21 14:09 Kunda Note Added: 0033312
14-Aug-21 14:10 Kunda Status new => confirmed
14-Aug-21 14:10 Kunda Target Version => 1.5.1
14-Aug-21 14:33 Kunda Note Added: 0033313
14-Aug-24 15:35 jghali Note Added: 0033338
14-Aug-24 15:35 jghali Target Version 1.5.1 => 1.4.5
14-Aug-28 12:44 fschmid Status confirmed => resolved
14-Aug-28 12:44 fschmid Fixed in Version => 1.5.0svn
14-Aug-28 12:44 fschmid Resolution open => fixed
14-Aug-28 12:44 fschmid Assigned To => fschmid
14-Aug-28 20:04 jghali Note Added: 0033357
14-Aug-28 20:04 jghali Fixed in Version 1.5.0svn => 1.4.5.svn
14-Aug-31 20:24 FirasH Note Added: 0033410
14-Aug-31 20:24 FirasH Status resolved => closed



Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker