View Issue Details

IDProjectCategoryView StatusLast Update
0011800ScribusCanvaspublic2018-04-30 13:17
ReporterFirasH Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionreopened 
Product Version1.5.0svn 
Target Version1.5.5Fixed in Version 
Summary0011800: Sending items to "Inline Items" causes bad canvas render
DescriptionSending items to "Inline Items" let the item selected go over the others until you click on the grey background of Scribus or another element on the page.
Steps To ReproduceI upload a file that helps understanding the problem faster.
In the file there are 3 elements: a big red shape (opacity 70%) as background, a thin black shape and over it a text frame.

1) Select the red background
2) Go to Item- Send to- Inline Items

Now the background goes over the other 2 items which were previously on a higher level

3a) Click on the grey background of Scribus and the problem seems resolved

or

3b) Select either the text frame or the black shape, which you see because of the transparency of the red shape, and move it around with arrow keys.

You'll notice that it renders just a small area around it.
Additional InformationWorking with the latest revision of Scribus (now 18571)
Tagsartifacts, display, inline
PatchNo

Relationships

child of 0013075 acknowledged Metabug: missing display refresh 

Activities

FirasH

2013-10-22 21:46

developer  

Testing.sla (15,687 bytes)

fschmid

2013-10-23 19:25

administrator   ~0030767

Can't reproduce here

FirasH

2013-10-23 20:07

developer   ~0030769

I've uploaded 3 screenshots.
1) Shows the document when opened
2) Shows what happens when you send the red shape to "Inline Items"
3) Shows what happens if you select the text frame and move it down with down arrow

Hope it helps,
thank you

FirasH

2013-10-23 20:07

developer  

Scrapbook.zip (347,736 bytes)

FirasH

2013-11-17 13:04

developer   ~0030846

I've tried to reproduce the bug many times and the result is always the same:
Every time I select an item (like a shape used as background), and send it to inline items, it jumps over the others (until you click on the grey background of Scribus or click 2 times on one of the covered shapes).
If I give transparency to the background I'm able to see the shapes that have been covered.
Selecting the area which I can see of the covered shapes and moving one of them with arrows renders just a small area around it.

I've uploaded another file (InlineTest.zip) which contains a document and 3 schreenshots (same as the my previous comment).

FirasH

2013-11-17 13:04

developer  

InlineTest.zip (281,613 bytes)

JLuc

2013-11-17 19:54

developer   ~0030848

Last edited: 2013-11-17 22:51

View 2 revisions

i reproduce : there is a temporary bad display once the "send to inline" is performed, that disappear after the user clicks anywhere once or twice.

FirasH

2014-01-19 11:49

developer   ~0031142

The issue seems resolved with Qt 5.2.0, so if someone can confirm this I suggest to close it.

FirasH

2014-01-19 15:46

developer   ~0031147

Last edited: 2014-01-19 15:51

View 2 revisions

I wasn't 100% sure about this issue, so I tried harder to find the problem.
With Qt 5.2.0 the issue SEEMS resolved but I can reproduce it if I do the following steps:

0) Create a new document
1) Insert a shape as big as the page (even with smaller ones is reproducible)
2) Select the Shape and from Properties:
Colors > Fill: select "Green" + Transparency > Solid > Opacity: 50%
3) Insert another Shape (about 100mm x 100mm in the middle of the page) and give it this Properties:
Colors > Fill: select "Cyan"
4) Right click on the green Shape created previously and Send to > Inline Items
Now the green Shape is temporary over the cyan one: if you change the size of the Scribus window (and also the zoom) or click Extras > Update Document everything is normal but:
5) Select the cyan Shape which you can see due to the transparency of the green one and press one time "arrow up"
6) Re-send the green Shape to Inline Items
7) Re-select the cyan Shape and press one time "arrow up"
Only a small area around the cyan Shape is updated

The libraries I'm using are the default ones available from the openSUSE 13.1 repository except for the Qt libraries provided from the Qt official website.
Maybe JLuc can confirm what I wrote and if not this issue is probably caused by some libraries I'm using.

FirasH

2014-04-25 01:32

developer   ~0031808

Here's a video about this issue, recorded with
Scribus 1.5.0 SVN (19086) - Qt 5.2.1:
https://www.dropbox.com/s/u2f8i6732hctxgh/video.mkv
(the video quality on dropbox is not that good, if you download and play it looks much better)

Kunda

2015-09-19 23:44

manager   ~0036292

I can recreate the original issue on OSX 10.10.5 1.5.1 r20401 Qt5.5.0

Recreated by:
1) Drag/Drop Testing.sla in to Scribus
2) Click red background
3) Send to Inline item
4) Click on text frame
5) move text frame down with down arrow

Added Screencast

Kunda

2016-05-10 19:44

manager  

Kunda

2016-05-10 19:45

manager   ~0040952

Persists on 10.10.5 r21300 Qt5.6
attached screencast

Issue History

Date Modified Username Field Change
2013-10-22 21:46 FirasH New Issue
2013-10-22 21:46 FirasH File Added: Testing.sla
2013-10-23 19:25 fschmid Note Added: 0030767
2013-10-23 20:07 FirasH Note Added: 0030769
2013-10-23 20:07 FirasH File Added: Scrapbook.zip
2013-11-17 13:04 FirasH Note Added: 0030846
2013-11-17 13:04 FirasH File Added: InlineTest.zip
2013-11-17 19:54 JLuc Note Added: 0030848
2013-11-17 22:51 JLuc Note Edited: 0030848 View Revisions
2014-01-19 11:49 FirasH Note Added: 0031142
2014-01-19 14:16 fschmid Status new => resolved
2014-01-19 14:16 fschmid Fixed in Version => 1.5.0svn
2014-01-19 14:16 fschmid Resolution open => fixed
2014-01-19 14:16 fschmid Assigned To => fschmid
2014-01-19 14:17 fschmid Status resolved => closed
2014-01-19 15:46 FirasH Note Added: 0031147
2014-01-19 15:46 FirasH Status closed => feedback
2014-01-19 15:46 FirasH Resolution fixed => reopened
2014-01-19 15:51 FirasH Note Edited: 0031147 View Revisions
2014-04-25 01:32 FirasH Note Added: 0031808
2014-04-25 01:32 FirasH Status feedback => assigned
2014-07-15 01:03 FirasH Category Scrapbook => Canvas
2014-07-15 01:03 FirasH Summary Sending items to "Inline Items" causes wrong arrangement of levels (and render) => Sending items to "Inline Items" causes bad canvas render
2014-07-28 21:31 Kunda Target Version => 1.5.1
2015-09-19 23:44 Kunda Note Added: 0036292
2015-09-19 23:45 Kunda File Added: Inline-Item-Bug.mov
2015-09-20 17:43 JLuc Tag Attached: display
2015-09-20 17:43 JLuc Tag Attached: render frames
2015-09-20 17:43 JLuc Tag Detached: render frames
2016-01-23 17:16 cbradney Target Version 1.5.1 => 1.5.3
2016-05-10 19:32 Kunda Tag Attached: inline
2016-05-10 19:44 Kunda File Added: send-to-inline-artifacts.gif
2016-05-10 19:45 Kunda Note Added: 0040952
2016-05-10 19:46 Kunda File Deleted: Inline-Item-Bug.mov
2016-05-10 19:46 Kunda Tag Attached: artifacts
2016-05-10 19:47 Kunda Relationship added child of 0013075
2016-05-10 19:48 Kunda Patch => No
2016-05-10 19:48 Kunda Target Version 1.5.3 => 1.5.4.svn
2016-05-10 19:55 Kunda Fixed in Version 1.5.0svn =>
2018-04-30 13:17 jghali Target Version 1.5.4.svn => 1.5.5