View Issue Details

IDProjectCategoryView StatusLast Update
0014980ScribusPDFpublic2017-09-08 08:07
Reporterwiz Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status newResolutionopen 
Product Version1.5.3 
Target VersionFixed in Version 
Summary0014980: Switch scribus to use public poppler API
Descriptionscribus uses the xpdf compatibility API provided by poppler.

However, upstream poppler sees this as "unsupported" and changes it when and how they want, see e.g.
https://bugs.scribus.net/view.php?id=14979

Their view is that consumers should use one of the public APIs, i.e. the glib, qt4, qt5, or cpp ones.

Please switch scribus to use one of those. If the API provided by upstream does not fulfill scribus' needs, upstream is willing to talk
(https://lists.freedesktop.org/mailman/listinfo/poppler).

(I'm not upstream, I'm just a packager that would like to reduce future breakage.)
TagsNo tags attached.
PatchNo

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2017-09-08 08:07 wiz New Issue